"Bedingtes" Zählen

Antwort erstellen


Um automatische Eingaben zu unterbinden, musst du die nachfolgende Aufgabe lösen.

BBCode ist eingeschaltet
[img] ist ausgeschaltet
[flash] ist ausgeschaltet
[url] ist eingeschaltet
Smilies sind ausgeschaltet

Die letzten Beiträge des Themas
   

Ansicht erweitern Die letzten Beiträge des Themas: "Bedingtes" Zählen

Re: "Bedingtes" Zählen

von juhge » So, 08.10.2017 22:54

Super vielen Dank. Es lag damit nur am WOCHENTAG, bei dem ich eben von den Namen ausging und nicht vom Datum...

Wochenende gerettet...

Re: "Bedingtes" Zählen

von Mondblatt24 » So, 08.10.2017 17:36

Hallo,
Summenprodukt() hilft Dir weiter.

Gruß Peter
Dateianhänge
Nachtschicht.ods
(13.64 KiB) 17-mal heruntergeladen

Re: "Bedingtes" Zählen

von echo » So, 08.10.2017 17:29

Mein letzter Versuch war: =ZÄHLENWENN(UND(D4:D33;"Mitarbeiter1";B4:B33;WENN(WOCHENTAG(B4;2)>5)) für das bekomme ich aber Fehler 520
Hallo, versuche es mal so:
=SUMMENPRODUKT((D4:D33="Mitarbeiter1")*(WOCHENTAG(B4:B33;2)<5))
für Mo-Do
=SUMMENPRODUKT((D4:D33="Mitarbeiter1")*(WOCHENTAG(B4:B33;2)>=5))
für Fr.-So

Beachte das Wochentag() ein Datum auswertet.
in Spalte B darf daher nicht "Mi" als Text stehen, sondern es bedarf dort eins gültigen Datums. (Zellformat TTT)
Alternativ Spalte A verwenden.

Gruß Holger

"Bedingtes" Zählen

von juhge » So, 08.10.2017 14:08

Hallo,
ich verzweifle gerade an einer wahrscheinlich recht einfachen Aufgabe.

Ich möchte aus einem Dienstplan mit Tag-/ Spät-/ Nachtdiensten für jeden Mitarbeiter einzeln die Dienste zählen. Für die Spätdienste kein Problem =ZÄHLENWENN(C4:C33;"Mitarbeiter1").. Ich möchte jedoch die Nachtdienste aufteilen in Dienste von Mo bis Do und Fr bis So.

Meine bisherigen Versuche mit Vorlagen aus dem Forum sind bisher immer gescheitert, daher benötige ich Hilfe.
Mein letzter Versuch war: =ZÄHLENWENN(UND(D4:D33;"Mitarbeiter1";B4:B33;WENN(WOCHENTAG(B4;2)>5)) für das bekomme ich aber Fehler 520

Der Aufbau ist folgendermaßen:
| A | B | C | D | E
|Datum|Wochentag|Spätdienst|Nachtdienst|Wochenenddienst Tag|
|1.11. | Mi | |Mitarbeiter1| Mitarbeiter2 |
usw...

Vielen Dank für eure Hilfe..

Nach oben