Mittelwertbildung von 2024 Zeilen

Antwort erstellen


Um automatische Eingaben zu unterbinden, musst du die nachfolgende Aufgabe lösen.

BBCode ist eingeschaltet
[img] ist ausgeschaltet
[flash] ist ausgeschaltet
[url] ist eingeschaltet
Smilies sind ausgeschaltet

Die letzten Beiträge des Themas
   

Ansicht erweitern Die letzten Beiträge des Themas: Mittelwertbildung von 2024 Zeilen

Re: Mittelwertbildung von 2024 Zeilen

von paljass » Mi, 06.12.2017 06:39

Moin,
Alternativ zu Stephan:

Code: Alles auswählen

=SUMME(VERSCHIEBUNG($B$1;(ZEILE()-1)*5;0;5))/5
Gruß
paljass

Re: Mittelwertbildung von 2024 Zeilen

von Stephan » Di, 05.12.2017 19:18

schreibe in C1:

Code: Alles auswählen

=MITTELWERT(INDIREKT("B"&((ZEILE()-1)*5)+1&":B"&ZEILE()*5))
und ziehe runter bis C405


Gruß
Stephan

Mittelwertbildung von 2024 Zeilen

von Rifunger » Di, 05.12.2017 18:52

Mein Problem ist vielleicht nicht so einfach wie es im Betreff steht. Ich versuch mal zu erklären:
Ich habe eine Spalte mit circa 2025 Zeilen. Ich möchte jetzt jede fünf Zeilen zusammenfassen. Sprich den Mittelwert der ersten fünf Zeilen bilden und sie in eine Seperate Zeile einer anderen Spalte ausgeben. Dann in der darunter liegenden Zeile den Mittelwert der sechsten bis elften Zeile und so weiter.
Sodass ich am Ende die 2025 Zeilen auf 405 reduziert habe, wobei jede Zeile der Mittelwert von fünf Werten ist. Jeweils dann natürlich aufsteigend.

Mein Problem ist, ich möchte das jetzt natürlich nicht 405 in die Formelzeile eingeben. Ich habe es versucht für die ersten 15 Werte meiner Daten zu machen und dann diese drei Zellen zu markieren und sie runter zu ziehen. Aber er macht nicht das was er soll. Er pickt sich immer irgendwelche willkürliche startzeilen heraus und geht entsprechend fünf zeilen weiter.

Beispiel:
=MITTELWERT(B1:B6)
=MITTELWERT(B7:B11)
=MITTELWERT(B12:B17)
Und wenn ich diese drei Zellen gemeinsam markiere und herunter ziehe geht er so vor
=MITTELWERT(B9:B3)
=MITTELWERT(B5:B9)
=MITTELWERT(B14:B18)

Ich verstehe nicht wieso er das macht. Vor allem steckt dahinter irgendwie kein system. Warum fängt er plötzlich bei B5 an in der übernächsten Zeile?

Kann mir jemand bitte helfen?

Nach oben