[GELÖST] Nach Uhrzeit und Wert filtern

Antwort erstellen


Um automatische Eingaben zu unterbinden, musst du die nachfolgende Aufgabe lösen.

BBCode ist eingeschaltet
[img] ist ausgeschaltet
[flash] ist ausgeschaltet
[url] ist eingeschaltet
Smilies sind ausgeschaltet

Die letzten Beiträge des Themas
   

Ansicht erweitern Die letzten Beiträge des Themas: [GELÖST] Nach Uhrzeit und Wert filtern

Re: Nach Uhrzeit und Wert filtern

von johnfm » Sa, 03.11.2018 16:19

Perfekt! Das ist die Lösung!
Vielen vielen Dank euch allen!

Re: Nach Uhrzeit und Wert filtern

von Helmut_S » Fr, 02.11.2018 21:22

Hallo nochmal, es geht auch mit den Funktionen zählenwenn() u. zählenwenns(). Schau dir die Tabelle an und beherzige was Mondblatt24 geschrieben hat.
IMHO scheint mir zählenwenns() in diesem Fall logischer. Die Eingabe der Uhrzeit musst du aber entsprechend ändern.
Gruß Helmut
Dateianhänge
uhrzeit 2.ods
(11.44 KiB) 27-mal heruntergeladen

Re: Nach Uhrzeit und Wert filtern

von Mondblatt24 » Fr, 02.11.2018 20:40

Hallo,

Zeilen- und Spaltenanzahl der Bereiche müssen identisch sein.
Ist dies nicht der Fall, gibt SUMMENPRODUKT den Fehlerwert #WERT! zurück.

Gruß Peter

Re: Nach Uhrzeit und Wert filtern

von johnfm » Fr, 02.11.2018 17:17

Lieber Holger,
Du hast natürlich recht. Die Originaldatei ist allerdings sehr groß und umfangreich und den eigentlichen Sinn meiner Formel kann ich auch nur schwer in knappen Worten erklären.

Ich danke euch allen für eure Mühen. Ich habe viele gute Anregungen und Tipps aus euren Antworten gezogen und werde damit erstmal weiter experimentieren. Ich melde mich wieder - entweder mit der Lösung oder mit weiteren Fragen ;)

LG johnfm

EDIT:

Ich habe das Problem nicht gelöst, aber ich habe es in einer neuen Datei reproduzieren können. Das ist ja auch schon etwas. In der angehängten neuen Beispieldatei haben wir in Spalte B die Uhrzeiten, in den Spalten C - G die "Werte" (Rot, Gelb, etc.).

Die Formel

Code: Alles auswählen

=SUMMENPRODUKT($B$1:$B$6<=ZEIT(13;0;0))
und

Code: Alles auswählen

=SUMMENPRODUKT($C$1:$G$6=C8)
funktionieren beide. Die Kombination aus beiden Matrizen zu

Code: Alles auswählen

=SUMMENPRODUKT($B$1:$B$6<=ZEIT(13;0;0);$C$1:$G$6=C8)
hingegen liefert den Fehler #WERT! und zwar unabhängig davon, ob ich (13/24) oder ZEIT(13;0;0) einsetze.

In den von euch hochgeladenen Tabellen funktionieren die Formeln, das ist richtig. Warum bekomme ich das in meinen Tabellen nicht hin?
Dateianhänge
uhrzeit 2.ods
(11.58 KiB) 25-mal heruntergeladen

Re: Nach Uhrzeit und Wert filtern

von Helmut_S » Fr, 02.11.2018 17:08

Hallo johnfm, schau dir die Tabelle an, so müsste es passen. Ich habe die Datenbankbereiche gelöscht und den Spalten A + B einen Namen verpasst.
So funktioniert es auch mit 13/24. Achtung es könnte sein, dass ich ein paar Zeiten beim Probieren geändert habe.
Gruß, Helmut
Dateianhänge
uhrzeit.ods
(15.36 KiB) 26-mal heruntergeladen

Re: Nach Uhrzeit und Wert filtern

von Gast » Fr, 02.11.2018 16:27

Servus,
Wert als Text @.
Ein Wert ist eine Zahl.


Gast

Re: Nach Uhrzeit und Wert filtern

von echo » Fr, 02.11.2018 16:23

Hallo
(13/24) mußt du in Klammern setzen weil das Ergebnis das Suchkriterium ist. (13 von 24 Stunden)
machst du das nicht wird nach 13 (Tage) gesucht und das Ergebnis durch 24 dividiert, Da bei dir aber kein Wert über 1 (Tag) liegt wird natürlich nichts gefunden

Hellsehen ist schlecht, wie heißt die angepaßte Formel jetzt? Bitte hier rein kopieren!
Sind die Bezüge überall gleich groß? (meine Formel $A$1:$A$32 und $B$1:$B$32)

Gruß Holger

PS du mußt nicht die Originalliste hier rein kopieren aber wenn man sehen kann wo die Werte stehen sollte die Formel kein Problem sein.

Re: Nach Uhrzeit und Wert filtern

von johnfm » Fr, 02.11.2018 15:44

Ihr seid das geilste Forum der Welt =D =D

Vielen Dank für die Antworten! Der Teil ZEIT(13;0;0) funktioniert, die Variante 13/24 komischerweise nicht.

Aber Achtung: In der Tabelle, in der ich die Formel dann wirklich verwende, erhalte ich als Ausgabe die Meldung "#WERT!". Das bedeutet laut help.libreoffice.org:
Die Formel ergibt einen Wert, der nicht der Definition entspricht, oder eine in der Formel referenzierte Zelle enthält Text anstelle einer Zahl.
Wenn ich beide Teilstücke mittels ZÄHLENWENN "teste" (also ZÄHLEWENN Zeit <= 13 Uhr und ZÄHLEWENN Wert = D3), erhalte ich korrekte Ergebnisse. Auch wenn ich nur je einen Teil in SUMMENPRODUKT einsetze, stimmt das Ergebnis. Nur bei beiden zusammen in der SUMMENPRODUKT-Formel bekomme ich die Fehlermeldung #WERT!

Ohne jetzt die richtige Tabelle hochzuladen, könnt ihr mir helfen, in welcher Richtung ich nach dem Fehler gucken soll? Ich habe die Zellen für Zeit als "Uhrzeit" HH:MM formatiert, die Zellen für Wert als Text @.

Ich habe die Formel exakt aus Holgers Antwort herauskopiert und auch händisch neu eingetippt, immer dasselbe.

Re: Nach Uhrzeit und Wert filtern

von echo » Do, 01.11.2018 20:33

Hallo
wenn du 13:00:00 in "" setzt ist das Text und keine Zahl, in Spalte A stehen aber Zahlenwerte (Uhrzeiten)
entweder du baust den Text in eine Berechnung ein ("13:00:00"*1) oder
du verendest gleich den Wert der dazu paßt (13/24 oder Zeit(13;0;0)

=SUMMENPRODUKT($A$1:$A$32<=Zeit(13;0;0);$B$1:$B$32=D3)

Gruß Holger

Re: Nach Uhrzeit und Wert filtern

von Lupo1 » Do, 01.11.2018 20:27

13/24 statt "13:00:00" mal probieren

[GELÖST] Nach Uhrzeit und Wert filtern

von johnfm » Do, 01.11.2018 19:41

Hallo liebe Forumsgemeinde,

ich brauche mal wieder eure fantastische Hilfe. Die FoSu hat nichts ergeben... Ich möchte eine Reihe von Werten nach den korrelierenden Uhrzeiten auswerten. Beispieldatei hängt an.

ich habe eine Tabelle mit zwei Spalten: In A2 - A70 sind verschiedene wiederkehrende Uhrzeiten eingetragen (Datenfeld "Zeit"), in B2 - B70 verschiedene wiederkehrende Begriffe (z.B. Rot, Blau, Gelb) (Datenfeld "Wert"). Ich möchte nun herausfinden, wie oft die einzelnen Werte ROT, BLAU und GELB innerhalb bestimmter Zeitfenster aufgelistet sind, z.B. wie oft "Rot" vor 13 Uhr auftaucht.

Bisher habe ich mit SUMMENPRODUKT herumprobiert, aber mir scheint, dass die Formel nicht mit Uhrzeiten klar kommt?

Meine Formel sieht so aus:

Code: Alles auswählen

=SUMMENPRODUKT(Zeit<="13:00:00";Wert="Rot")
Im Ergebnis spuckt die Formel aber nur die Gesamtzahl des Ereignisses "Rot" aus, ohne den Bezug zur Zeit.
Habe ich die Zellen falsch formatiert oder hätte ich eine andere Funktion wählen sollen?
Bin für jede Hilfe dankbar!

LG johnfm
Dateianhänge
uhrzeit.ods
(11.8 KiB) 32-mal heruntergeladen

Nach oben