"E-Porto Add-In" der Deutsche Post AG in OpenOffice nutzen?

Das Textverarbeitungsprogramm

Moderator: Moderatoren

Gast

Re: "E-Porto Add-In" der Deutsche Post AG in OpenOffice nutz

Beitrag von Gast » Fr, 09.11.2012 12:35

Hallo,

Nachtrag:
http://www.deutschepost.de/dpag?tab=1&s ... 70_1022369
deutschepost hat geschrieben:JavaTM Runtime Version 1.6 empfohlen,

PabloXavier
Beiträge: 3
Registriert: Fr, 09.11.2012 01:37

Re: "E-Porto Add-In" der Deutsche Post AG in OpenOffice nutz

Beitrag von PabloXavier » Fr, 09.11.2012 17:28

Hallo,

erstmal vielen Dank für die Hilfestellung.

Meine Java-Version
1.7.0_09 build b05
Wie gesagt auf dem aktuellem Stand. Vorversion war 1.6... und da hat es auch schon nicht mit "Eporto" funktioniert.

Muss ich wohl oder übel mit MS Word weiterarbeiten, denn damit funktioniert es.

Hat sonst vlt. noch jemand eine Idee?

Schöne Grüße -Pablo-

Gast

Re: "E-Porto Add-In" der Deutsche Post AG in OpenOffice nutz

Beitrag von Gast » Fr, 09.11.2012 17:52

Hallo Pablo,
Hat sonst vlt. noch jemand eine Idee?
Ich würde mich an deiner Stelle an die Post wenden, wie es bisher ein paar andere getan haben.

Je mehr Leute das tun, desto größer ist die Chance,
dass die Post diese Erweiterung für OO verbessert und etwas dafür tut,
das sie nicht nur mit Word nutzbar ist.

PabloXavier
Beiträge: 3
Registriert: Fr, 09.11.2012 01:37

Re: "E-Porto Add-In" der Deutsche Post AG in OpenOffice nutz

Beitrag von PabloXavier » Fr, 09.11.2012 18:02

Hallo,

naja mit der Post kann man ja immer noch tun aber evt. liegt es ja auch an meiner Rechnerkonfiguration? Mann kennt das ja, wenn man längere Zeit seinen PC nicht neu aufsetzt, ist irgendwann das System zugemüllt und kann dann auch zu gewissen Fehlermeldungen führen, die bei einem "frischen" System funktionieren würden.

Oder funktioniert das Addon generell nicht mit OpenOffice?

Wenn dem so wäre, dann brauch ich ja nicht länger rumfummeln und hier im Forum damit nerven...

Ich werde mal übers Wochenende meinen Laptop mit OO füttern, das System ist noch relativ "frisch" und dann schau ich mal ob es dort funktioniert.

Bis später,

Schöne Grüße -Pablo-

Gast

Re: "E-Porto Add-In" der Deutsche Post AG in OpenOffice nutz

Beitrag von Gast » Fr, 09.11.2012 18:36

Hallo Pablo,
Oder funktioniert das Addon generell nicht mit OpenOffice?
Naja, in den z.Z. vier Seiten dieses Themas gibt es einige Erfahrungsberichte damit.
Wenn du alles durchliest ...

Hier zum Beispiel liest man, dass es funktioniert - theoretisch
http://www.it-consulting-lorenz.de/elek ... penoffice/

Und hier auf der Malingliste von LibreOffice wurde eher von Problemen damit berichtet
http://thread.gmane.org/gmane.comp.docu ... rman/13880

Stefan Lorenz

Re: "E-Porto Add-In" der Deutsche Post AG in OpenOffice nutz

Beitrag von Stefan Lorenz » Fr, 09.11.2012 19:54

Da ich der Verfasser des oben genannten Beitrages bin, kann ich bestätigen das es auch praktisch funktioniert. ;-)
Unter Linux konnte ich das Plugin mit der Oracle-Version von Java installieren und nutzen. Startet man LibreOffice mit dem OpenJDK in der Konsole sieht man, dass sich das Plugin mit dem Zertifikat-Server von Oracle verbinden will um sicherzustellen das es sich um das "echte" Java handelt. Das schlägt beim OpenJDK dementsprechend fehl.

Leider verlangsamt der Einsatz von Oracle-Java-7 LibreOffice sehr stark, das sind auch die Probleme von denen in dem anderen Thread berichtet wird. Das ist aber kein Problem des Plugins sondern ein Problem von LibreOffice/OOo ivm Java.
Startet man LibreOffice bzw OOo mit der Java-Version wird ein Kern komplett ausgelastet. Die Ursache dafür ist mir aber auch nicht bekannt.
Aktuell habe ich deshalb einen etwas umständlichen Workflow, ich schreibe meine Briefe vor, dann aktiviere ich die Erweiterung nach einem Wechsel auf Java 7 in den Optionen und einem Neustart um dann das Porto einzufügen. Ist aber immer noch bequemer als immer neue Marken zu kaufen.
Ich bleibe da aber dran und berichte mal von meinen Erfahrungen mit der Beta von Java 8.

bodo000
Beiträge: 1
Registriert: So, 02.12.2012 19:04

Re: "E-Porto Add-In" der Deutsche Post AG in OpenOffice nutz

Beitrag von bodo000 » So, 02.12.2012 20:07

Runtime Error!
Program C:\Program Files\White Label Office3\soffice.bin
This application has requested the Runtime to terminate it in an unusual way.
Please contract the application´s support team for more information
Bei mir sieht die Meldung ähnlich aus:
"Microsoft Visual ++ Runtime Libary
Runtime error!
Program: C:\Program Files\OpenOffice.org3\program\soffice.bin
This application... (s. oben)

So danach wird das Programm geschlossen; wenn ich dann neu starte, wird die Wiederherstellung aufgerufen und das Dokument wieder angezeigt. Einloggen in Eporto geht ohne Problem. Auch "Eporto hinzufügen" geht, nur Drucken über Menü geht nicht, und das Spiel geht von vorne los.

Dieser Fehler tritt auf wenn ich im Menü auf Drucken klicke. Gehe ich in der Symbolleiste auf das Druckersymbol, kommt die Meldung nicht. :?

Please application's support team take on the problem!

TPunkt

Re: "E-Porto Add-In" der Deutsche Post AG in OpenOffice nutz

Beitrag von TPunkt » Fr, 22.11.2013 15:08

Ich bekomme beim versuch das Plugin zu starten folgende Fehlermeldung (mit Plugin Version 1.0.2 und Open Office 4.01)

---------------------------
OpenOffice 4.0.1 - Fatal Error
---------------------------
[jni_uno bridge error] UNO calling Java method queryDispatch: non-UNO exception occurred: java.lang.NullPointerException
java stack trace:
java.lang.NullPointerException

at de.deutschepost.ooeporto.EPortoStarter.queryDispatch(Unknown Source)


---------------------------
OK
---------------------------

pmoegenb
********
Beiträge: 4330
Registriert: Di, 22.06.2004 12:02
Wohnort: 71134 Aidlingen
Kontaktdaten:

Re: "E-Porto Add-In" der Deutsche Post AG in OpenOffice nutz

Beitrag von pmoegenb » Fr, 22.11.2013 16:18

TPunkt hat geschrieben:Ich bekomme beim versuch das Plugin zu starten folgende Fehlermeldung (mit Plugin Version 1.0.2 und Open Office 4.01)

---------------------------
OpenOffice 4.0.1 - Fatal Error
---------------------------
Siehe viewtopic.php?f=1&t=62125
Gruß

Peter
---------------------------------------------------------------------------
Windows 7 Prof. 64-bit SP1, LibreOffice 4.3.6.2 und AOO 4.1.1

gast freedom

Re: "E-Porto Add-In" der Deutsche Post AG in OpenOffice nutz

Beitrag von gast freedom » Do, 06.02.2014 18:38

http://thread.gmane.org/gmane.comp.docu ... rman/11361
das Thema lief auf der Mailingliste von LibreOffice.

Beinhalter den Trick, um das Add-In 1.02 in den AOO/LO-Versionen nutzen kann, für die es nicht gedacht ist
=> und auch den Link zur Version 1.0.3, die auf "aktuellen Versionen" AOO und LO lauffähig sein soll (laut Post)

gast freedom

Re: "E-Porto Add-In" der Deutsche Post AG in OpenOffice nutz

Beitrag von gast freedom » Do, 06.02.2014 19:15

Ops, mein Fehler.
Die Post nennt AOO/LO Versionen 3.* aktuell. Also doch nicht für Writer 4.+.

Aber der Trick, der auf der Mailingliste beschrieben ist, sollte helfen. Immerhin.
(Benutzer von Writer 4.* gaukeln dem Add-In vor, mit Writer 3.* zu arbeiten)

Peter B-L
**
Beiträge: 36
Registriert: Di, 29.08.2006 19:40
Wohnort: Kerpen

Re: "E-Porto Add-In" der Deutsche Post AG in OpenOffice nutz

Beitrag von Peter B-L » Sa, 08.02.2014 10:51

Hallo ,

ich habe OO 4.01, XP SP3, Java 7.51.

E-Porto Add-In 1.02 war nicht mehr installiert. Also 1.03 (für OO) nur installiert. Wie es ausschaut funktioniert es. Bist "Testdruck" bin ich gekommen. Auch Bilder einfügen in einem Text funktioniert wieder.

PeterB-L

Andreas s.

Re: "E-Porto Add-In" der Deutsche Post AG in OpenOffice nutzen?

Beitrag von Andreas s. » So, 06.01.2019 14:53

Das Add-In wird von der Deutschen Post noch für OpenOffice zum download angeboten, funktioniert jedoch nicht.
Antwort der Post: ´Der Service wurde seit Monaten eingestellt.` Um das zu erfahren muss man sich jedoch erst bei der Portokasse anmelden und mindestens 10,00€ einzahlen. Danach kann man der Post schreiben was man will, keine Reaktion mehr.
Also Finger weg!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

nikki
******
Beiträge: 731
Registriert: Do, 05.03.2015 10:42

Re: "E-Porto Add-In" der Deutsche Post AG in OpenOffice nutzen?

Beitrag von nikki » Mo, 07.01.2019 10:57

Andreas s. hat geschrieben:
So, 06.01.2019 14:53
Das Add-In wird von der Deutschen Post noch für OpenOffice zum download angeboten, funktioniert jedoch nicht.
Das ist eigenartig, zumal die Deutsche Post AG folgendes angibt:

Von der Deutschen Post wurden die folgenden Systeme getestet und für eine einwandfreie Funktionalität empfohlen:

1. Aktuelle OpenOffice Writer Version (ab Version 4.1) mit folgenden Betriebssystemen

MacOS 10.X
Microsoft Windows 7, 8, 8.1 oder 10
Linux

2. Eine mit OpenOffice kompatible JavaTM Runtime Version.
Download: Java SE Downloads

nur kurzer Hinweis:
ich hatte bereits gestern getestet und das Add-In ansich funktionierte bei mir rein technisch einwandfrei (AOO 4.1.6), nicht sagen kann ich hingegen ob die Anbindung der Porto-Funktion, seitens der Post funktioniert, da ich dort kein Konto für e-Porto besitze.
Falls jemand mehr weiß, dann bitte gerne dazu einen neuen Thread eröffnen.

Stephan
Gruß

---------------------------------------------------------
Win.10 Prof. 64-bit, AOO 4.1.6, LO 6.2.4 (x64)

Gesperrt