PDF-Erzeugung geht nicht

Das Textverarbeitungsprogramm

Moderator: Moderatoren

AvN
**
Beiträge: 38
Registriert: So, 07.08.2016 00:46

PDF-Erzeugung geht nicht

Beitrag von AvN » So, 22.01.2017 18:16

Liebe Forumsuser,

eigentlich kenne ich das mit der PDF-Erzeugung ja, früher schaffte ich das auch, aber heute klappt es gar nicht. Wenn ich "als PDF exportieren" mache und PDF 1-a1 erzeugen will (oder andere), dann bekomme ich zwar eine PDF-Datei, aber da sind nur wirre Zeichen drauf, in Schrift Arial, zwar irgendwie an den Stellen, wo auch im Dokument Schrift steht, aber ansonsten nicht lesbar (ohne Sinn).

Was habe ich nun wieder falsch gemacht, daß es nicht klappt? Ich hatte als Schriften ja Times benutzt; vielleicht ist die Schrift nicht richtig ins Dokument eingebettet, aber wo kann man das regeln? In der Open-Office-Hilfe kommt nichts wenn ich "Schriftarten einbetten" suche.

Grüße
AvN

freedom
********
Beiträge: 2146
Registriert: Do, 16.08.2007 15:12

Re: PDF-Erzeugung geht nicht

Beitrag von freedom » So, 22.01.2017 19:57

Hallo,
dann bekomme ich zwar eine PDF-Datei, aber da sind nur wirre Zeichen drauf,
mit welchem PDF-Lese-Programm öffnest du das?

AvN
**
Beiträge: 38
Registriert: So, 07.08.2016 00:46

Re: PDF-Erzeugung geht nicht

Beitrag von AvN » So, 22.01.2017 20:01

Mit Acrobat-Reader. Das ging auch bei meinen älteren (1 Jahr alt) erzeugten OOo-PDFs, die kann man problemlos lesen. Nur jetzt klappt es nicht mehr. Ich habe auch ein OOo Dokument, was ich vor einem Jahr problemlos exportieren konnte, noch einmal exportiert, es war nun auch nicht mehr lesbar.
Irgendeine Einstellung in den Registerkarten der PDF-Exportierung müßte es demnach sein.

AvN

Ich habe auch bemerkt, daß die nicht lesbare PDF gering kleiner ist (62.000), als die vor einem Jahr vom gleichen Dokument erzeugte lesbare PDF (64.000). Irgendetwas fehlt also. Vielleicht die Schrifteinbettung?

freedom
********
Beiträge: 2146
Registriert: Do, 16.08.2007 15:12

Re: PDF-Erzeugung geht nicht

Beitrag von freedom » So, 22.01.2017 21:30

OOo Dokument, was ich vor einem Jahr problemlos exportieren konnte, noch einmal exportiert, es war nun auch nicht mehr lesbar.
Hast du vielleicht innerhalb dieses Jahres auf eine andere Version von AdobeReader gewechselt?
Irgendeine Einstellung in den Registerkarten der PDF-Exportierung
Wir wissen nicht, welche Einstellungen du im PDF-Export-Dialog vorgenommen hast.
Gehe einmal alle Registerkarten durch und schreib auf, was aktiviert war und was nicht.
Vielleicht die Schrifteinbettung?
Im PDF-Reader gibt es wahrscheinlich Datei-Eigenschaften-Schriften oder sinngemäß ähnlich.
Schau, ob dir da was auffällt.

Einfache Hilfe ist schwierig, eigentlich kann man in diesem Fall nur raten.
In der Open-Office-Hilfe kommt nichts wenn ich "Schriftarten einbetten" suche.
Dann klicke im Export-Dialog auf Schaltfläche "Hilfe". Bringt dich das weiter?

AvN
**
Beiträge: 38
Registriert: So, 07.08.2016 00:46

Re: PDF-Erzeugung geht nicht

Beitrag von AvN » So, 22.01.2017 22:03

Im PDF-Reader gibt es wahrscheinlich Datei-Eigenschaften-Schriften oder sinngemäß ähnlich.
Schau, ob dir da was auffällt.
Ja, da steht gar nichts drin, während bei dem, das funktioniert, dort Schriften verzeichnet sind.
Hast du vielleicht innerhalb dieses Jahres auf eine andere Version von AdobeReader gewechselt?
Nein, Reader 11.0.08.
Wir wissen nicht, welche Einstellungen du im PDF-Export-Dialog vorgenommen hast.
Gehe einmal alle Registerkarten durch und schreib auf, was aktiviert war und was nicht.
Allgemein: "Alles", "Verlustfreie Komprimierung", X bei "PDF A-1a" (auch der Versuch mit X bei "Tagged PDF" klappte nicht), X bei "Lesezeichen exportieren", X bei "Kommentare exportieren" und X bei "Automatisch eingefügte Leerseiten exportieren".

Anfangsdarstellung: X bei "Seiten-Fenster und Seite", X bei "Standard" und X bei "Fortlaufend Doppelseiten".

Benutzeroberfläche: X bei "Dokumenttitel anzeigen", X bei "Alle Lesenzeichenebenen".

Verknüpfungen: X bei "Lesezeichen als benannte Ziele exportieren", X bei "Dokumentreferenzen in PDF-Ziele umwandeln", X bei "URLs relativ zum Dateisystem exportieren", X bei "Standardverhalten".

Sicherheit: (hier ist nichts aktiv).
Dann klicke im Export-Dialog auf Schaltfläche "Hilfe". Bringt dich das weiter?
Nein, das hatte ich schon alles gelesen. Ich hatte natürlich auch andere Möglichkeiten ("PDF-Formular erzeugen") geprobt.

Es scheint so, daß die verwendeten Schriften nicht mit exportiert werden. Woran kann das liegen, wo es doch vor zwei Monaten, Anfang Dezember, noch ging? Irgendetwas muß sich verändert haben.

Grüße
AvN

freedom
********
Beiträge: 2146
Registriert: Do, 16.08.2007 15:12

Re: PDF-Erzeugung geht nicht

Beitrag von freedom » So, 22.01.2017 22:19

PDF 1-a1
Dabei sollen Schriften eingebettet sein, sagt auch die Hilfe.

OpenOffice Version ist auch noch die selbe wie vor 1Jahr? Welche Version du hast - wissen wir noch nicht.
Bei aktueller 4.1.3 ist ein solcher Bug meines Wissens nicht bekannt.

LibreOffice hat die Option "Schriften einbetten", wenn das Rätsel nicht gelöst wird, probier es damit.
Portable Version braucht keine Installation und ist schnell wieder entfernt.

AvN
**
Beiträge: 38
Registriert: So, 07.08.2016 00:46

Re: PDF-Erzeugung geht nicht

Beitrag von AvN » So, 22.01.2017 22:38

Ich habe die Version 3.4.1. Wie gesagt, im Dezember ging es noch, jetzt geht es nicht mehr, mit demselben Programm. Ich versuche es nun noch einmal und schalte dazu mein Anti-Virenprogramm aus, möglicherweise verhindert das das Exportieren der Schriften. Viel Hoffnung habe ich nicht.

LibreOffice? Ein anderes Schriftprogramm? Wenn ich damit das Dokument einlese, bleiben dann die Formatierungen, Seitenumbrüche, Bilder im Text erhalten?

Also am Virenprogramm lag es auch nicht. Ich finde auch bei den aktuellen Versuchen, eine PDF zu erzeugen immer eine weitere Datei dabei, die so bezeichnet ist: .~lock.Titel des Dokuments.odt#
Sind da vielleicht die fehlenden Schriften extra gespeichert? Man kann sie nicht öffnen (weil nach dem Programm zum Öffnen gefragt wird).

Würde ein Update auf eine neuere OOo Version helfen? Oder würde die mir gleich wieder alle Formatierungen des Dokuments verändern?

AvN

freedom
********
Beiträge: 2146
Registriert: Do, 16.08.2007 15:12

Re: PDF-Erzeugung geht nicht

Beitrag von freedom » So, 22.01.2017 22:56

.~lock.
Sobald OpenOffice eine Datei öffnet, erstellt es im gleichen Verzeichnis diese versteckte Datei.
Sie kennzeichnet die Datei als "bereits geöffnet".
Daran kann eine andere Person (Kollege...)erkennen, dass die Datei gerade in Verwendung ist,
und er sie z.Z. nur lesend öffnen kann.

Du sagst, es hat sich nichts verändert, was Versionen betrifft.
Dann ist vielleicht dein Benutzerverzeichnis beschädigt. Benenne es probehalber um,
beim nächsten Start wird es neu erstellt, mit Standardeinstellungen.
https://wiki.documentfoundation.org/UserProfile/de
(tausche gedanklich libre gegen open)

AvN
**
Beiträge: 38
Registriert: So, 07.08.2016 00:46

Re: PDF-Erzeugung geht nicht

Beitrag von AvN » So, 22.01.2017 23:17

Bei Windows XP: unter \Dokumente und Einstellungen\<Benutzername>\Anwendungsdaten\libreoffice\3\user (LibreOffice 3)
LibreOffice oder OpenOffice\3\ oder ähnliches gibt es da bei mir nicht.
Wichtig: Der Ordner "AppData" ist normalerweise versteckt.
So einen Ordner gibts da nicht (versteckte werden bei mir angezeigt). Und war soll ich mit dem machen?
Schließen Sie alle LibreOffice-Instanzen. Achtung: Auch der Schnellstarter aus der Systemleiste muss geschlossen werden, vergewissern Sie sich ggf. mit Hilfe des Task-Managers, dass keine LibreOffice-Instanzen mehr aktiv sind.
"Schnellstarter schließen?" Keine Ahnung, wie das geht.
Benennen Sie den Ordner um, in dem sich Ihr Benutzerprofil befindet, z.B. von user nach user-old. Löschen Sie auf keinen Fall den Ordner; möglicherweise benötigen Sie die Daten des Profils (z.B. Ihre Dokumentvorlagen) im weiteren Verlauf noch.
"Benutzerprofil" oder einen entsprechenden Ordner habe ich nie gesehen.
Starten Sie LibreOffice neu. LibreOffice erstellt ein neues Benutzerprofil.
Überprüfen Sie, ob Ihr Problem dadurch gelöst wurde.
Leider überfordert mich das völlig.

AvN

AvN
**
Beiträge: 38
Registriert: So, 07.08.2016 00:46

Re: PDF-Erzeugung geht nicht

Beitrag von AvN » So, 22.01.2017 23:36

Ich habe es doch geschafft, diese Anleitung umzusetzen. Es wurde tatsächlich ein neuer Ordner erzeugt, doch die PDF-Erzeugung geht immer noch nicht, immer noch die fehlenden Schriften.

Was nun?
AvN

freedom
********
Beiträge: 2146
Registriert: Do, 16.08.2007 15:12

Re: PDF-Erzeugung geht nicht

Beitrag von freedom » So, 22.01.2017 23:43

Dass OpenOffice nur bei PDF A-1a Schriften einbettet - erinnerst du dich noch? Siehe meine Antwort von 23:19

AvN
**
Beiträge: 38
Registriert: So, 07.08.2016 00:46

Re: PDF-Erzeugung geht nicht

Beitrag von AvN » Mo, 23.01.2017 00:50

Dass OpenOffice nur bei PDF A-1a Schriften einbettet
Hatte ich auch probiert, klappte leider auch nicht.

AvN

AvN
**
Beiträge: 38
Registriert: So, 07.08.2016 00:46

Re: PDF-Erzeugung geht nicht

Beitrag von AvN » Mo, 23.01.2017 13:54

Ich habe jetzt die alte Version von OOo entfernt und OOo 4.1.3 installiert. Dann habe ich probeweise das Exportieren als PDF gemacht, wobei ich die Voreinstellungen belassen habe, da sie nach meinem Wissen richtig waren. Ergebnis: Wieder fehlen die Schriften im PDF-Dokument.

Was kann man nun noch machen?

AvN

AvN
**
Beiträge: 38
Registriert: So, 07.08.2016 00:46

Re: PDF-Erzeugung geht nicht

Beitrag von AvN » Mo, 23.01.2017 15:46

Am Schluß blieb nur, OpenOffice zu vergessen und die PDF mit "PdfPrinter" zu erzeugen, einem Programm, was man für 19 Euro bekommt.
Damit ging es nun endlich.

AvN

Stephan
********
Beiträge: 10116
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: PDF-Erzeugung geht nicht

Beitrag von Stephan » Di, 24.01.2017 10:14

Was kann man nun noch machen?
Das OO-Benutzerverzeichnis umbenennen:
viewtopic.php?f=27&t=54231#p206070


Gruß
Stephan

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 16 Gäste