Leseproblem von docx mit OO 3.1 unter Debian

spezielle Probleme mit AOO/LO unter Linux

Moderator: Moderatoren

SabineSW
Beiträge: 7
Registriert: Mo, 07.02.2005 21:55
Wohnort: München

Leseproblem von docx mit OO 3.1 unter Debian

Beitrag von SabineSW » Fr, 18.09.2009 11:09

Hallo!

Wenn ich hier in der Arbeit auf meinem Rechner unter Debian (testing) versuche, mit OO 3.1 irgendeine docx-Datei zu öffnen, kommt nur folgende Fehlermeldung: "Leseproblem. Von der Datei konnte nicht gelesen werden." oder auf Englisch "Read error. Data could not be read from file."

Daheim (ebenfalls Debian (testing) und OO 3.1) funktioniert es dagegen problemlos. Wo kann da der Unterschied sein?

Ich habe schon länger gesucht, aber keine Lösung gefunden, obwohl ich einiges ohne Erfolg ausprobiert habe.
Viele Grüße

Sabine

Barlee
******
Beiträge: 767
Registriert: Sa, 17.12.2005 12:27

Re: Leseproblem von docx mit OO 3.1 unter Debian

Beitrag von Barlee » So, 20.09.2009 20:11

Hallo Sabine,
Wo kann da der Unterschied sein?
Grund sind vermutlich unterschiedlich verwendete Varianten (forks) von OOo. Go-OO kann bspw. docx öffnen.

Gruß Barlee

SabineSW
Beiträge: 7
Registriert: Mo, 07.02.2005 21:55
Wohnort: München

Re: Leseproblem von docx mit OO 3.1 unter Debian

Beitrag von SabineSW » So, 20.09.2009 22:53

Hallo Barlee,
Barlee hat geschrieben:Grund sind vermutlich unterschiedlich verwendete Varianten (forks) von OOo. Go-OO kann bspw. docx öffnen.
Das kann es nicht sein. Die /etc/apt/sources.list sind auf allen Rechnern identisch, es werden also die gleichen Pakete installiert.
Viele Grüße

Sabine

Barlee
******
Beiträge: 767
Registriert: Sa, 17.12.2005 12:27

Re: Leseproblem von docx mit OO 3.1 unter Debian

Beitrag von Barlee » So, 20.09.2009 23:50

Hallo Sabine,

sind die installierten Pakete auf beiden Rechnern identisch? Könnte sein, dass die Filter nicht installiert sind (Paket: OpenOffice_org-filters - Import and Export Filters for OpenOffice.org)

Gruß Barlee

hol.sten
******
Beiträge: 871
Registriert: Fr, 18.11.2005 21:21

Re: Leseproblem von docx mit OO 3.1 unter Debian

Beitrag von hol.sten » Mo, 21.09.2009 17:08

SabineSW hat geschrieben:Die /etc/apt/sources.list sind auf allen Rechnern identisch, es werden also die gleichen Pakete installiert.
Aber nur, wenn auch die gleichen Pakete ausgewählt wurden.

SabineSW
Beiträge: 7
Registriert: Mo, 07.02.2005 21:55
Wohnort: München

Re: Leseproblem von docx mit OO 3.1 unter Debian

Beitrag von SabineSW » Mo, 21.09.2009 20:36

Hallo Barlee,
Barlee hat geschrieben:sind die installierten Pakete auf beiden Rechnern identisch? Könnte sein, dass die Filter nicht installiert sind (Paket: OpenOffice_org-filters - Import and Export Filters for OpenOffice.org)
Es sind aufgrund der verschiedenen Anforderungen auf den Rechnern jeweils zusätzliche Pakete installiert, da die beiden Rechner unterschiedliche Aufgaben zu bewältigen haben. Das von Dir erwähnte Paket gibt es bei Debian nicht. Auf beiden Rechnern sind alle vorhandenen Filterpakete installiert:
ii openoffice.org-filter-binfilter 1:3.1.1-1
ii openoffice.org-filter-mobiledev 1:3.1.1-1

Bestimmt liegt es an einem fehlenden Paket, aber welchem?
Viele Grüße

Sabine

SabineSW
Beiträge: 7
Registriert: Mo, 07.02.2005 21:55
Wohnort: München

Re: Leseproblem von docx mit OO 3.1 unter Debian

Beitrag von SabineSW » Mo, 21.09.2009 20:38

hol.sten hat geschrieben:
SabineSW hat geschrieben:Die /etc/apt/sources.list sind auf allen Rechnern identisch, es werden also die gleichen Pakete installiert.
Aber nur, wenn auch die gleichen Pakete ausgewählt wurden.
Da habe ich mich wohl mißverständlich ausgedrückt. Es ging um verschiedene Varianten von OOo, die Barlee erwähnt hat. Ist die sources.list identisch, werden auch die gleichen OO-Pakete installiert.
Viele Grüße

Sabine

Antworten