LO 3.3.1 64bit Base sehr träge

spezielle Probleme mit AOO/LO unter Linux

Moderator: Moderatoren

Linuxkommunist
***
Beiträge: 56
Registriert: Mi, 20.08.2008 17:44

LO 3.3.1 64bit Base sehr träge

Beitrag von Linuxkommunist » Sa, 05.03.2011 13:18

Hallo!

Seit der Umstellung auf LibreOffice unter Ubuntu 10.10 ist das Base-Modul extrem träge und fast unbenutzbar. Eine meiner Datenbanken mit ca. 4200 Datensätzen zu durchsuchen dauert fast 6 Minuten, dabei sind nur drei simple Tabellenverknüpfungen in der verwendeten Abfrage enthalten. Beim Laden der Datenbank gönnt sich LO zudem noch eine ca. 30-sekündige Denkpause.

Da ich ein 64bit-Ubuntu nutze, habe ich auch die 64bit-DEBs von LO installiert, die verwendete JVM ist die aktuelle von Sun bzw. Oracle - OpenJDK hatte ich entfernt, weil ich dies zuerst in Verdacht hatte. Da ich mit der Datenbank zuletzt im August zu tun hatte und mit der damals noch installierten OOo-Version keine Probleme auftraten, kann ich nicht genau sagen, mit welchem Wechsel der Fehler ins System kam.

Ein Test mit der 32bit-Version von LO unter XP (auch Oracle JVM) zeigt, dass dort alles butterweich funktioniert - keine Startverzögerung, Durchsuchen der DB ist in wenigen Sekunden erledigt.

Falls jemand eine Lösung für dieses Problem kennt, wäre ich dankbar, wenn man mir diese mitteilt :-)

Schönes Wochenende,
Frank

Gast

Re: LO 3.3.1 64bit Base sehr träge

Beitrag von Gast » Sa, 05.03.2011 13:34

Hallo Frank,

auch auf Ubuntu 10.10-64bit kannst du LO-32bit nutzen,
dann brauchst du auch JRE-32bit.

Jedenfalls denke ich, dass nichts dagegen spricht.
http://wiki.ubuntuusers.de/64bit-Architektur

Linuxkommunist
***
Beiträge: 56
Registriert: Mi, 20.08.2008 17:44

Re: LO 3.3.1 64bit Base sehr träge

Beitrag von Linuxkommunist » Sa, 05.03.2011 13:45

Hallo Gast,

dass auch 32bit-Binaries laufen ist mir bekannt, hatte aber gehofft, ohne ein solches "Downgrade" auszukommen - für das Java-Plugin im Browser bräuchte ich ja dann auch wieder diesen fürchterlichen Wrapper etc. Andererseits ist das Booten von Windows (ob real oder in einer VM) sicher auch keine attraktive Lösung... werde mal sehen.

Dank und Gruß,
Frank

Linuxkommunist
***
Beiträge: 56
Registriert: Mi, 20.08.2008 17:44

Re: LO 3.3.1 64bit Base sehr träge

Beitrag von Linuxkommunist » Mi, 12.09.2012 08:26

Nachtrag: dieses Problem besteht schon länger nicht mehr. Abhilfe brachte die Unterstützung von Java 7 durch LO, damit war die Trägheit verschwunden

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste