Seite 1 von 1

[gelöst] Zeile erkennen, wo Wert das nächste Mal auftritt

Verfasst: Mi, 10.10.2012 11:13
von FM_81
Hallo alle zusammen!
Ich komme einfach nicht drauf, OO-calc V 3 unter Linux:
Spalte A enthält Zahlen von 0 bis 6. Wenn der Wert in Spalte A=1 ist, soll in Spalte B die Nummer der Zeile sein, wo in Spalte A der nächste Einser-Wert ist.

Code: Alles auswählen

1	5
3	
6
2
1	7
0
1	10
3
3
1	#Fehler
Ob dort, wo es keinen nächsten Einser-Wert mehr gibt, ein Fehler ausgegeben wird, ist egal.

Vielen Dank, FM_81
PS: Dass es wahrscheinlich über eine Matrix-Funktion geht, ist mir klar, aber mir fehlt einfach der Ansatz ... :(

Re: Zeile erkennen, wo Wert das nächste Mal auftritt

Verfasst: Mi, 10.10.2012 11:55
von juetho
Wenn ich das richtig sehe, musst du die Suche auf einen Bereich einschränken: In Zeile 1 suchen innerhalb von A2:A1000, in Zeile 5 innerhalb von A6:A1000 - allgemein ab Zeile n suchen innerhalb von A(n+1):A1000. Dafür gibt es geeignete Funktionen, siehe in der Calc-Hilfe unter "Funktionen für Tabellen".

Ich habe den Eindruck, dass SVERWEIS (eine Matrixfunktion) einfacher ist, habe damit aber noch keine Erfahrung. Gruß Jürgen

Re: Zeile erkennen, wo Wert das nächste Mal auftritt

Verfasst: Mi, 10.10.2012 12:45
von tobi90
Hallo FM_81,

teste mal, ob die Formel

Code: Alles auswählen

=WENN(A1=1;VERGLEICH(1;A2:A$10;0)+ZEILE(A1);"")
deinen Erwartungen entspricht. Du kannst sie in Zelle B1 kopieren und dann nach unten ausfüllen - in der letzten vorkommenden Zeile (hier 10) wird ein Fehler ausgegeben.


Viele Grüße

Re: Zeile erkennen, wo Wert das nächste Mal auftritt

Verfasst: Mi, 10.10.2012 13:04
von FM_81
Vielen Dank!
Das Letzte von tobi90 funktioniert!

Manchmal sieht man den Wald vor Bäumen nicht; vor Jahren hatte ich nämlich eine ähnliche Frage hier gestellt, nur daß damals die Referenzierung quasi nach "oben" statt wie jetzt nach "unten" ging! Und da hatte man mir hier im Forum mit einer Matrixformel geholfen; deshalb hing ich so in diesem "Gedankengerüst" fest.

Danke & Gruß, FM_81