OpenOffice unter ROSA-Linux

spezielle Probleme mit AOO/LO unter Linux

Moderator: Moderatoren

enrico65
Beiträge: 4
Registriert: So, 08.04.2018 17:51

OpenOffice unter ROSA-Linux

Beitrag von enrico65 » So, 08.04.2018 17:59

Hallo allerseits,

ich nutze bei mir und meinen Kunden auch unter Linux (i.d.R. ROSA Desktop Fresh 8.1 und 10) immer noch OpenOffice. Leider lässt sich die jeweils aktuelle Variante schon seit Version 4.0 nicht mehr unter ROSA Linux installieren, so dass ich seither notgedrungen mit OpenOffice 3.2.1 arbeite (die letzte funktionstüchtige Variante unter ROSA Linux). Nun steht demnächst eine größere Migration auf HP-Workstations von Windows auf Linux an, und es wird auch wieder ROSA Desktop Fresh werden. Allerdings klappt es mit OpenOffice auch mit Version 4.1.5 nicht mit ROSA Linux. Die Suite lässt sich installieren, startet jedoch nicht. Ist das Problem bekannt und gibt es eine Lösung?

Gruß
enrico65

Stephan
********
Beiträge: 10596
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: OpenOffice unter ROSA-Linux

Beitrag von Stephan » So, 08.04.2018 18:30

Ich höre von dieser Linux-Distribution heute das allererste Mal. Bei uns bei der ProOO-Box (http://www.prooo-box.org/) gibt es aber jemanden der sich mit Installation/Installationsskripten für verschiedene LInuxe befasst, ich frage mal nach ob der etwas weiß und schreibe das Ergebnis hierin den Thread.


Gruß
Stephan

Stephan
********
Beiträge: 10596
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: OpenOffice unter ROSA-Linux

Beitrag von Stephan » So, 08.04.2018 21:13

Rückfragen:
Welche Version von ROSA-Linux nutzt ihr, 32 oder 64Bit?
Welche Meldung erhaltet ihr bei der Installation von OO-Version 4.0 oder höher, wenn ihr in der Konsole den Befehl soffice eingebt?
Welche Desktopumgebung?


Gruß
Stephan

enrico65
Beiträge: 4
Registriert: So, 08.04.2018 17:51

Re: OpenOffice unter ROSA-Linux

Beitrag von enrico65 » Di, 24.04.2018 20:14

@Stephan:

Danke erst einmal für die Mühe!

Bei ROSA-Linux handelt es sich um diese Distribution hier:

http://www.rosalab.com/

Bei Golem besprochen hier:

https://www.golem.de/news/linux-distrib ... 13271.html

Die Probleme mit OpenOffice und ROSA R8-R10 treten unter den 64 Bit-Varianten auf. Ich habe inzwischen auch bei der neuen Migration wieder OpenOffice 3.2.1 installiert, da es mit ROSA R10 und OpenOffice 4.1.5 ebenfalls nicht klappt. Die Desktopumgebung spielt dabei keine Rolle. Wir haben das Problem unter allen genutzten Desktop-Varianten nachvollziehen können, also KDE Plasma 5, KDE SC 4.14 und LXQt. Andere Desktops habe ich hier nicht im Einsatz. Wegen der genauen Fehlermeldung muss ich noch mal ein Testsystem installieren. Wenn ich mich recht erinnere, war es ein Segmentation Fault.

Gruß
enrico65

Stephan
********
Beiträge: 10596
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: OpenOffice unter ROSA-Linux

Beitrag von Stephan » Di, 24.04.2018 20:55

ich hatte Deine Frage weitergeleitet und ebenso die Rückfragen wie der hier in den Thread geschrieben. Da Du Dich 16(!) Tage nicht gemeldet hast, ist derjenige den ich um Hilfe gebeten hatte davon ausgegangen das Du Dich nicht mehr meldest. Ich glaube nicht das der nun nochmals einen erneuten Anlauf macht. Sorry.


Gruß
Stephan

enrico65
Beiträge: 4
Registriert: So, 08.04.2018 17:51

Re: OpenOffice unter ROSA-Linux

Beitrag von enrico65 » Mi, 25.04.2018 22:56

Ja, die Problematik stand bei mir nicht ganz oben auf der Prioritätenliste wegen meiner derzeit sehr hohen Arbeitsbelastung (auch "dank" der DSGVO), deshalb die späte Rückmeldung. Die Migration beim Kunden ist inzwischen erfolgreich abgeschlossen. Dass wir keine Lösung für OpenOffice 4.x parat haben, ist daher nicht so gravierend, mit OpenOffice 3.2.1 arbeitet das System ja einwandfrei. Es hat dahingehend auch keine Beschwerden von Mitarbeitern gegeben wegen der etwas rustikaler wirkenden Oberfläche von OO 3.2.1, und die neueren Dokumente konnten zu meiner eigenen Überraschung selbst bei anspruchsvoller Formatierung 1:1 übernommen werden nach Installation eines zusätzlichen Fonts, so dass wir damit erst einmal zufrieden sind.

Gruß
enrico65

Stephan
********
Beiträge: 10596
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: OpenOffice unter ROSA-Linux

Beitrag von Stephan » Mo, 30.04.2018 18:15

So, mein Kontakt von der ProOO-Box schreibt mir heute Folgendes zu Deinem Problem:

"nachdem sich der Fragende doch noch gemeldet hat, mein Kommentar.

Es tritt die Fehlermeldung:

.../soffice: Zeile 121: .... Speicherzugriffsfehler (Speicherabzug geschrieben) "$sd_prog/$sd_binary" "$@"

auf.

Wobei die Punkte Pfade bzw. Fehlereinträge meines Rechners ersetzen.
Hierbei handelt es sich um einen Bug im Kernel.

Pikant dabei ist, dass der gleiche Fehler unter OpenSuSe im letzten Jahr aufgetreten ist.
Bug 1045340 (Speicherverarbeitung in Verbindung mit Java).

Bug ist behoben und OpenOffice läuft unter SuSe."



Gruß
Stephan

enrico65
Beiträge: 4
Registriert: So, 08.04.2018 17:51

Re: OpenOffice unter ROSA-Linux

Beitrag von enrico65 » Sa, 05.05.2018 12:52

Hallo,

ich danke für die Mitteilung und werde das jetzt so weitergeben. Mal sehen, ob der Fehler behoben wird. Falls Rückmeldung kommt, werde ich diese hier posten.

Gruß
enrico65

Antworten