Aktuelles Datum einfügen und fixieren

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Didi1964er

Aktuelles Datum einfügen und fixieren

Beitrag von Didi1964er » Mi, 30.03.2011 11:51

Hallo zusammen,
ich hoffe, ich bekomme schnelle Hilfe, denn eigentlich ist es sicherlich ein ganz simples Problem.
Ich habe eine Tabelle erstellt, in der ich Werte am aktuellen Datum eintrage. Ich habe also eine Spalte, in der in der obersten Zelle das momentane Datum und die Zeit eingetragen werden soll.
Formatiert habe ich die Zelle : "NN, TT.MM.JJ, HH:MM" und wenn ich einen Eintrag in der Spalte mache, also das Datum brauche, schreibe ich die Formel "=JETZT ()" in die Zelle.
Soweit sogut, aber wie kann ich die Zelle jetzt gegen Veränderung schützen? Das eingetragene Datum soll nicht wieder verändert werden können. Also irgendwie fixieren, oder so.
Ich habe jetzt schon eine Weile die Suche bemüht, aber ich scheine den Wald vor lauter Bäumen nicht zu sehen, denn dies müßte doch ein alltägliches Problem sein?!?

Vielen Dank im Voraus

Dirk

Benutzeravatar
komma4
********
Beiträge: 5331
Registriert: Mi, 03.05.2006 23:29
Wohnort: Chon Buri Thailand Asia
Kontaktdaten:

Re: Aktuelles Datum einfügen und fixieren

Beitrag von komma4 » Mi, 30.03.2011 12:02

Einfachster Weg: STRG+C (kopieren) dann STRG+Umschalt+V (Inhalte einfügen): Alles, ausser Formeln

Da das wirklich ein "alltägliches Problem ist, wurde das natürlich auch schon vor langer Zeit gelöst:
meine Extension (s.u.) installieren und Tastenkombinationen zuweisen.
Dann geht das Einfügen von Datum (oder Zeit oder Zeitstempel) in jedem gewünschten Format auch in Writer... 8)
Cheers
Winfried
aktuell: LO 5.3.5.2 30m0(Build:2) SUSE rpm, unter Linux openSuSE Leap 42.3 x86_64/KDE5
DateTime2 Einfügen von Datum/Zeit/Zeitstempel (als OOo Extension)

clag
********
Beiträge: 3532
Registriert: Di, 27.01.2009 15:30

Re: Aktuelles Datum einfügen und fixieren

Beitrag von clag » Mi, 30.03.2011 12:40

Hallo Didi1964er

folgende Formel habe ich vor einiger Zeit hier im Forum entdeckt

zB in A2 geschrieben, fixiert die Formel hin A2 den aktuellen Wert von JETZT(),
wenn die Referenzzelle B2 von "leer" auf einen Inhalt wechselt

A2=WENN(B2="";"";WENN(A2="";JETZT();A2))

hat mir schon oft geholfen, vielleicht ja auch dir :D
LG
clag

nutzt: WinXP SP3 / AOO 4.1.2 / Firefox

Didi1964er

Re: Aktuelles Datum einfügen und fixieren

Beitrag von Didi1964er » Mi, 30.03.2011 13:26

Vielen Dank für die schnellen Tipps, mir ist geholfen :-) :-)

LG Dirk

Besucher

Re: Aktuelles Datum einfügen und fixieren

Beitrag von Besucher » Sa, 08.09.2012 18:36

Bei mir führt die Formel zu Err:522!!!
Da würde mich doch wirklich mal eine Beispiel-Tabelle interessieren!

Gruß,

JeannieS

Gast

Re: Aktuelles Datum einfügen und fixieren

Beitrag von Gast » Sa, 08.09.2012 18:52

Da würde mich doch wirklich mal eine Beispiel-Tabelle interessieren!
es wäre hilfreich, von dir ein Beispieldokument zu bekommen,
um sehen zu können, warum es bei dir nicht funktioniert.
- anmelden
- Dokument hochladen
Err:522
du hast sicher in der Hilfe geschaut, was diese Fehlermeldung besagt??

Benutzeravatar
lorbass
********
Beiträge: 4102
Registriert: Mo, 01.05.2006 21:29
Wohnort: Bonn

Re: Aktuelles Datum einfügen und fixieren

Beitrag von lorbass » Sa, 08.09.2012 19:10

Besucher hat geschrieben:Da würde mich doch wirklich mal eine Beispiel-Tabelle interessieren!
Das machen wir hier eigentlich immer anders rum: Der-/Diejenige, der/die ein Problem hat, lädt hier ein Beispieldokument hoch und bekommt dann die Korrektur in Textform und/oder als korrigierte Beispieldatei. ;) Dies dürfte insbesondere dann der Fall sein, wenn der Thread schon betagt ist, denn dann müssten sich dessen Protagonisten wieder in das Problem einarbeiten – wenn sie überhaupt noch am Geschehen hier teilnehmen…

Beachte bitte auch die Allgemeinen Hinweise zur Forumsbenutzung, die in jedem Unterforum ganz oben stehen. :?

Vorab: Fehler 522 zeigt eine Zirkuläre Referenz an.

Gruß
lorbass

matlat
***
Beiträge: 86
Registriert: Sa, 03.03.2007 13:51

Re: Aktuelles Datum einfügen und fixieren

Beitrag von matlat » Sa, 08.09.2012 19:20

A2=WENN(B2="";"";WENN(A2="";JETZT();A2))
Die Formel trägt das aktuelle Datum ein, wenn sich in B2 der Wert ändert.
Solange sich der Wert in B2 nicht mehr ändert, bleibt das Datum auch in den nächsten Tagen erhalten.
Um keinen Fehler angezeigt zu bekommen, muss unter EXTRAS/OPTIONEN/CALC/BERECHNEN
bei 'zirkuläre Referenzen' der Haken bei 'Iterationen' gesetzt werden.

paljass als Gast

Re: Aktuelles Datum einfügen und fixieren

Beitrag von paljass als Gast » So, 09.09.2012 10:14

Hi,
Die Formel trägt das aktuelle Datum ein, wenn sich in B2 der Wert ändert.
Mal ausprobiert? Funktioniert nämlich nicht. Wenn in B2 schon ein Wert steht, muss der zuerst gelöscht werden. Erst wenn das Feld leer ist und ein neuer Wert eingetragen wird, ändert sich das Datum.

Gruß
paljass

Gast

Re: Aktuelles Datum einfügen und fixieren

Beitrag von Gast » So, 22.04.2018 14:43

Es funtioniert. Super. Danke.

skunky4711
Beiträge: 6
Registriert: So, 26.07.2015 13:47

Re: Aktuelles Datum einfügen und fixieren

Beitrag von skunky4711 » Fr, 27.04.2018 00:01

@clag

super Formel. Danke dafür.

Antworten