Syntax in WENN Funktion

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Officeclerk
***
Beiträge: 64
Registriert: Mo, 21.01.2013 14:06

Syntax in WENN Funktion

Beitrag von Officeclerk » Di, 02.12.2014 15:24

Hallo zusammen,

ich möchte eine einfache WENN-Funktion verwenden, wobei der Wert "x" geprüft werden soll.

Laut OO-Hilfe gilt:
WENN(Prüfung; DannWert; SonstWert)
Prüfung ist ein beliebiger Wert oder Ausdruck, der WAHR oder FALSCH sein kann.


So sieht die Funktion bei mir aus:

Code: Alles auswählen

=WENN(C3='x';F3*-1;F3*1)
Wird "x" durch eine Zahl ersetzt, dann funktioniert es- ich würde aber gerne das "x" nehmen, da die betreffende Spalte eine Art "Ankreuzspalte" ist, in der zwischen zutreffend und nicht zutreffend ausgewählt werden kann.

Eine Datei habe ich auch hochgeladen

Ach ja: wenn, wie in Zeile 4, in Spalte C nichts steht, dafür aber in B, dann muss ich da natürlich noch eine Fallunterscheidung machen, das ist klar.


Der
Officeclerk
Dateianhänge
Wenn Test.ods
(10.17 KiB) 37-mal heruntergeladen
OS: Windows 7 auf der EeeBox und AMD-No-Name ATX-PC, Lubuntu und XP auf dem EeePC, MacOS 7.1 auf dem Powerbook
Officepaket: Apache OpenOffice 4.1.2

Benutzeravatar
miesepeter
*******
Beiträge: 1643
Registriert: Sa, 10.05.2008 15:05
Wohnort: Bayern

Re: Syntax in WENN Funktion

Beitrag von miesepeter » Di, 02.12.2014 15:33

Hallo,

setze x in doppelte Anführungszeichen, so wie "x".
Ich würde auch noch den Multiplikanden (-1) in Klammern schreiben, obwohl Calc das ohne Klammern wohl versteht...

Ciao

Officeclerk
***
Beiträge: 64
Registriert: Mo, 21.01.2013 14:06

Re: Syntax in WENN Funktion

Beitrag von Officeclerk » Di, 02.12.2014 16:00

Hallo miesepeter,

es funzt! :)
Danke

Damit ich da besser geistig folgen kann:

miesepeter hat geschrieben:
setze x in doppelte Anführungszeichen, so wie "x".
Warum ist das so und wo kann man das im größeren Kontext nachlesen?
Merkwürdig ist, dass die einfachen Anführungszeichen automatisch durch calc zum einfachen x ergänzt wurden- eigentlich müsste man ja dann davon ausgehen können, dass das so richtig ist... :?
miesepeter hat geschrieben: Ich würde auch noch den Multiplikanden (-1) in Klammern schreiben, obwohl Calc das ohne Klammern wohl versteht...
Versteht es :)

Gruß
Officeclerk
OS: Windows 7 auf der EeeBox und AMD-No-Name ATX-PC, Lubuntu und XP auf dem EeePC, MacOS 7.1 auf dem Powerbook
Officepaket: Apache OpenOffice 4.1.2

Karolus
********
Beiträge: 7063
Registriert: Mo, 02.01.2006 19:48
Kontaktdaten:

Re: Syntax in WENN Funktion

Beitrag von Karolus » Di, 02.12.2014 16:15

Hallo
Mein Vorschlag wäre

Code: Alles auswählen

=F3*WENN(C3="x";-1;1) 
Die einfachen ' werden benötigt um Referenzen mit Leerzeichen im Namen zu quoten, litereraler Text in Formeln braucht immer doppelte Anführungszeichen drumrum.
AOO4, LO4.3, LO4.4 LinuxMint17.2

Officeclerk
***
Beiträge: 64
Registriert: Mo, 21.01.2013 14:06

Re: Syntax in WENN Funktion

Beitrag von Officeclerk » Di, 02.12.2014 20:25

Hallo,
Karolus hat geschrieben:

Code: Alles auswählen

=F3*WENN(C3="x";-1;1) 
Das sieht elegant aus :-)
Ich wusste gar nicht dass man einen Operator wie * vor die Formel insgesamt stellen kann
Karolus hat geschrieben:Die einfachen ' werden benötigt um Referenzen mit Leerzeichen im Namen zu quoten, litereraler Text in Formeln braucht immer doppelte Anführungszeichen drumrum.
OK; gibt es zu dieser Art von Syntay irgendwo eine gute Zusammenfassung?

Danke

vom Officeclerk
OS: Windows 7 auf der EeeBox und AMD-No-Name ATX-PC, Lubuntu und XP auf dem EeePC, MacOS 7.1 auf dem Powerbook
Officepaket: Apache OpenOffice 4.1.2

TrueColor
******
Beiträge: 542
Registriert: Do, 11.03.2010 11:23

Re: Syntax in WENN Funktion

Beitrag von TrueColor » Mi, 03.12.2014 14:34

Officeclerk hat geschrieben:Hallo,
Karolus hat geschrieben:

Code: Alles auswählen

=F3*WENN(C3="x";-1;1) 
Das sieht elegant aus :-)
Ich wusste gar nicht dass man einen Operator wie * vor die Formel insgesamt stellen kann
Du könntest auch schreiben: F3 * (WENN[...])
Damit wird das vlt. klarer. Jedoch liefert die WENN-Funktion schon ein Teilergebnis, also eine Zahl, somit sind die Klammern unnötig.
System:
Arbeit: Windows 7 (64 bit) + Apache OpenOffice 4.1.2 (AOO412m3), LibreOffice 4.1.4.2
Home: Windows 10 (64 bit) + Apache OpenOffice 4.1.2 (AOO412m3)

Karolus
********
Beiträge: 7063
Registriert: Mo, 02.01.2006 19:48
Kontaktdaten:

Re: Syntax in WENN Funktion

Beitrag von Karolus » Mi, 03.12.2014 14:40

Hallo

Oder umdrehen:

Code: Alles auswählen

=WENN(...) * F3
Karolus
AOO4, LO4.3, LO4.4 LinuxMint17.2

Antworten