Auswertung und Zählen von Menschen mit Geburtsdatum bestimmten BEreich

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

mwanangu
Beiträge: 2
Registriert: Do, 30.03.2017 09:18

Auswertung und Zählen von Menschen mit Geburtsdatum bestimmten BEreich

Beitrag von mwanangu » Do, 30.03.2017 09:41

Hallo!
ich muss in einer Tabelle alle Perseonen (Zellen) zählen, die zwischen 6 und 25 Jahren sind. Die Geburtsdaten sind alle in einer Spalte. Weiß jemand, wie ich das lösen kann? Über ZÄHLEWENNS bin ich nicht weitergekommen, weil das Datum oder die Zuordnung </> nicht verstanden wurde (Err: 501).

Vielen Dank!

Karolus
********
Beiträge: 7063
Registriert: Mo, 02.01.2006 19:48
Kontaktdaten:

Re: Auswertung und Zählen von Menschen mit Geburtsdatum bestimmten BEreich

Beitrag von Karolus » Do, 30.03.2017 10:08

Hallo

Code: Alles auswählen

=SUMMENPRODUKT( JAHRE( A1:A1000 ; HEUTE() ; 0 )>=6 ; JAHRE( A1:A1000 ; HEUTE() ; 0 )<=25 ) 
AOO4, LO4.3, LO4.4 LinuxMint17.2

mwanangu
Beiträge: 2
Registriert: Do, 30.03.2017 09:18

Re: Auswertung und Zählen von Menschen mit Geburtsdatum bestimmten BEreich

Beitrag von mwanangu » Do, 30.03.2017 12:41

Hallo Karolus,

vielen Dank für die schnelle Antwort.
Die vorgeschlagene Formel erscheint mir logisch, aber ich mache wohl irgendeinen Syntax-Fehler (Err:508)

Ich habe den Zellenbereich korrekt angepasst und in die Klammer das heutige Daum eingegeben, ausserdem habe ich es mal mit/mal ohne "HEUTE" versucht. Der entsprechende Zellbereich ist als "Datum" formatiert, die ERgebniszelle als Zahl (Standard).
immer Err 508
Muss ich noch die Leerzeichen rausnehmen?
oder was anderes?

Karolus
********
Beiträge: 7063
Registriert: Mo, 02.01.2006 19:48
Kontaktdaten:

Re: Auswertung und Zählen von Menschen mit Geburtsdatum bestimmten BEreich

Beitrag von Karolus » Do, 30.03.2017 13:17

Hallo

Die Formel funktioniert eigenartigerweise nur mit explizit gesetzter Matrix-option ?! im Formelassistenten.
Passe nur den Zellbereich an.

Bei Fehler #508 hast du vmtl. irgendwo eine Klammer unterschlagen?
AOO4, LO4.3, LO4.4 LinuxMint17.2

paljass
******
Beiträge: 640
Registriert: Do, 25.10.2012 07:25

Re: Auswertung und Zählen von Menschen mit Geburtsdatum bestimmten BEreich

Beitrag von paljass » Do, 30.03.2017 13:26

Hi,

Code: Alles auswählen

=SUMMENPRODUKT(DATUMDIF(A1:A12;HEUTE();"y")>=6;DATUMDIF(A1:A12;HEUTE();"y")<=25)
funktioniert zumindest in LO 5.3 ohne geschweifte Klammern.

Gruß
paljass
EDV ist wie U-Boot fahren - machst du ein Fenster auf, fangen die Probleme an.

Karolus
********
Beiträge: 7063
Registriert: Mo, 02.01.2006 19:48
Kontaktdaten:

Re: Auswertung und Zählen von Menschen mit Geburtsdatum bestimmten BEreich

Beitrag von Karolus » Do, 30.03.2017 13:37

paljass hat geschrieben:
Do, 30.03.2017 13:26
Hi,

Code: Alles auswählen

=SUMMENPRODUKT(DATUMDIF(A1:A12;HEUTE();"y")>=6;DATUMDIF(A1:A12;HEUTE();"y")<=25)
funktioniert zumindest in LO 5.3 ohne geschweifte Klammern.

Gruß
paljass
Ja - hier genauso.
Das ist ja das eigenartige, im Normalfall sorgt SUMMENPRODUKT implizit für die Matrix-auswertung aller inneren Formeln
AOO4, LO4.3, LO4.4 LinuxMint17.2

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 13 Gäste