Wenn in Zelle x Inhalt dann in Zelle y Datum von Zelle davor + 1 Tag

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Annna
Beiträge: 8
Registriert: Sa, 11.02.2017 11:31

Wenn in Zelle x Inhalt dann in Zelle y Datum von Zelle davor + 1 Tag

Beitrag von Annna » Do, 20.04.2017 19:52

Ich habe folgendes Problem:
In Zelle A1 steht eine Zahl. Die trägt man manuell ein. Reihe 1 ist zum Einfügen von Zahlen.
In Zelle B7 steht ein Datum. Das trägt man auch manuell ein.
Wenn nun in Zelle B1 eine Zahl eingetragen wird, soll in Zelle B7 das Datum von der Zelle davor (A7) plus 1 Tag stehen.
Beispiel:

A1: 5
A7: 15.03.2016

B1: 6
B7: 16.03.2016 (automatisch)

Dabei ist es mir wichtig, dass die Zelle danach keinen Eintrag enthält. Also das Problem ist nicht gelöst mit B7+1

Wie mache ich das?

Karolus
********
Beiträge: 7063
Registriert: Mo, 02.01.2006 19:48
Kontaktdaten:

Re: Wenn in Zelle x Inhalt dann in Zelle y Datum von Zelle davor + 1 Tag

Beitrag von Karolus » Do, 20.04.2017 20:11

Hallo

B7:

Code: Alles auswählen

=WENN(ISTLEER(B1);"";A7+1)
AOO4, LO4.3, LO4.4 LinuxMint17.2

Benutzeravatar
lorbass
********
Beiträge: 4015
Registriert: Mo, 01.05.2006 21:29
Wohnort: Bonn

Re: Wenn in Zelle x Inhalt dann in Zelle y Datum von Zelle davor + 1 Tag

Beitrag von lorbass » Do, 20.04.2017 20:22

Annna hat geschrieben:
Do, 20.04.2017 19:52
Dabei ist es mir wichtig, dass die Zelle danach keinen Eintrag enthält.
Welche Zelle? Wonach? B1 nachdem B7 berechnet worden ist?

Wie auch immer, alle Calc-Formeln wirken immer nur auf die Zelle, in der sie selbst stehen. Keine Calc-Formel in Zelle B7 ist in der Lage, den Wert der Zelle B1 zu manipulieren. Wenn du also (z.B.) B1 zurücksetzen willst, sobald B7 berechnet worden ist, musst du dies selbst programmieren. Hilfe dabei findest du im Bereich Makros und allgemeine Programmierung.

Gruß
lorbass

Antworten

Wer ist online?

Mitglieder in diesem Forum: paljass und 14 Gäste