[Geschlossen] TabellenAuswertung

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

EinHoffungsloserFall

[Geschlossen] TabellenAuswertung

Beitrag von EinHoffungsloserFall » Di, 25.04.2017 12:38

Hallo Helfende,
Ich habe ein Problem mit meiner Tabellenauswertung.
Ich habe eine Tabelle mit viele Zahlenwerten, aber auch LEER-Stellen. Eine Pivot-Tabelle mit Summenwerten hab ich auch schon angelegt.
Nun möchte ich aber seperat noch wissen wie viel Plus, bzw. Minus gemacht wurden. In der Pivot-Tabelle wird +und- ja direkt zusammen gerechnet
und ich kann nicht einfach das Endergebnis kopieren.

Da ich nicht weiß, wie man Screenshots hier einfügt, versuche ich die Tabelle mal in Worte zu fassen.
In der linken Spalte können Zahlen oder LEER-Felder sein.
Die rechte Zeile ist mit positiven oder negativen Zahlen bestückt.

Nun möchte ich alle rechten positiven Zellen zusammenrechnen, wo in der linken Spalte ein Wert steht.
Die, wo links ein LEER-Feld ist interessieren mich nicht.

Das gleiche dann für die rechten negativen Zellen, wo links ein Wert steht.
Auch hier interessieren mich die LEER-Felder nicht

Ich hoffe, dass irgendwer von euch mir bei der Lösung helfen kann, soweit es eine gibt. Habe schon diverse Foren durchsucht,
vllt bin ich aber auch einfach zu dumm....

Thomas Mc Kie
******
Beiträge: 879
Registriert: Mo, 12.04.2010 00:37

Re: TabellenAuswertung

Beitrag von Thomas Mc Kie » Di, 25.04.2017 13:27

Bitte eine kleine Beispieldatei erstellen, sonst müsste die sich jeder nachbasteln (ein Screenshot ist da nicht besser). Als angemeldeter Nutzer kannst du die dann auch an die Beiträge anhängen, ansonsten einen Filehoster nutzen.

Siehe auch
viewtopic.php?f=3&t=54568
--> Wie stelle ich ein Beispieldokument zur Verfügung (und wozu)?

Grüße

Thomas

TrueColor
******
Beiträge: 542
Registriert: Do, 11.03.2010 11:23

Re: TabellenAuswertung

Beitrag von TrueColor » Di, 25.04.2017 13:30

EinHoffungsloserFall hat geschrieben:
Di, 25.04.2017 12:38
Da ich nicht weiß, wie man Screenshots hier einfügt, versuche ich die Tabelle mal in Worte zu fassen.
Screenshot ist meist eine schlechte Idee, da man nicht unter die Haube gucken kann. Besser ist, eine ggf. gekürzte und anonymisierte Datei anzuhängen. Das kannst du als registrierter Benutzer machen, unter dem Textfeld --> Dateianhänge
EinHoffungsloserFall hat geschrieben:
Di, 25.04.2017 12:38
In der linken Spalte können Zahlen oder LEER-Felder sein.
Die rechte Zeile ist mit positiven oder negativen Zahlen bestückt.

Nun möchte ich alle rechten positiven Zellen zusammenrechnen, wo in der linken Spalte ein Wert steht.
Die, wo links ein LEER-Feld ist interessieren mich nicht.
Wie man das mit Pivot macht, kann ich dir leider nicht sagen. Mit SUMMENPRODUKT() könnte das z.B. wie folgt aussehen:

Die Summe der Positiven: =SUMMENPRODUKT((A1:A10<>"")*(B1:B10>0)*(B1:B10))
Die Summe der Negativen: =SUMMENPRODUKT((A1:A10<>"")*(B1:B10<0)*(B1:B10))
System:
Arbeit: Windows 7 (64 bit) + Apache OpenOffice 4.1.2 (AOO412m3), LibreOffice 4.1.4.2
Home: Windows 10 (64 bit) + Apache OpenOffice 4.1.2 (AOO412m3)

EinHoffungsloserFall

[Gelöst] TabellenAuswertung

Beitrag von EinHoffungsloserFall » Di, 25.04.2017 14:05

Vielen Dank für die schnellen Antworten
Falls ich mal wieder eine Frage habe, werde ich mich registrieren und eine Beispieldatei anhängen.

Wie es immer so ist, findet man die Lösung, obwohl man 2Tage danach gesucht hat, eine dreiviertel Stunde,
nachdem man einen Theard eröffnet hat....
Vielen Dank an dich @TrueColor, deine Variante funktioniert auf jeden Fall und kommt auf das gleiche richtige Ergebnis wie meine
=SUMMEWENNS('01.04.17'.D2:D49;'01.04.17'.D2:D49;">0";'01.04.17'.A2:A49;"<>")
=SUMMENPRODUKT(('01.04.17'.A2:A49<>"")*('01.04.17'.D2:D49>0)*('01.04.17'.D2:D49))

Damit kann dieser Theard geschlossen werden, wie ich das selber mache habe ich leider nicht verstanden, oder hilft es was, wenn ich den Betreff in dieser Antwort ändere, ich weiß es nicht....

Vielen Dank auf jeden Fall

Benutzeravatar
lorbass
********
Beiträge: 4014
Registriert: Mo, 01.05.2006 21:29
Wohnort: Bonn

[Geschlossen] Re: TabellenAuswertung

Beitrag von lorbass » Di, 25.04.2017 17:03

EinHoffungsloserFall hat geschrieben:
Di, 25.04.2017 14:05
hilft es was, wenn ich den Betreff in dieser Antwort ändere
Genau so. Das geht allerdings nur, wenn du dich zuvor registriert hast und aktuelle angemeldet bist.
Jetzt mache ich das für dich.

Gruß
lorbass

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 21 Gäste