Nach Datum sortieren bei 2 verschiedenen Datumsformaten.

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

vierviervier
*****
Beiträge: 240
Registriert: Mo, 10.05.2010 11:17

Nach Datum sortieren bei 2 verschiedenen Datumsformaten.

Beitrag von vierviervier » Mi, 26.04.2017 10:10

Guten Tag in die Runde,
altes Thema, aber habe unter den Beiträgen keine Lösung für mich gefunden:
möchte eine Spalte nach Datum sortieren.
Die Einträge haben 2 Formen
01.01.17 und 01.17
Spalte ist als Datum formatiert DD.MM.JJ.
Keine Hochkommas.

So kommt es zur Reihenfolge:
23.02.17
02.05.17
03.17

Am liebsten wäre mir eine Reihenfolge mit Ordnung nach Monat, wenn der Monat der gleiche ist zuerst die mit Tagangabe.
also z.B:
01.01.17
02.01.17
01.17
01.02.17
02.02.17
02.17

Hab es mit DATUMWERT($A2) probiert, da kommt bei mir "Err: 502".

Vielen Dank für Hilfe, vierviervier.
Windows 10
AOO 4.1.1 LO 4.4.7.2

Karolus
********
Beiträge: 7063
Registriert: Mo, 02.01.2006 19:48
Kontaktdaten:

Re: Nach Datum sortieren bei 2 verschiedenen Datumsformaten.

Beitrag von Karolus » Mi, 26.04.2017 10:31

Hallo

Du hast nicht verschiedene Datumsformate, sondern verschiedene Datentypen: Datum versus Text.

Code: Alles auswählen

=WENN(ISTTEXT(A2);DATUMWERT("28."&A2);A2)
AOO4, LO4.3, LO4.4 LinuxMint17.2

vierviervier
*****
Beiträge: 240
Registriert: Mo, 10.05.2010 11:17

Re: Nach Datum sortieren bei 2 verschiedenen Datumsformaten.

Beitrag von vierviervier » Mi, 26.04.2017 11:07

Hallo Karolus,
erst mal Danke für die Antwort. Habs eingesetzt und verstanden, funktioniert im Prinzip.
Noch ist ein kleiner Schönheitsfehler drin: Wenn ich Datums mit den Tagen 29. 10. 31. verwende, werden die dann hinter die per Formel auf 28. gesetzen Datums gesetzt.
Wir hätten dann:
20.05.17
05.17
29.05.17
was jetzt kein Drama wäre, aber vieleicht gibts dafür noch einen Kniff. Kann man einfach mit DATUMWERT("32."$A2) arbeiten? die Zeile wäre ja dann eh versteckt und würde nur für die Sortierfunktion genutzt. Oder kollidiert das dann mit dem Datumsformat?
Schöne Grüße, vierviervier.
Windows 10
AOO 4.1.1 LO 4.4.7.2

TrueColor
******
Beiträge: 542
Registriert: Do, 11.03.2010 11:23

Re: Nach Datum sortieren bei 2 verschiedenen Datumsformaten.

Beitrag von TrueColor » Mi, 26.04.2017 11:22

Vielleicht hilft dir das: https://help.libreoffice.org/Calc/EOMONTH/de

Ich hab's allerdings nicht getestet
System:
Arbeit: Windows 7 (64 bit) + Apache OpenOffice 4.1.2 (AOO412m3), LibreOffice 4.1.4.2
Home: Windows 10 (64 bit) + Apache OpenOffice 4.1.2 (AOO412m3)

Karolus
********
Beiträge: 7063
Registriert: Mo, 02.01.2006 19:48
Kontaktdaten:

Re: Nach Datum sortieren bei 2 verschiedenen Datumsformaten.

Beitrag von Karolus » Mi, 26.04.2017 11:24

Hallo

Code: Alles auswählen

=WENN(ISTTEXT(A2) ; MONATSENDE(DATUMWERT("01."&A2);0) +0,1 ; A2)
AOO4, LO4.3, LO4.4 LinuxMint17.2

vierviervier
*****
Beiträge: 240
Registriert: Mo, 10.05.2010 11:17

Re: Nach Datum sortieren bei 2 verschiedenen Datumsformaten.

Beitrag von vierviervier » Mi, 26.04.2017 11:28

Hallo,
war grade selber schon am tüfteln, die +0,1 soll dafür sorgen dass bei gleichem Datum von Formelgeneriertem und händischem Datum, das Formelgenerierte später sortiert wird, oder?
Werds testen und Rückmeldung geben.
Schon mal vielen Dank.
vierviervier.
Windows 10
AOO 4.1.1 LO 4.4.7.2

vierviervier
*****
Beiträge: 240
Registriert: Mo, 10.05.2010 11:17

[gelöst] Nach Datum sortieren bei 2 verschiedenen Datumsformaten.

Beitrag von vierviervier » Mi, 26.04.2017 11:37

Hallo,

getestet und für gut befunden. Der händische Monatsletzte ist vorne. Passt alles

Karolus, TrueColor, Vielen Dank (wieder mal).

vierviervier.
Windows 10
AOO 4.1.1 LO 4.4.7.2

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 16 Gäste