in meiner zelle ist eine Formel,aber es erscheint/steht makro?

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Forscher
*
Beiträge: 14
Registriert: So, 14.05.2017 11:28

in meiner zelle ist eine Formel,aber es erscheint/steht makro?

Beitrag von Forscher » So, 14.05.2017 11:47

das geht in allen zellen,wo eine formel zum rechnen steht,#Makro? wie bekomme ich das wieder weg?
leider Neuling mit LibreOffice Calc #MAKRO? hat jemand da eine Idee ?

Stephan
********
Beiträge: 10094
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: in meiner zelle ist eine Formel,aber es erscheint/steht makro?

Beitrag von Stephan » So, 14.05.2017 13:07

#MAKRO? ist eine Fehlermeldung die in die Zelle ausgegeben wird wenn in der Formel der Zelle ein Fehler auftritt. Im Konkreten handelt es sich wohl um einen Fehler der entsteht weil ein Teil der Formel als fehlende benutzerdefinierte Funktion interpretiert wird bzw. ein Teil der Formel eine fehlende benutzerdefinierte Funktion ist.

Ich kann das Szenario hier aber spontan nicht nachstellen, weshalb Du wohl die Formel Deiner Zelle posten musst, damit man genau sagen kann woran es liegt.


Gruß
Stephan

Forscher2

Re: in meiner zelle ist eine Formel,aber es erscheint/steht makro?

Beitrag von Forscher2 » So, 14.05.2017 14:20

danke für deine Antwort
du hast bestimmt recht !! jetzt das aber, ich habe 12 Tabellenblätter (Monate) und in allen zellen wo eine Formel steht (unterschiedliche Formeln)
Z.B.=SUMMENPRODUKT(($C6:$C36="Feiertag")*(WOCHENTAG($B$6:$B$36;2)<=5))*9,3 erscheint / steht #Makro?
die Formel funktioniert hab sie separat ausprobiert
ich habe nur ein einziges makro das aber nicht aktiv ist,jedenfalls nach den Wechsel auf Libre

Gruß Holger

Forscher
*
Beiträge: 14
Registriert: So, 14.05.2017 11:28

Re: in meiner zelle ist eine Formel,aber es erscheint/steht makro?

Beitrag von Forscher » So, 14.05.2017 15:40

Danke für die Antwort hab eine Lösung gefunden
wollte mit einer Formel die beweglichen Feiertage einfügen das ganze ist mit irgendwas kollidiert
ist doch gut wenn man eine Sicherung hat

Thema kann geschlossen werden

Gruß Holger

Stephan
********
Beiträge: 10094
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: in meiner zelle ist eine Formel,aber es erscheint/steht makro?

Beitrag von Stephan » Mo, 15.05.2017 07:25

ich habe nur ein einziges makro das aber nicht aktiv ist
Mit Makro hat die Fehlermeldung auch nichts zu tun, sondern mit benutzerdefinierter Funktion, ich schrieb es bereits. WEnn in der Fehlermeldung das Wort "Makro" verwendet wird dann nur deshalb weil es synonym für 'irgendwelchen Basic-Code' steht.


Gruß
Stephan

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 12 Gäste