wenn Funktion

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

speednetz
*
Beiträge: 16
Registriert: Mo, 03.01.2011 21:01

wenn Funktion

Beitrag von speednetz » Mo, 15.05.2017 20:21

Hallo
Habe da ein Problem hoffe es kann mir jemand helfen.

Ich habe A1 Datum Heute. nun möchte ich das sich das Datum ändert wenn Datum Heute ein Montag ist auf den Freitag der vor Woche.

Ich brauch also in Zelle A1wenn Dienstag;Mittwoch;Donnerstag;Freitag Datum Heute()-1.
Montag Datum Heute ()-3

Habe jetz schon mehreres ausprobiert bekomme es aber nicht hin.

Vieleicht kann mir ja jemand helfen.

Gruß speednetz

Benutzeravatar
miesepeter
*******
Beiträge: 1606
Registriert: Sa, 10.05.2008 15:05
Wohnort: Bayern

Re: wenn Funktion

Beitrag von miesepeter » Mo, 15.05.2017 20:50

in Zelle B1

Code: Alles auswählen

=WENN(WOCHENTAG(A1;2)>5;"Sa/So";WENN(WOCHENTAG(A1;2)>1;A1-1;WENN(WOCHENTAG(A1;2)=1;A1-3;"Eingabe prüfen")))
Sowas?
A1 Datum Heute
Dann kann man wohl als Bezug A1 nehmen, oder?

Wenn ich dein Anliegen recht verstanden habe (?):
Du brauchst also eine zweite Zelle (B1), die aus den Werten der ersten Zelle (A1) rechnet. Bei einer direkten Eingabe und folgenden Umwandlung in der selben Zelle könnte man m.E. nur eine bedingte Formatierung erzeugen, nicht jedoch einen zweiten Wert. Wäre vermutlich eine Endlosschleife.

speednetz
*
Beiträge: 16
Registriert: Mo, 03.01.2011 21:01

Re: wenn Fuktion

Beitrag von speednetz » Mo, 15.05.2017 22:08

Hallo noch mal.

Habe mich wahrscheinlich nicht richtig aus gedrückt.

Alls ich brauche in A1 Dienstag/Mittwoch/Donnerstag/Freitag das Datum vom vor Tag.

Und am Montag das Datum vom Freitag da vor.

Hoffe das es so besser verständlich ist.

Hoffe das mir jemand helfen kann.

Danke Speednetz

clag
********
Beiträge: 3523
Registriert: Di, 27.01.2009 15:30

Re: wenn Fuktion

Beitrag von clag » Di, 16.05.2017 06:40

Moin speednetz,

schreibe in A1 folgende Formel

Code: Alles auswählen

=WENN(WOCHENTAG(HEUTE();2)=1;HEUTE()-3;WENN(WOCHENTAG(HEUTE();2)<6;HEUTE()-1;""))
damit sollte dein Wunsch erfüllt werden.
LG
clag

nutzt: WinXP SP3 / AOO 4.1.2 / Firefox

Karolus
********
Beiträge: 7063
Registriert: Mo, 02.01.2006 19:48
Kontaktdaten:

Re: wenn Fuktion

Beitrag von Karolus » Di, 16.05.2017 11:45

Hallo

Code: Alles auswählen

=HEUTE()-1-(WOCHENTAG(HEUTE();2)=1)*2

Code: Alles auswählen

=HEUTE()-WENN(WOCHENTAG(HEUTE();2)=1;3;1)
AOO4, LO4.3, LO4.4 LinuxMint17.2

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 13 Gäste