Wenn-Funktion mit Zeichenlänge

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Perceptron

Wenn-Funktion mit Zeichenlänge

Beitrag von Perceptron » Mi, 31.05.2017 23:46

Hallo,

ich habe eine Spalte mit verschiedenen Zahlenwerten, die als Text behandelt werden sollen. Einige davon sind 2-stellig, und einige davon 3-stellig. Bei den 2-stelligen soll nun in einer neuen Spalte, damit diese Werte ebenfalls 3-stellig sind, eine 0 davor gesetzt werden.

Bisher bin ich auf =WENN(LÄNGE(A1)<3;"0"+A1) gekommen, aber irgendwie scheint das nicht zu funktionieren.

Kennt jemand den richtigen Befehl?

Danke & viele Grüße,

P.

Benutzeravatar
komma4
********
Beiträge: 5331
Registriert: Mi, 03.05.2006 23:29
Wohnort: Chon Buri Thailand Asia
Kontaktdaten:

Re: Wenn-Funktion mit Zeichenlänge

Beitrag von komma4 » Mi, 31.05.2017 23:55

Zahlenwerte als Text behandeln geht mit derFunktion WERT

Code: Alles auswählen

=WENN(LÄNGE(A1)<3;"0"&WERT(A1);"")
Das Ergebnis ist TEXT !

Warum formatierst Du die Zellen nicht so, dass sie eine führende Null anzeigen?
Cheers
Winfried
aktuell: LO 5.3.5.2 30m0(Build:2) SUSE rpm, unter Linux openSuSE Leap 42.3 x86_64/KDE5
DateTime2 Einfügen von Datum/Zeit/Zeitstempel (als OOo Extension)

Perceptron

Re: Wenn-Funktion mit Zeichenlänge

Beitrag von Perceptron » Do, 01.06.2017 11:27

Super, vielen Dank, mit WERT() hat es funktioniert!
Warum formatierst Du die Zellen nicht so, dass sie eine führende Null anzeigen?
Weil ich nicht weiß, wie das geht :-)


Aber ich habe festgestellt, dass die CSV-Datei, von der ich die Daten importiert habe, die führenden Nullen ebenfalls enthält, und wenn ich gezielt die betreffende Spalte als Text importiere, funktioniert es auch (nun hab ich also 2 Lösungen) :-)

Benutzeravatar
komma4
********
Beiträge: 5331
Registriert: Mi, 03.05.2006 23:29
Wohnort: Chon Buri Thailand Asia
Kontaktdaten:

Re: Wenn-Funktion mit Zeichenlänge

Beitrag von komma4 » Do, 01.06.2017 12:40

Perceptron hat geschrieben:
Do, 01.06.2017 11:27
Warum formatierst Du die Zellen nicht so, dass sie eine führende Null anzeigen?
Weil ich nicht weiß, wie das geht :-)
Erstelle eine neu Zellvorlage: F11 > Erstelle Vorlage> Name: _NullAnzeigen [führender Unterstrich, damit die Vorlage in der Übersicht immer OBEN angezeigt wird]

Rechte Maustaste darauf, Ändern: Reiter: Zahlen Format-Code: 000

Ggfs. Anzahl der "Führenden Nullen" angeben: 3

F1 erklärt es Dir (und vieles andere mehr)


Kommt immer darauf an, was mit den Spaltenwerten gemacht werden soll.
Cheers
Winfried
aktuell: LO 5.3.5.2 30m0(Build:2) SUSE rpm, unter Linux openSuSE Leap 42.3 x86_64/KDE5
DateTime2 Einfügen von Datum/Zeit/Zeitstempel (als OOo Extension)

Perceptron

Re: Wenn-Funktion mit Zeichenlänge

Beitrag von Perceptron » Do, 01.06.2017 12:48

Dankeschön! Ich hab das Problem wie gesagt inzwischen gelöst, werde mir aber merken, dass es diese Option gibt, damit ich danach beim nächsten mal nicht mehr fragen muss :-)

Viele Grüße,

P.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 13 Gäste