mp3 abspielen bei bestimmten wert

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Ghost_Hunter

mp3 abspielen bei bestimmten wert

Beitrag von Ghost_Hunter » Fr, 09.06.2017 17:42

Hallo zusammen.
Bin neu hier!!! und absoluter Neuling in Open Office und auch am PC.
Hoffe ich bin hier richtig!!!
Habe mir ne kleine Dartliste zusammen geklaut mit den super Tipps aus euren Forum, leider finde ich nichts
wie ich ne mp3 abspielen kann wenn die 180 in meiner Liste auftaucht.
Ist das überhaupt möglich mit Open Office?
Ist mir peinlich, aber wie kann ich hier meine Datei anhängen, damit ihr schauen könnt was ich meine???
Wie gesagt Neuling.

danke schon mal für eure Hilfe.

F3K Total
********
Beiträge: 3137
Registriert: Mo, 28.02.2011 17:49

Re: mp3 abspielen bei bestimmten wert

Beitrag von F3K Total » Fr, 09.06.2017 18:02

Hallo,
du kannst nur dann Dateien anhängen, wenn du dich im Forum registierst. Möchtest du das nicht, kannst du einen Filehoster verwenden und die Datei hier verlinken.
EDIT: Zu deiner Frage
Ja, grundsätzlich ist das möglich, allerdings benötigst du dazu Makros, die du programmieren musst.
Gruß R

clag
********
Beiträge: 3523
Registriert: Di, 27.01.2009 15:30

Re: mp3 abspielen bei bestimmten wert

Beitrag von clag » Mo, 12.06.2017 12:34

Hallo Ghost_Hunter,

@ F3K Total
es geht auch mit einer eigenen Funkktion.

Vor einiger Zeit hatte ich mir einmal eine solche "UDF" erstellt, die funktioniert einwandfrei,
allerdings müsste man da die Pfade anpassen. (ist ja für ein Win XP)

Code: Alles auswählen

FUNCTION PLAYON(optional repeats as integer, optional SoundFile as string) 'wie oft, welche Tonsequenz
	if IsMissing (SoundFile) Then soundfile = "c:\batch\sound\Chime.mp3"
	if IsMissing (repeats) Then repeats = 1
	playme = ConvertToUrl("c:\WINXP\system32\mplay32.exe")
	for i=1 to repeats
	Shell(playme, 2, " /play /close /new " & SoundFile, 0)
	wait 1000 ' ggf. erhöhen wenn Tonsequenz länger als 1 Sekunde
	next
End FUNCTION
diesen Code must du unter
Menü/Extras/Makros/Makros verwalten/OpenOfficeBasic.../Meine Makros_Standard_Funktionen
einfügen ggf. anpassen und abspeichern.

2 Parameter sind möglich:
ohne Parameter wird der Standardton einmal abgespielt,
1. Anzahl Wiederholungen
2. ein anderer "Pfad/Datei"

@ Ghost_Hunter

angenommen deine Ergebnisliste ist im Bereich B2:B31, dann müsste deine Formel minimal so aussehen

Code: Alles auswählen

=WENN(MAX(B2:B31)>180;PLAYON();"")
erscheint ein Wert >180 in dem Bereich , wird der Ton/ die Melodi abgespielt.

hilft dir das weiter?
LG
clag

nutzt: WinXP SP3 / AOO 4.1.2 / Firefox

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 20 Gäste