Verweis liefert falsche Werte

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

StefanB
*
Beiträge: 12
Registriert: Do, 08.08.2013 16:02

Verweis liefert falsche Werte

Beitrag von StefanB » So, 16.07.2017 15:06

Guten Tag zusammen

hab ne Verweis der mir total wirre Werte liefert.
2017-07-16_15-03-19_Fotos.jpg
2017-07-16_15-03-19_Fotos.jpg (117.22 KiB) 838 mal betrachtet
Sowohl der Suchvektor, als auch der Ergebnisvektor sind Aufsteigend sortiert.
Gibt keine Duplikate, hab ich auch gechecked!

Beide Vektoren sind in einer anderen Datei, wenn ich jetzt genau die gleiche Tabelle in einer Datei mit anderem Namen nehm, dann funktionierts einwandfrei.

Formatierungsproblem? Hab aber geschaut dass alles als Zahlen formatiert ist.

Ideen auf die schnelle?

paljass
******
Beiträge: 640
Registriert: Do, 25.10.2012 07:25

Re: Verweis liefert falsche Werte

Beitrag von paljass » So, 16.07.2017 15:28

Hi,
Ideen auf die schnelle?
Verweis-Formel angeben, Beispieldatei hochladen und Format überprüfen - Linksbündig ausgerichtete Ziffern deuten auf Text hin.
Gibt keine Duplikate, hab ich auch gechecked!
Un was ist mit den 16 1084?

Gruß
paljass
EDV ist wie U-Boot fahren - machst du ein Fenster auf, fangen die Probleme an.

Gast

Re: Verweis liefert falsche Werte

Beitrag von Gast » So, 16.07.2017 15:34

Linksbündig is ne händische formatierung.
Und er macht die Duplikate von selbst, des is ja des problem!

Beispieldatei hochladen is ned drin leider, wären zum einen 2 Dateien und beide kann ich ned rausgeben, sorry!

Code: Alles auswählen

=WENN(D4="";"";VERWEIS(D4;'file:///E:/Ordner1/Datenbank.ods'#$'DB.Projekte'.$G$5:$G$500;'file:///E:/Ordner1/Datenbank.ods'#$'DB.Projekte'.$A$5:$A$500))
Das Suchkriterium wird dynamisch erzeugt weil die Anzahl der "Projekte" wechselnd sind, deswegen auch die Wenn-Funktion davor.

StefanB
*
Beiträge: 12
Registriert: Do, 08.08.2013 16:02

Re: Verweis liefert falsche Werte

Beitrag von StefanB » So, 16.07.2017 15:43

Des drüber war ich, keine Ahnung warum er mich rausgeworfen hat obwohl der Haken beim Login drin war.

Des komische an der ganzen Sache ist: Ich hatt es bereits funktionierend! Hab jetzt nur ein paar Tabelle "neu Angeordnet", sprich diese Projektliste ist jetzt in die "Datenbank-ODS" gewandert aus einer extra Datei.
Und seit dem funktionierts nimmer...

StefanB
*
Beiträge: 12
Registriert: Do, 08.08.2013 16:02

Re: Verweis liefert falsche Werte

Beitrag von StefanB » So, 16.07.2017 16:01

Hab grad ne "Lösung" gefunden.

Bei der alten Version, habe ich einen Schritt extra gemacht, den ich jetzt in einem machen wollte.

Zur Erklärung:
Die Projektliste aus der die Daten gezogen worden hat eine Spalte in der steht drin ob das Projekt noch läuft oder bereits abgeschlossen ist.
Alle laufenden Projekte werden durchnummeriert mit folgender Funktion:

Code: Alles auswählen

=WENN(F7="laufend";MAX(G$4:G6)+1;"")
Nachdem die erste Spalte der Tabelle die Projektnummer ist, kann ich ned mit einem SVERWEIS Arbeiten.
Deswegen ein Verweis, der mir die "laufenden" Projekte eben auflistet und dann kann ich mit der Projektnummer die ganzen anderen Daten ziehen.
Mit einer Matrixfunktion arbeiten hatte ich mal versucht, aber führte zu keinem Ergebnis, und ich glaub ich kann mir denken warum.

Nachdem hier zwischen den verschiedenen Zeilen immerwieder leere Zellen dabei sind, scheint das hier der Knackpunkt zu sein wenn man nen Verweis auf ne externe Datei anwendet.

Habe jetzt in meiner Datei mit der Projektliste, ne eigene Tabelle gemacht, die genau das macht was ich haben will und da funktioniert es. Jetzt geh ich einfach her und zieh mir meine Projektnummern ebenfalls mit einem Verweis von dort. Jetzt funktionierts.

Muss jetzt leider los, werde mal schaun dass ich diesen Fehler mal reproduzieren kann und sag nochmal bescheid.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 10 Gäste