Tabellendruck - Zellen ohne Inhalt nicht berücksichtigen

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

McSpain

Tabellendruck - Zellen ohne Inhalt nicht berücksichtigen

Beitrag von McSpain » So, 23.07.2017 13:27

Hi,
ich möchte eine Tabelle ausdrucken, die 6 Seiten lang ist. Die Inhalte der einzelnen Zellen sind variabel und können auch mal 0 betragen bzw. es ist möglich, dass die Zellen keinen Inhalt haben. Nun möchte ich beim Drucken keine 6 Seiten haben, auf denen alle 5 cm ein Wert steht.
Ist es möglich, dass beim Druck die leeren Zellen nicht berücksichtigt werden und automatisch vorhandene Inhalte direkt untereinander gedruckt werden, quasi wie eine Liste ohne Leerräume?

Hoffe ich habe mich einigermaßen verständlich ausgedrückt.
Gruß McSpain

echo
******
Beiträge: 666
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: Tabellendruck - Zellen ohne Inhalt nicht berücksichtigen

Beitrag von echo » So, 23.07.2017 17:32

Hallo,
ich benutze hier LibreOffice daher könnte der Weg etwas anders sein aber es sollte funktionieren in dem du deine Tabelle incl. Überschrift markierst und unter Daten >> Filter den Autofilter aktivierst.
In der Überschrift bekommst du ein PullDown-Menü in dem du Leere Zellen ausfiltern kannst.

Soll das über mehrere Spalten funktionieren oder sollte OO etwas anders sein,
so könntest du in einer Hilfsspalte eine Formel einfügen und runter kopieren:
Beispiel: Beginn oben in Zeile 2, für den Bereich A2:D2
=ZÄHLENWENN(A2:D2;"<>")

Steht in A2 bis D2 nichts drin, ist das Ergebnis der Formel 0
Jetzt markierst du deine Tabelle incl. Hilfsspalte und filterst wie oben beschreiben mit dem Autofilter die Null's aus der Hilfsspalte raus.
ggf Formelbereich anpassen

Druckbereich anpassen, fertig
Gruß Holger

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 18 Gäste