SUMMEWENN und VERGLEICH

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

retuwe61
****
Beiträge: 148
Registriert: So, 18.11.2007 21:25

SUMMEWENN und VERGLEICH

Beitrag von retuwe61 » Do, 27.07.2017 13:53

Hallo miteinander.
Mit

Code: Alles auswählen

=SUMMEWENN(INDIREKT("$Tabelle1_2.$A$4:$A$2000");"0.*";INDIREKT("$Tabelle1_2.$B$4:$B$2000"))
werden die Werte in Spalte B aufsummiert.
Allerdings benötige ich nicht die Spalte B sondern diejenige, in deren erster Zeile der Wert mit demjenigen der Tabelle1.B1 übereinstimmt.
Die Spaltennummer würde ich mit

Code: Alles auswählen

=VERGLEICH(Tabelle1.B1;Tabelle1_2.B1:AMJ1;0)
ermitteln.
Habt ihr eine Lösung für mein Problem?
Gruß
Uwe
Angewandt wird LibeOffice Version 5.1.6.2

paljass
******
Beiträge: 640
Registriert: Do, 25.10.2012 07:25

Re: SUMMEWENN und VERGLEICH

Beitrag von paljass » Do, 27.07.2017 15:27

Hi,
wofür soll Indirekt() in deiner Formel gut sein?
Ohne gehts so:

Code: Alles auswählen

=SUMME(VERSCHIEBUNG($Tabelle1_2.$A$3;1;VERGLEICH($Tabelle1.$B$1;$Tabelle1_2.$A$4:$G$4;0)-1;1996)*(LINKS($Tabelle1_2.$A$4:$A$2000;1)="0"))
Formel mit Strg-Umschalt-Enter als Matrixformel abschließen!!!

Gruß
paljass
EDV ist wie U-Boot fahren - machst du ein Fenster auf, fangen die Probleme an.

retuwe61
****
Beiträge: 148
Registriert: So, 18.11.2007 21:25

Re: SUMMEWENN und VERGLEICH

Beitrag von retuwe61 » Do, 27.07.2017 16:03

Hallo paljass.
Da ich nicht weiß, ob ich mich missverständlich ausgedrückt habe, lade ich die Beispieldatei mal hoch.
Deine Formel befindet sich in Tabelle1_2.H3 (=#NV anstatt 27).
Falls du noch mal einen Blick darauf werfen könntest?
Gruß
Uwe
Dateianhänge
Datei.ods
(12.32 KiB) 88-mal heruntergeladen
Angewandt wird LibeOffice Version 5.1.6.2

paljass
******
Beiträge: 640
Registriert: Do, 25.10.2012 07:25

Re: SUMMEWENN und VERGLEICH

Beitrag von paljass » Fr, 28.07.2017 06:22

Moin,
entweder du weißt nicht, was du tust, oder du hast keine Lust dir mal die Formel mit Sinn und Verstand anzugucken.
Wenn du die Formel in ein Tabelle kopierst, die anders aufgebaut ist als diejenige, auf die Formel basiert, musst du selbstverständlich die Bezüge anpassen dann klappts auch mit dem richtigen Ergebnis.

Gruß
paljass

na gut, eigentlich wollte ich dich ja probieren lassen, aber hier die richtige Formel:

Code: Alles auswählen

=SUMME(VERSCHIEBUNG($Tabelle1_2.$A$2;1;VERGLEICH($Tabelle1.$B$1;$Tabelle1_2.$A$1:$G$1;0)-1;1996)*(LINKS($Tabelle1_2.$A$3:$A$2000;1)="0"))
EDV ist wie U-Boot fahren - machst du ein Fenster auf, fangen die Probleme an.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 12 Gäste