Anzahl unterschiedlicher Argumente in Spalte, bei mehreren Bedingungen ausgeben

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

NoSolution
Beiträge: 4
Registriert: Mi, 23.08.2017 19:30

Anzahl unterschiedlicher Argumente in Spalte, bei mehreren Bedingungen ausgeben

Beitrag von NoSolution » Mi, 23.08.2017 19:50

Hallo erst Mal,
ich hoffe mir kann hier geholfen werden, da ich bereits einen Tag verschenkt habe mit nicht funktionierenden Lösungsversuchen zu meinem Problem.

Es geht um Folgendes.

Es soll die Anzahl unterschiedlicher Daten in Spalte C ausgegeben werden.

Dies hatte mir folgender Formel funktioniert.

=SUMME(WENN(HÄUFIGKEIT(C3:C500;C3:C500)>0;1))

Nun benötige ich aber nur die Anzahl unterschiedlicher Daten in Spalten C, wo in der selben Zeile in Spalte A ein bestimmter Wert steht.
Formel.jpg
Formel.jpg (345.21 KiB) 1069 mal betrachtet
In der Spalte A stehen übrigens "Namen" und es geht, darum pro Person die Arbeitstage aus dieser Tabelle heraus zu ermitteln.
Die Schichten sind dabei irrelevant. Es geht nur darum an wievielen Tagen im Monat die Person anwesend war.

Ich hoffe ich konnte es sinnvoll erklären.

Wie kann ich das machen?

Egal was ich bisher probiert habe ich bekam immer nur Fehlermeldungen.

Vielen Dank im Vorraus.

Es grüßt der Kevin :-)

paljass
******
Beiträge: 639
Registriert: Do, 25.10.2012 07:25

Re: Anzahl unterschiedlicher Argumente in Spalte, bei mehreren Bedingungen ausgeben

Beitrag von paljass » Do, 24.08.2017 06:10

Hi,
das wird wohl mit =Summenprodukt() zu lösen sein.
Für genauere Hilfe bitte eine Beispieldatei.

Gruß
paljass
EDV ist wie U-Boot fahren - machst du ein Fenster auf, fangen die Probleme an.

NoSolution
Beiträge: 4
Registriert: Mi, 23.08.2017 19:30

Re: Anzahl unterschiedlicher Argumente in Spalte, bei mehreren Bedingungen ausgeben

Beitrag von NoSolution » Do, 24.08.2017 17:02

Hallo,

hier ist Mal die Datei um die es geht.

Vielleicht kann mir ja jemand helfen. Auf dem 2.ten Tabellenblatt soll die Auswertung erfolgen.
Dateianhänge
August 2016.ods
(23.32 KiB) 23-mal heruntergeladen

HeritzP
*****
Beiträge: 227
Registriert: So, 22.12.2013 11:23

Re: Anzahl unterschiedlicher Argumente in Spalte, bei mehreren Bedingungen ausgeben

Beitrag von HeritzP » Do, 24.08.2017 21:37

Hallo,

es würde diese Formel reichen.

Code: Alles auswählen

=ZÄHLENWENN('08-2017'.A$3:A$380;A4)
Wenn es genauer mit Monat sein soll dann.

Code: Alles auswählen

=SUMMENPRODUKT('08-2017'.A$3:A$380=A4;MONAT('08-2017'.C$3:C$380)=MONAT(C$1))
In C1 ist das Datum 01.08.17 eingetragen.


Gruß HeritzP

NoSolution
Beiträge: 4
Registriert: Mi, 23.08.2017 19:30

Re: Anzahl unterschiedlicher Argumente in Spalte, bei mehreren Bedingungen ausgeben

Beitrag von NoSolution » So, 27.08.2017 17:06

Hallo,

vielen Dank erst Mal, das habe ich leider auch schon alles probiert.

In Spalte A stehen die Namen.

Ich brauche die Auswertung pro Mitarbeiteramen und für jeden Monat.

Die Schichten sind 0-6 6-16 16-24 <<< ich brauche aber die Tage dahinter. Dabei ist es egal ob jemand an 2 Schichten an einem Tag da ist, in einer oder in 3. Wenn er in einer da ist, reicht das für mich in der Statistik als Tag.

Die jeweilige Tabelle geht immer nur genau über einen Monat. Aber in ihr sind eben alle Mitarbeiter erfasst.
Auf einem seperaten Tabellenblatt will ich für jeden Monat die Daten aus dieser Tabelle ziehen.

Vielleicht habe ich mich falsch ausgrdrückt. Hast du noch eine Idee ?

Mondblatt24
***
Beiträge: 93
Registriert: So, 14.05.2017 16:11

Re: Anzahl unterschiedlicher Argumente in Spalte, bei mehreren Bedingungen ausgeben

Beitrag von Mondblatt24 » So, 27.08.2017 19:05

Hallo,
Wenn er in einer da ist, reicht das für mich in der Statistik als Tag.
vielleicht hilft Dir das.

Gruß Peter

Nachtrag:falsche Spalte bei der 2.Bedingung.
Formel sollte so aussehen:=ZÄHLENWENNS('08-2017'.A:A;A3;'08-2017'.D:D;">0")
Wobei ich davon ausgehe, 0 Umsatz→ nicht anwesend.
Dateianhänge
August 2016-2.ods
(24.95 KiB) 16-mal heruntergeladen
Zuletzt geändert von Mondblatt24 am Mo, 28.08.2017 08:13, insgesamt 1-mal geändert.
LO 5.3.6; LO 5.4.1; AOO Portable 4.1.3

mikeleb
******
Beiträge: 613
Registriert: Fr, 09.12.2011 16:50

Re: Anzahl unterschiedlicher Argumente in Spalte, bei mehreren Bedingungen ausgeben

Beitrag von mikeleb » So, 27.08.2017 20:37

Hallo,
du kannst auch mit einer abgewandelten Version deiner ursprünglichen (Matrix-)Formel arbeiten:

Code: Alles auswählen

=SUMME(HÄUFIGKEIT(C3:C500*((A3:A500)="Andi");C3:C500)>0)
Wenn du es in der Auswertungstabelle, Spalte E, nutzen willst dann hieße es z. B.

Code: Alles auswählen

=SUMME(HÄUFIGKEIT('08-2017'.C3:C500*(('08-2017'.A3:A500)=A4);'08-2017'.C3:C500)>0)
Unabhängig davon wäre es überlegenswert, deine Monatstabelle anders zu organisieren, um die Auswertungen dann einfach per Pivottabellen zu realisieren.
Gruß,
mikeleb

NoSolution
Beiträge: 4
Registriert: Mi, 23.08.2017 19:30

Re: Anzahl unterschiedlicher Argumente in Spalte, bei mehreren Bedingungen ausgeben

Beitrag von NoSolution » Di, 29.08.2017 15:15

Vielen Dank, das hat alles super funktioniert. Meine Tabelle ist jetzt soweit fertig.

Ich würde gerne in der Auswertung automatisch die Werte bzw. Mitarbeiternamen aus dem ersten Tabellenblatt
ohne die Duplikate übernehmen lassen. Allerdings bekomme ich es nicht hin einen Spezialfilter zu erstellen, wenn das überhaupt das ist
was ich brauche

Ich brauche für die Auswertunggstabelle ja nur die Namen der Mitarbeiter die im jeweiligen Monat gearbeitet haben ohne Duplikate.

Vielen Dank noch Mal für alles.

Ihr seit Super!!!

Mondblatt24
***
Beiträge: 93
Registriert: So, 14.05.2017 16:11

Re: Anzahl unterschiedlicher Argumente in Spalte, bei mehreren Bedingungen ausgeben

Beitrag von Mondblatt24 » Di, 29.08.2017 21:04

Hallo,
Ich brauche für die Auswertunggstabelle ja nur die Namen der Mitarbeiter die im jeweiligen Monat gearbeitet haben ohne Duplikate.
Das lässt sich mit dem Standardfilter erledigen.

-markiere den Bereich mit den Namen.
-dann über Daten→Filter→Standardfilter öffnen
-unter Wert "nicht leer" wählen
-Mehr Optionen→keine DuplikateFilterergebnis ausgeben nach
auswählen, die Zielzelle angeben, fertig.

Gruß Peter
LO 5.3.6; LO 5.4.1; AOO Portable 4.1.3

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 8 Gäste