Summe eines variablen bereichs

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

zyncosaa

Summe eines variablen bereichs

Beitrag von zyncosaa » Di, 29.08.2017 18:20

Moin moin

Bin ganz neu hier bei dummen fragen nen klaps aufn hinterkopf...

Mein Problem ist das ich mehrere Tabellen blätter habe das erste ist die Übersicht zu allen anderen wo auch drauf berechnet wird anhand der Tabellen auf den anderen Tabellen blättern.

Jetzt will ich auf der ersten Tabelle zwei werte vorgeben die der auf einer anderen Tabelle suchen soll =SVERWEIS(D7;'Lvl Up Daten '.A128:B477;2) D7 ist der Wert den er suchen soll. der Zweite wert auch so =SVERWEIS(G7;'Lvl Up Daten '.A128:B477;2) jetzt soll der mir die summe ausrechnen die zwischen diesen beiden Indexexen(?) 2 stehen. Hoffe das das verstädlich ausgedrückt ist,

HeritzP
*****
Beiträge: 235
Registriert: So, 22.12.2013 11:23

Re: Summe eines variablen bereichs

Beitrag von HeritzP » Di, 29.08.2017 18:42

Hallo,

welches Ergebnis liefern die beiden SVERWEIS() Formeln ?


Gruß HeritzP

Stephan
********
Beiträge: 10168
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Summe eines variablen bereichs

Beitrag von Stephan » Di, 29.08.2017 19:04

Jetzt will ich auf der ersten Tabelle zwei werte vorgeben die der auf einer anderen Tabelle suchen soll =SVERWEIS(D7;'Lvl Up Daten '.A128:B477;2) D7 ist der Wert den er suchen soll. der Zweite wert auch so =SVERWEIS(G7;'Lvl Up Daten '.A128:B477;2) jetzt soll der mir die summe ausrechnen die zwischen diesen beiden Indexexen(?) 2 stehen.
Und welches Problem tritt dabei auf?

Falls es einen Referenzfehler (#REF!) gibt dann möglicherweise weil in den Formeln die Tabellennamen hinten ein Leerzeichen haben, was die Originaltabelle mutmaßlich nicht hat.


Gruß
Stephan

zyncosaa

Re: Summe eines variablen bereichs

Beitrag von zyncosaa » Di, 29.08.2017 19:27

Huch das geht aber schnell mit antworten,

@ HeritzP
Die Sverweise geben eine zahl aus, oder wie meinst du das?
hoffe das bild sagt mehr wie Tausend worte

http://www.bilder-upload.eu/show.php?fi ... 027498.jpg

das mit dem Bild geht leider nicht anders.

Stephan
********
Beiträge: 10168
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Summe eines variablen bereichs

Beitrag von Stephan » Di, 29.08.2017 19:42

Die Sverweise geben eine zahl aus
dann verstehe ich DEin Problem nicht, denn eine Zahl willst Du ja haben und das bzw. ob die jetzige Zahl falsch ist darüber sagst Du nichts.
hoffe das bild sagt mehr wie Tausend worte


Das Bild sagt mir leider wenig, denn weder sind Formeln erkennbar, noch das Zahlenergebnis der SVerweis-Formeln das Du obenstehend ansprachst, noch ist mir aus den in dem Bild ersichtlichen Einträgen klar warum die Zahl die die Summe der zwei SVerweis-Formeln sein soll eine 8 wäre, denn neben T1-1 steht eine 1 und neben T1-10 eine 0 und die Summe (1+0) wäre 1 und nicht 8.


Gruß
Stephan

zyncosaa

Re: Summe eines variablen bereichs

Beitrag von zyncosaa » Di, 29.08.2017 19:52

@ Stephan

Ich will die summe von T1-1 bis T1-10 (die nebenstehenden zahlen) errechnen wobei der anfang und das ende ja variable sind es könnte auch heißen T2-30 bis T3-50 die tabelle ist elendig lang.

Stephan
********
Beiträge: 10168
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Summe eines variablen bereichs

Beitrag von Stephan » Di, 29.08.2017 20:01

Ich will die summe von T1-1 bis T1-10 (die nebenstehenden zahlen) errechnen
darauf muss man aber ersteinmal kommen, das Du das willst. Ich hätte mit allen möglichen Dingen gerechnet aber wirklich nicht damit.

Ich weiß auch leider nicht wie das im Konkreten zu bewerkstelligen wäre, evtl. irgendwie mit VERSCHIEBUNG()? Ich habe aber keine konkrete Idee.


Gruß
Stephan

HeritzP
*****
Beiträge: 235
Registriert: So, 22.12.2013 11:23

Re: Summe eines variablen bereichs

Beitrag von HeritzP » Di, 29.08.2017 20:36

Hallo,

eine Möglichkeit.
Summe variabel.ods
(7.9 KiB) 24-mal heruntergeladen

Code: Alles auswählen

=SUMME(INDIREKT("Tabelle1."&ADRESSE(VERGLEICH(Tabelle1.D$128;Tabelle1.A$128:Tabelle1.A$149;0)+127;2)&":"&ADRESSE(VERGLEICH(Tabelle1.E$128;Tabelle1.A$128:Tabelle1.A$149;0)+127;2)))
Wenn die Formel in der Tabelle2 ist.

Die Formeln müssen noch angepasst werden.

Gruß HeritzP

Zyncosaa

Re: Summe eines variablen bereichs

Beitrag von Zyncosaa » Mi, 30.08.2017 11:19

Moin, moin ,

Ja super tausendfacher dank,

habe es aber nicht geschaft die Formel anzupassen, aber habe mir mit = geholfen indem ich die werte übernehme aus der anderen tabelle.

Keiner den ich bis dato gefragt habe konnte mir helfen, und das waren einige leute die sich "eigentlich" auskennen.

paljass als Gast

Re: Summe eines variablen bereichs

Beitrag von paljass als Gast » Mi, 30.08.2017 11:45

Hi,
etwas kürzer (die Idee von Stephan aufgenommen):

Code: Alles auswählen

=SUMME(VERSCHIEBUNG(B128;0;0;(VERGLEICH(E$128;A$128:A$149;0)+127)-(VERGLEICH(D$128;A$128:A$149;0)+127)+1))
Gruß
paljass

HeritzP
*****
Beiträge: 235
Registriert: So, 22.12.2013 11:23

Re: Summe eines variablen bereichs

Beitrag von HeritzP » Mi, 30.08.2017 16:37

Hallo,

die Lösung wie auf deinem Bild.
Eine Beispieldatei wäre immer hilfreicher als Bilder.

Code: Alles auswählen

=SUMME(INDIREKT("Tabelle2."&ADRESSE(VERGLEICH($D$7;Tabelle2.A$128:A$149;0)+127;2)&":"&ADRESSE(VERGLEICH($G$7;Tabelle2.A$128:A$149;0)+127;2)))
Summe variabel1..ods
(8.77 KiB) 29-mal heruntergeladen
Gruß HeritzP

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot], Yahoo [Bot] und 3 Gäste