verfrickelte Uhrzeit/Zeit

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Maiskolben
Beiträge: 8
Registriert: Fr, 22.05.2015 00:42

verfrickelte Uhrzeit/Zeit

Beitrag von Maiskolben » Mi, 30.08.2017 15:54

Moin Leute,

ich habe zwei Felder A-VON und B-BIS mit Zeitangaben alá 23:00 - 01:00 und möchte mir die Stundenanzahl als Ergebnis auf C ausgeben lassen.

Zelle A und B sind formatiert: HH:MM. - Die Ergebniszelle ist formatiert: [HH]:MM.
Das Ergebnisfeld (C) hat die Formel: =WENN(B27<A27;24-A27+B27;B27-A27)

Nun habe ich mir diese drei Felder kopiert, für den Tag 2.

Tag 1: A (23:00) -> B (01:00) -> C (02:00) -> SOWEIT gut.

Nun hinten dran, dasselbe für den Tag 2: A -> B -> C -> D (23:00) -> E (01:00) -> F (02:00)

Nun möchte ich die beiden Tagesstunden addieren -> G (Format: [HH]:MM). Wären ja 04:00 Stunden. Das klappt aber nicht! Wenn ich an beiden Tagen innerhalb von 24h bleibe (bspw. jeden Tag von 08:00 - 10:00 Uhr), dann addiert Calc mir mit =SUMME(C1;F1) die richtige Wochenstundenanzahl. Sobald aber nur einer der Tage über 24:00 Uhr läuft, verstehe ich das Ergebnis nicht mehr.

Das Ergebnis mit 23:00 - 01:00 Uhr täglich ist dann: 1108:00:00 ?

Das Ergebnis mit 08:00 - 10:00 Uhr täglich ist korrejt 04:00.

Woran liegt das?

Sobald ich das Gesamtergebnis aber so formatiere: HH:MM, ist das Ergebnis UNTER 24 Stunden auch korrekt. Aber sobald die Gesamtstundenanzahl ÜBER die 24 Stunden geht, steige ich wieder völlig aus und das Ergebnis ist falsch. ?

echo
******
Beiträge: 668
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: verfrickelte Uhrzeit/Zeit

Beitrag von echo » Mi, 30.08.2017 16:50

=WENN(B27<A27;24-A27+B27;B27-A27)

Hallo
Deine Formel stimmt nicht,
24 das sind 24 Tage nicht 24 Stunden; daher hasst du auch 23 Tage zufiel auf der Uhr...
24 Stunden= 1 weil ein Tag

Ersetze 24 durch 1 oder
verwende statt dessen die die Formel =REST(B27-A27;1)
Dann wird vermutlich auch die Summe passen

Wenn du die [hh] eckigen Klammern weg lässt werden die vollen Tage nicht in Stunden umgerechnet, das sind dann Tage.
Das gibt das Zellformat aber nicht her und wird deshalb nicht angezeigt. Ist aber Sehwohl vorhanden!!! Siehe Summe.
Zum Test könntest du mal TT hh:mm als Zellformat einstellen

Gruß Holger
Zuletzt geändert von echo am Mi, 30.08.2017 21:19, insgesamt 1-mal geändert.

Maiskolben
Beiträge: 8
Registriert: Fr, 22.05.2015 00:42

Re: verfrickelte Uhrzeit/Zeit

Beitrag von Maiskolben » Mi, 30.08.2017 17:32

Hallo Holger,

ja, jetzt passt die Summe. Vielen Dank für den Hinweis!

Lg, Maiskolben

Antworten

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 17 Gäste