Seite 1 von 1

bestimmten text filtern

Verfasst: Fr, 06.10.2017 16:44
von kadalon
Hallo,

habe heute eine Tabelle erstellt und stehe bei letzten Schritt auf dem Schlauch.

=SUMMENPRODUKT('Monat 3'.C8:C2000="Anpassung";'Monat 3'.F8:F2000="durch Erstattung";'Monat 3'.U8:U2000)

durch Erstattung soll gesucht werden, aber die Zeilen enthalten mehr Wörter als durch Erstattung

Habe es schon .* " und anderen Zeichen versucht aber nichts funktioniert
Kann jemand helfen?

Grüße Kadalon

Re: bestimmten text filtern

Verfasst: Fr, 06.10.2017 16:54
von echo
Hallo
ich kann es hier ja nicht testen aber versuche es mal so:
=SUMMENPRODUKT('Monat 3'.C8:C2000="Anpassung";'Monat 3'.F8:F2000="durch Erstattung";'Monat 3'.U8:U2000)
=SUMMENPRODUKT('Monat 3'.C8:C2000="Anpassung";suchen("durch Erstattung";'Monat 3'.F8:F2000)<>0;'Monat 3'.U8:U2000)

Gruß Holger

Re: bestimmten text filtern

Verfasst: Fr, 06.10.2017 17:03
von kadalon
echo hat geschrieben:
Fr, 06.10.2017 16:54
Hallo
ich kann es hier ja nicht testen aber versuche es mal so:
=SUMMENPRODUKT('Monat 3'.C8:C2000="Anpassung";'Monat 3'.F8:F2000="durch Erstattung";'Monat 3'.U8:U2000)
=SUMMENPRODUKT('Monat 3'.C8:C2000="Anpassung";suchen("durch Erstattung";'Monat 3'.F8:F2000)<>0;'Monat 3'.U8:U2000)

Gruß Holger
Hallo Holger,

danke,
habe ich mal probiert mit suchen und auch mit finden, aber da kommt ein Fehler. :(

Ich hatte schon gesucht und auch etwas gefunden aber kann mich leider nicht mehr genau erinnern.
vor und nach den gesuchten Wort mussten bestimmte Zeichen stehen.
Grüße Kadalon

Re: bestimmten text filtern

Verfasst: Fr, 06.10.2017 17:05
von Mondblatt24
Hallo,
stelle bitte eine Beispieldatei zur Verfügung.

MfG Peter

Re: bestimmten text filtern

Verfasst: Fr, 06.10.2017 17:07
von lorbass
Damit ».*« in Calc-Funktionen als Regulärer Ausdruck (RegEx) funktioniert, muss die Option Extras → Optionen → LibreOffice Calc → Berechnen → [✓] Reguläre Ausdrücke in Formeln ermöglichen aktiviert sein. Allerdings sind nicht alle Funktionen RegEx-tauglich.

Gruß
lorbass

Re: bestimmten text filtern

Verfasst: Fr, 06.10.2017 17:30
von kadalon
lorbass hat geschrieben:
Fr, 06.10.2017 17:07
Damit ».*« in Calc-Funktionen als Regulärer Ausdruck (RegEx) funktioniert, muss die Option Extras → Optionen → LibreOffice Calc → Berechnen → [✓] Reguläre Ausdrücke in Formeln ermöglichen aktiviert sein. Allerdings sind nicht alle Funktionen RegEx-tauglich.

Gruß
lorbass
Hallo lorbass,

das habe ich durch suche auch gefunden und es war schon aktiviert.

Mondblatt24 hat geschrieben:
Fr, 06.10.2017 17:05
Hallo,
stelle bitte eine Beispieldatei zur Verfügung.

MfG Peter
Hallo Peter,

anbei Datei


Grüße Kadalon

Re: bestimmten text filtern

Verfasst: Fr, 06.10.2017 18:11
von Mondblatt24
Hallo,
Versuche es mit Summewenns(), wenn Du Open Office benutzt.
Gruß Peter

Re: bestimmten text filtern

Verfasst: Fr, 06.10.2017 19:03
von kadalon
Mondblatt24 hat geschrieben:
Fr, 06.10.2017 18:11
Hallo,
Versuche es mit Summewenns(), wenn Du Open Office benutzt.
Gruß Peter
Summewenns oder sumifs gibt es bei meinen Openoffice nicht.
Dein Vorschlag funktioniert leider nicht bei mir.
Anscheinend muss ich noch irgendetwas einstellen.

Re: bestimmten text filtern

Verfasst: Fr, 06.10.2017 19:58
von HeritzP
Hallo,

mit einem Update ist SUMMEWENNS() verfügbar.
Eine Formel mit SUMMEWENN().

Code: Alles auswählen

=SUMMEWENN(F8:F2000;".*Erstattung zurück.*";(H8:H2000)*(C8:C2000="Anpassung"))
Als Matrix im Fomeleditor markieren.

SUMMENPRODUKT() kann mit regulären Ausdrücken nicht umgehen.

Gruß HeritzP

Re: bestimmten text filtern

Verfasst: Fr, 06.10.2017 20:01
von Mondblatt24
Hallo,
Summewenns oder sumifs gibt es bei meinen Openoffice nicht.
bei mir schon.
Gruß Peter

Re: bestimmten text filtern

Verfasst: Fr, 06.10.2017 20:38
von kadalon
Mondblatt24 hat geschrieben:
Fr, 06.10.2017 18:11
Hallo,
Versuche es mit Summewenns(), wenn Du Open Office benutzt.
Gruß Peter
Hallo Peter,

Update gemacht und nun funktionirt es in der Testdatei. :-)
Danke.

HeritzP hat geschrieben:
Fr, 06.10.2017 19:58
Hallo,

mit einem Update ist SUMMEWENNS() verfügbar.
Eine Formel mit SUMMEWENN().

Code: Alles auswählen

=SUMMEWENN(F8:F2000;".*Erstattung zurück.*";(H8:H2000)*(C8:C2000="Anpassung"))
Als Matrix im Fomeleditor markieren.

SUMMENPRODUKT() kann mit regulären Ausdrücken nicht umgehen.

Gruß HeritzP
Hallo HeritzP,

danke für Tip mit regulären Ausdrücken.
Deswegen kann es ja nicht funktionieren.
Dein Summewenn geht bei mir auch nicht.

Folge dann mal Peters Vorschlag.

Re: bestimmten text filtern

Verfasst: Fr, 06.10.2017 20:48
von kadalon
Vielen Dank an
Mondblatt24 hat geschrieben:
Fr, 06.10.2017 18:11
Hallo,
Versuche es mit Summewenns(), wenn Du Open Office benutzt.
Gruß Peter
Das hat bei mir funktioniert nach einen Update.
Topforum. Sehr schnelle Hilfe bekommen. Danke. :-)