mittelwert nur aus den 8 höchsten zahlen

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

wolfgangihde
Beiträge: 1
Registriert: Mo, 30.10.2017 16:31

mittelwert nur aus den 8 höchsten zahlen

Beitrag von wolfgangihde » Mo, 30.10.2017 16:40

Ich habe 24 Zeilen mit je 12 Zahlen. Ich möchte für jede Zeile den Mittelwert nur aus den 8 höchsten Zahlen haben,
die 4 niedrigsten sollen nicht beachtet werden.
Gibt es da eine Lösung?
Es geht übrigens um eine Skatvereins-Jahresstatistik.

Mondblatt24
****
Beiträge: 121
Registriert: So, 14.05.2017 16:11

Re: mittelwert nur aus den 8 höchsten zahlen

Beitrag von Mondblatt24 » Mo, 30.10.2017 17:47

Hallo,
es gibt die Funktion Mittelwertwenn(),
mit der solltest Du ans Ziel kommen.

https://help.libreoffice.org/Calc/AVERAGEIF_function/de

Gruß Peter
LO 5.3.6; LO 5.4.2; LO 5.4.2 Portable; AOO Portable 4.1.4

Benutzeravatar
lorbass
********
Beiträge: 4014
Registriert: Mo, 01.05.2006 21:29
Wohnort: Bonn

Re: mittelwert nur aus den 8 höchsten zahlen

Beitrag von lorbass » Mo, 30.10.2017 17:49

Code: Alles auswählen

{=MITTELWERT(KGRÖSSTE(A1:L1;{1;2;3;4;5;6;7;8}))}
Mit [UMSCHALT]+[STRG]+[ENTER] als Matrixformel einfügen!

Gruß
lorbass

Helmut_S
*
Beiträge: 16
Registriert: So, 29.10.2017 11:29

Re: mittelwert nur aus den 8 höchsten zahlen

Beitrag von Helmut_S » Di, 31.10.2017 16:13

Hallo Wolfgang, zusätzlich zu den Lösungsvorschlägen von @Mondblatt24 und @lorbass habe ich dein Problem in der angehängten Tabelle nachgebaut. Von Skat habe ich zwar keinen blassen Schimmer, ich hoffe aber, dass ich deine Fragestellung richtig verstanden habe und du mit meiner ziemlich einfachen Tabelle zu recht kommst. Die Lösungsformel von @lorbass arbeitet perfekt und braucht nur 1 Tabelle, erfordert aber einige Sorgfalt bei der Eingabe. Habe dir 2 Varianten gemacht, wahrscheinlich wird die Zeilen-orientierte Sortierung eher zu gebrauchen sein. Die "Dummy-Werte" dienen nur der Kontrolle und müssen vor Eingabe der richtigen Werte in die Tabelle "unsortiert" gelöscht werden. Die Mittelwerte sind mit einer bedingten Formatierung versehen von max=dunkelgrün bis min = rot.
Gruß Helmut
Skatstatistik.ods
(27.63 KiB) 14-mal heruntergeladen

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 17 Gäste