durchschnitt letzte 30 werte spalte

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Masl75
**
Beiträge: 47
Registriert: So, 24.02.2013 11:45

durchschnitt letzte 30 werte spalte

Beitrag von Masl75 » Fr, 03.11.2017 16:49

Hallo,

ich pflege eine Tabelle, in der fast täglich Daten hinzukommen. Nun suche ich eine Formel, welche mir den Durchschnitt der letzten 30, 60 oder auch 90 Werte einer Spalte errechnet.

Sinngemäß in etwa =average((letzterWert-30Zeilen):letzterWert)

Das Problem ist die variable Adressierung der Zeile, die Spalte ist ja konstant...

Für die Füchse unter euch ist das sicher ein Klacks, die Forumssuche schweigt sich zur Suche "durchschnitt letzte 30 werte spalte" leider aus.
Liebe Grüße, Marcel

Benutzeravatar
lorbass
********
Beiträge: 4013
Registriert: Mo, 01.05.2006 21:29
Wohnort: Bonn

Re: durchschnitt letzte 30 werte spalte

Beitrag von lorbass » Fr, 03.11.2017 18:18

Lege eine Hilfstabelle mit dem Datumsbereich =HEUTE()-90 bis =HEUTE() an. Die zugehörigen Daten kannst du mit =SVERWEIS(…) übernehmen. Die Auswertung erfolgt dann über die gesamte (Hilfs-)Tabelle oder die letzten 60 oder 30 Zeilen, die du innerhalb der fixen Tabelle ja gut bestimmen kannst.

Gruß
lorbass

HeritzP
*****
Beiträge: 234
Registriert: So, 22.12.2013 11:23

Re: durchschnitt letzte 30 werte spalte

Beitrag von HeritzP » Fr, 03.11.2017 18:19

Hallo,

so z.B.

Code: Alles auswählen

=MITTELWERT(VERSCHIEBUNG(A1;ANZAHL(A1:A100)-C1;0;ANZAHL(A1:A100)))
C1 ist die Anzahl der Werte

Gruß HeritzP

Masl75
**
Beiträge: 47
Registriert: So, 24.02.2013 11:45

Re: durchschnitt letzte 30 werte spalte

Beitrag von Masl75 » Sa, 04.11.2017 08:35

Moin Lorbass,

vielen Dank für deine schnelle und verständliche Antwort. Das klingt durchaus machbar, allerdings sind es nicht die letzten 30/60/90 Tage sondern Werte (es kommt nicht jeden Tag ein Wert/Datensatz hinzu, sondern nur alle 1-3 Tage, bei Krankheit gar nichts) - über eine Datumsfunktion wie HEUTE dürfte das dann schwierig werden, oder?
Liebe Grüße, Marcel

Masl75
**
Beiträge: 47
Registriert: So, 24.02.2013 11:45

Re: durchschnitt letzte 30 werte spalte

Beitrag von Masl75 » Sa, 04.11.2017 11:37

ich glaube, ich hab es hinbekommen:

=IF(AND($H40>0;$M40>=N$8);AVERAGE($H10:$H40);AVERAGE($H$10:$H40))
(der erste Wertesatz steht in Zeile 10)

Spalte H: die für die Berechnung relevanten Werte
Spalte M: eine lfd Nummer, die sich um je 1 erhöht, sofern in H ein Wert > 0 steht (=MAX() führt dann zur Zeile mit dem letzten Wert)
Spalte N: 30er-Durchschnitt
Spalte O: 60er-Durchschnitt
Spalte P: 90er-Durchschnitt
Liebe Grüße, Marcel

echo
******
Beiträge: 666
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: durchschnitt letzte 30 werte spalte

Beitrag von echo » Sa, 04.11.2017 11:43

Hallo zusammen
wenn du dir eine Hilfsspalte anlegst die deine Werte zählt (lfd.-Nr), dann hilft dir =mittelwertwenn() siehe Anhang
Gruß Holger
mittelwertwenn.ods
(17.32 KiB) 10-mal heruntergeladen

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 18 Gäste