Andere Tabelle dynamisch referenzieren / SUMMEWENN und INDIREKT

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

FeWe
Beiträge: 2
Registriert: Di, 26.12.2017 17:05

Andere Tabelle dynamisch referenzieren / SUMMEWENN und INDIREKT

Beitrag von FeWe » Di, 26.12.2017 17:21

Hallo,

ich habe eine Calc-Datei, die eine simple projektweise Arbeitszeiterfassung ist.

Je Monat gibt es eine Tabelle, man trägt oben ein Projekt ein und dann jeweils Stunden die sich summieren etc. Beispieldatei im Anhang.

Jetzt würde ich gerne eine Projektweise Auswertung machen, und komme mit SUMMEWENN auch schon recht weit, ich würde aber gerne den Tabellennamen (also den Monat) auch gerne referenzieren, da bekomm ich aber damit nicht hin:

=SUMMEWENN(Januar.$C$2:$F$2;C$4;Januar.$D$11:$G$11)
;C$4; ist der referenzierte Projektname, Januar würde ich gerne referenzieren.


Beim googlen bin ich auf Indirekt gestoßen:
=INDIREKT("" & A18 & ".D11")
damit bekomme ich zwar die Tabelle dynamisch, aber sonst nix mehr referenziert und die Verbinung mit Summewenn ist mir unklar.

Perspektivisch würde ich gerne die Erfassung von mehreren dieser Arbeitszeitdateien von einer Datei aus machen, aber das ist dann der nächste Schritt.

Simplifizierte Datei mit den Bezügen im Anhang. Benutze OO 4.1.1 auf OSX

Gruß
Fewe

Sundenliste test.ods
(11.73 KiB) 24-mal heruntergeladen

paljass
******
Beiträge: 663
Registriert: Do, 25.10.2012 07:25

Re: Andere Tabelle dynamisch referenzieren / SUMMEWENN und INDIREKT

Beitrag von paljass » Mi, 27.12.2017 10:14

Hi,
für den zweiten Januar in deiner Tabelle (also Zeile 18)

Code: Alles auswählen

=SUMMEWENN(INDIREKT($A18&".$C$2:$F$2");C$4;INDIREKT($A18&".$D$11:$G$11"))
.

Gruß
paljass
EDV ist wie U-Boot fahren - machst du ein Fenster auf, fangen die Probleme an.

FeWe
Beiträge: 2
Registriert: Di, 26.12.2017 17:05

Re: Andere Tabelle dynamisch referenzieren / SUMMEWENN und INDIREKT

Beitrag von FeWe » Mi, 27.12.2017 13:14

Vielen Dank!
Wenn man die Lösung anguckt, siehts so aus als hätte ich drauf kommen müssen, ging aber nicht ;) Klappt wunderbar und löst mein Problem.

Antworten