Seite 1 von 1

Andere Tabelle dynamisch referenzieren / SUMMEWENN und INDIREKT

Verfasst: Di, 26.12.2017 17:21
von FeWe
Hallo,

ich habe eine Calc-Datei, die eine simple projektweise Arbeitszeiterfassung ist.

Je Monat gibt es eine Tabelle, man trägt oben ein Projekt ein und dann jeweils Stunden die sich summieren etc. Beispieldatei im Anhang.

Jetzt würde ich gerne eine Projektweise Auswertung machen, und komme mit SUMMEWENN auch schon recht weit, ich würde aber gerne den Tabellennamen (also den Monat) auch gerne referenzieren, da bekomm ich aber damit nicht hin:

=SUMMEWENN(Januar.$C$2:$F$2;C$4;Januar.$D$11:$G$11)
;C$4; ist der referenzierte Projektname, Januar würde ich gerne referenzieren.


Beim googlen bin ich auf Indirekt gestoßen:
=INDIREKT("" & A18 & ".D11")
damit bekomme ich zwar die Tabelle dynamisch, aber sonst nix mehr referenziert und die Verbinung mit Summewenn ist mir unklar.

Perspektivisch würde ich gerne die Erfassung von mehreren dieser Arbeitszeitdateien von einer Datei aus machen, aber das ist dann der nächste Schritt.

Simplifizierte Datei mit den Bezügen im Anhang. Benutze OO 4.1.1 auf OSX

Gruß
Fewe

Sundenliste test.ods
(11.73 KiB) 36-mal heruntergeladen

Re: Andere Tabelle dynamisch referenzieren / SUMMEWENN und INDIREKT

Verfasst: Mi, 27.12.2017 10:14
von paljass
Hi,
für den zweiten Januar in deiner Tabelle (also Zeile 18)

Code: Alles auswählen

=SUMMEWENN(INDIREKT($A18&".$C$2:$F$2");C$4;INDIREKT($A18&".$D$11:$G$11"))
.

Gruß
paljass

Re: Andere Tabelle dynamisch referenzieren / SUMMEWENN und INDIREKT

Verfasst: Mi, 27.12.2017 13:14
von FeWe
Vielen Dank!
Wenn man die Lösung anguckt, siehts so aus als hätte ich drauf kommen müssen, ging aber nicht ;) Klappt wunderbar und löst mein Problem.