Seite 1 von 1

Excel Problem

Verfasst: Di, 02.01.2018 23:21
von Daniel1234
Hallo,

folgende Frage:

Falls Zelle A1 und B1 gefüllt sind soll er die prozentuale Wertveränderung ausrechnen.
Falls beide Zellen leer sind soll er "" ausgeben.
Falls nur Zelle A einen Wert ausgibt so sollte Excel hier den Wert der Zelle ausgeben.

Ich habe es versucht mit folgende Formel zu lösen und erkenne meinen Fehler nicht.
Leider wird mir statt dem Wert der Zelle nur 100% ausgeben.

=WENN(ISTLEER(A1)*UND(ISTLEER(B1)),"",WENN(ISTLEER(A1)*ODER(ISTLEER(B1)),A1,(B1-A1)/A1))

A B C
1 25000.00 30000.00 20.00%
2 25000.00 100,00%
3
4 16000.00 12000.00 -25.00%

Danke für eure Hilfe!!

Re: Excel Problem

Verfasst: Di, 02.01.2018 23:26
von Daniel 1234
Diesmal etwas übersichtlicher. Sorry!

1 25000.00 30000.00 20.00%
2 25000.00 -100.00%
3
4 16000.00 12000.00 -25.00%

Re: Excel Problem

Verfasst: Di, 02.01.2018 23:42
von Daniel1234
Jetzt sollte es aber klappen.

Statt denn 100% sollte Excel hier egtl. 25.000 ausgeben.
Excel.JPG
Excel.JPG (16.61 KiB) 1237 mal betrachtet

Re: Excel Problem

Verfasst: Di, 02.01.2018 23:56
von echo
=WENN(ISTLEER(A1)*UND(ISTLEER(B1)),"",WENN(ISTLEER(A1)*ODER(ISTLEER(B1)),A1,(B1-A1)/A1))
Klammern falsch und alle Trennungen Semikolon nicht Komma!!

Hallo
benutze beim erstellen deiner Formel doch mal den Formel-Assistent links neben der Eingabezelle (Fx)
Dann kommst du schnell drauf, das das Trennzeichen einer wenn-Funktion nicht das Komma sondern das Semikolon ist.
Der Assistent fügt es nämlich selbstständig ein.
*und ist ebenfalls die Falsche Syntax
Eine Multiplikation ist wie eine und-Verknüpfung da muss dann das UND weg alternative, das UND nach vorne, dann die Prüfungen getrennt mit Semikolon.
*ODER
DITO Eine Addition der Prüfungen würde einer ODER-Prüfung entsprechen, alternative wäre wieder das ODER nach vorne, Prüfungen getrennt durch Semikolon.

Ich habe die Formel mal nur auf Funktion angepasst, ob die Berechnungen so sind wie sollen ist mir aus der Vorlage nicht ganz ersichtlich
=WENN(UND(ISTLEER(A1);ISTLEER(B1));"";WENN(ODER(ISTLEER(A1);ISTLEER(B1));A1;(B1-A1)/A1))
Gruß Holger
PS Dies ist eigendlich kein Excel- sondern ein Calc- Forum

Re: Excel Problem

Verfasst: Mi, 03.01.2018 11:44
von Daniel1234
Hallo Holger,

so wie du es geschrieben hast funktioniert es!

Vielen Dank!