Abfrage mit 3 Kriterien

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

HWurst

Abfrage mit 3 Kriterien

Beitrag von HWurst » Sa, 13.01.2018 18:38

Hallo,
ich habe eine Preisliste mit den angaben (Spalten) Format, Material, stärke und Preis.
Bsp Kleinformat, Glas, 8mm, 10,00€.
Natürlich gibt es alle angeben mehrfach aber in der Kombination nur einmal!

In einer anderen Tabele kann man per Dropdownmenu die auswahl treffen.

Geht sowas wie
Index Preis ; Vergleich 1 ; Vergleich 2 ; Vergleich 3
Index(Preis.A1:A10 ; Vergleich(Format abfrage ; Format A1:A10) & Vergleich(Material abfr. ; Material A1:A10) & Vergleich(Stärke abfr. ; Stärke A1:A10)

Danke für Eure hilfe
cu Hans

Mondblatt24
*****
Beiträge: 220
Registriert: So, 14.05.2017 16:11

Re: Abfrage mit 3 Kriterien

Beitrag von Mondblatt24 » Sa, 13.01.2018 19:33

Hallo,
versuche SUMMEWENNS()

Gruß Peter.
Win.10(x64)__ LO 5.4.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

HWurst

Re: Abfrage mit 3 Kriterien

Beitrag von HWurst » Sa, 13.01.2018 19:47

Danke,
stimmt solange es nur ein Treffer gibt!
Kennst du auch eine andere Lösung?

LG Hans

Mondblatt24
*****
Beiträge: 220
Registriert: So, 14.05.2017 16:11

Re: Abfrage mit 3 Kriterien

Beitrag von Mondblatt24 » So, 14.01.2018 09:23

Hallo Hans,
stimmt solange es nur ein Treffer gibt!
verwechsel bitte nicht Summewenn mit Summewenns.

Gruß Peter.
Win.10(x64)__ LO 5.4.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

Gast

Re: Abfrage mit 3 Kriterien

Beitrag von Gast » So, 14.01.2018 11:27

Servus,

wenn Du angemeldet bist, kann unterhalb des Antwortfeldes eine Beispieldatei hochgeladen werden.
Das würde helfen.

Gast

mikeleb
******
Beiträge: 685
Registriert: Fr, 09.12.2011 16:50

Re: Abfrage mit 3 Kriterien

Beitrag von mikeleb » So, 14.01.2018 13:26

Hallo,
Natürlich gibt es alle angeben mehrfach aber in der Kombination nur einmal!
Dann sollte es mehrere Treffer doch nicht geben?!
Anbei mal zwei Varianten. Die effektivste und schnellste wäre wohl eine Pivotabelle (mit dem Spezialfilter ginge auch noch was).
Dateianhänge
liste mit mehreren kriterien.ods
(13.07 KiB) 35-mal heruntergeladen
Gruß,
mikeleb

HWurst

Re: Abfrage mit 3 Kriterien

Beitrag von HWurst » So, 14.01.2018 16:14

Danke
für eure Hilfe!
Ich habe mich für die Lösung von Mikeleb entschieden:
=SUMMENPRODUKT(INDEX(material;;1)=H3;INDEX(material;;2)=H4;INDEX(material;;3)=H5;INDEX(material;;4))

LG Hans
Und nochmal danke an alle!!!

Mondblatt24
*****
Beiträge: 220
Registriert: So, 14.05.2017 16:11

Re: Abfrage mit 3 Kriterien

Beitrag von Mondblatt24 » So, 14.01.2018 17:08

Hallo Hans,
nichts anderes macht die Funktion SUMMEWENNS().
MfG Peter.
Win.10(x64)__ LO 5.4.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

Antworten