SUMMENPRODUKT Zeiterfassung

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

uljahoff

SUMMENPRODUKT Zeiterfassung

Beitrag von uljahoff » Mo, 15.01.2018 17:01

Hallo,
habe folgende Tabelle (siehe Dateianhang)

Code: Alles auswählen

    A        B         C        D
1  Datum   X.Y.2018  Y.X.2018  Zeit
2  Name1     100       100     =SUMMENPRODUKT(B1:C1=100;$B$5:$C$5)  Ergebnis Name1=(16 Stunden)
3  Name2      40       100     Formel für Ergebnis Name2=(10 Stunden)
4  Name3      60        40     Formel für Ergebnis Name3=(6 Stunden)
5  Stunden     8         8
Moderationshinweis: Zur übersichtlicheren Darstellung und besserer Lesbarkeit der Tabelle [ ​code][​/code] Tags eingefügt. — lorbass, Moderator

mit der Formel =SUMMENPRODUKT
will ich die individuelle Zeit für Name1,2,3 erfassen. Die Werte 100, 60, 40 stehen für unterschiedliche Anwesenheitszeiten.
100 steht für 8 Stunden, 60 steht für (8 halbe = 4 Stunden), 40 steht für (8 viertel = 2 Stunden).

Wie muss die allgemeine SUMMENPRODUKTFormel aussehen damit die unterschiedlichen Zeiten für in Spalte D erfasst sind?
Vielen Dank im voraus.

Mondblatt24
*****
Beiträge: 261
Registriert: So, 14.05.2017 16:11

Re: SUMMENPRODUKT Zeiterfassung

Beitrag von Mondblatt24 » Mo, 15.01.2018 17:22

Hallo,
habe folgende Tabelle (siehe Dateianhang)
wo ist der Dateianhang?

MfG Peter.
Win.10(x64)__ LO 6.0.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

uljanoff
*
Beiträge: 12
Registriert: So, 20.03.2016 21:20

Re: SUMMENPRODUKT Zeiterfassung

Beitrag von uljanoff » Mo, 15.01.2018 17:38

Dateianhang
SUMMENPRODUKT Zeiterfassung.ods
(10.59 KiB) 39-mal heruntergeladen

Mondblatt24
*****
Beiträge: 261
Registriert: So, 14.05.2017 16:11

Re: SUMMENPRODUKT Zeiterfassung

Beitrag von Mondblatt24 » Mo, 15.01.2018 17:46

Hallo,
vielleicht kannst du hiermit was anfangen.

Gruß Peter.
Dateianhänge
SUMMENPRODUKT Zeiterfassung.ods
(10.6 KiB) 35-mal heruntergeladen
Win.10(x64)__ LO 6.0.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

mikeleb
******
Beiträge: 737
Registriert: Fr, 09.12.2011 16:50

Re: SUMMENPRODUKT Zeiterfassung

Beitrag von mikeleb » Mo, 15.01.2018 21:02

Hallo,
folgende Formel liefert auch das gewünschte Ergebnis:

Code: Alles auswählen

=(B2+C2)/10-4
Gruß,
mikeleb

uljanoff
*
Beiträge: 12
Registriert: So, 20.03.2016 21:20

Re: SUMMENPRODUKT Zeiterfassung

Beitrag von uljanoff » Di, 16.01.2018 15:53

Hallo Peter,
danke für Deine schnelle Antwort.
Die Formel mit SVERWEIS geht schon, nur muss ich dann jeden neuen Tag ständig hinzu addieren und die Formel wird übers Jahr hin immer länger... :-(
Eine Formel mit SUMMENPRODUKT die, die jeweiligen Bedingungen der Werte 100, 60, 40, die für unterschiedliche Anwesenheitszeiten stehen, bezogen auf die 8 Stunden scheint mir eleganter. Nur wie kann ich das (als WENN DANN) ins SUMMENPRODUKT formulieren?
Besten dank im voraus.
Hier der neue Anhang.
Zeiterfassung-2 SVERWEIS SUMMENPRODUKT.ods
(11.82 KiB) 23-mal heruntergeladen

paljass
******
Beiträge: 683
Registriert: Do, 25.10.2012 07:25

Re: SUMMENPRODUKT Zeiterfassung

Beitrag von paljass » Di, 16.01.2018 16:46

Hi,
in Abänderung von mikelebs Formel kannst du doch für Name 1

Code: Alles auswählen

=SUMME(C4:H4)/10-ANZAHL(C4:H4)*2
nehmen, ergibt nach kurzen Tests meinerseits das gleiche Ergebnis wie deine SVerweise.

Gruß
paljass

P.S.: Wenn es was anderes sein soll, dann

Code: Alles auswählen

=SUMME(WENN(C6:H6=100;8;WENN(C6:H6=60;4;WENN(C6:H6=40;2;0))))
, abschließen mit Strg-Umschalt-Enter als Matrixformel.
EDV ist wie U-Boot fahren - machst du ein Fenster auf, fangen die Probleme an.

uljanoff
*
Beiträge: 12
Registriert: So, 20.03.2016 21:20

Re: SUMMENPRODUKT Zeiterfassung

Beitrag von uljanoff » Di, 16.01.2018 17:45

Hallo paljass
mit deinen formeln bekomm ich keine werte.
siehe anhang
Zeiterfassung-3 SVERWEIS SUMMENPRODUKT.ods
(14.5 KiB) 30-mal heruntergeladen

Mondblatt24
*****
Beiträge: 261
Registriert: So, 14.05.2017 16:11

Re: SUMMENPRODUKT Zeiterfassung

Beitrag von Mondblatt24 » Di, 16.01.2018 18:18

Hallo,
wenn du die Formel falsch übernimmst, kann sie nicht funktionieren.
von paljass » Heute 16:46
Hi,
in Abänderung von mikelebs Formel kannst du doch für Name 1

Code: Alles auswählen

=SUMME(C4:H4)/10-ANZAHL(C4:H4)*2
deine Formel

Code: Alles auswählen

=SUMME((C4:H4)/10-ANZAHL(C4:H4)*2)
Gruß Peter.
Win.10(x64)__ LO 6.0.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

ulja

Re: SUMMENPRODUKT Zeiterfassung

Beitrag von ulja » Di, 16.01.2018 20:11

Hallo paljass, Hallo Peter
ups da ist eine Klammmer zuviel:

Danke, für den Hinweis Peter
und danke für die Formel paljass und auch an mikeleb

Super!!! die Formel =SUMME(C4:H4)/10-ANZAHL(C4:H4)*2 ist die, die ich suchte.

Wie funktioniert die Formel?

Wo sind die Werte 100, 60, 40 eingebettet, die für unterschiedliche Anwesenheitszeiten stehen?

Herzlichen Dank

mikeleb
******
Beiträge: 737
Registriert: Fr, 09.12.2011 16:50

Re: SUMMENPRODUKT Zeiterfassung

Beitrag von mikeleb » Di, 16.01.2018 20:50

Hallo,
Wie funktioniert die Formel?
Subtrahiert man von den Werten 100;60;40 die Zahl 20 so erhält man 80;40;20. Noch durch 10 dividiert sind es 8;4;2 - also die gesuchte Stundenanzahl. (x-20)/10=x/10-2
Spannend ist für mich eher die umgekehrte Frage: Warum arbeitest du nicht gleich mit 8;4;2 ? Warum steht also 100 für 8 Stunden? Ich dachte zunächst an einen prozentuale Aussage, aber das ist es nicht.
Gruß,
mikeleb

uija

Re: SUMMENPRODUKT Zeiterfassung

Beitrag von uija » Di, 16.01.2018 23:15

hallo mikeleb
danke für die elegante Formel und deren Aufschlüsselung.
Stimmt 100, 60, 40 ist keine prozentuale Aussagen zu 8,4,2.
Mit 8,4,2 kann ich nicht arbeiten, weil
100, 60, 40 Werte sind, die in „Lern-Zeit“ umgerechnet wird.
8 ist die gesamte „Lehr-Zeit“.

Vielen Dank.

Antworten