Text in Zelle (Zahl + Buchstaben) in wert umwandeln und in matrixabfrage verwenden ?

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Katko
Beiträge: 7
Registriert: Sa, 07.10.2017 12:14

Text in Zelle (Zahl + Buchstaben) in wert umwandeln und in matrixabfrage verwenden ?

Beitrag von Katko » So, 21.01.2018 14:02

Moin Leuts, hab da ein Problem !
Wie kann ich die Formel aus Zelle H1 in die Matrixformel in H5 einbauen, so daß ich die umgewandelten Werte aus Spalte B direkt summieren kann ?
Der Umweg über eine zusätzliche Spalte kommt leider nicht in Frage.
Einer ´ne Idee ?
Ich krieg hier gleich ´nen Anfall, komm nich drauf, vollkommen ahnungslos !

Vielen Dank im Voraus
beispiel.ods
(11.58 KiB) 21-mal heruntergeladen

HeritzP
*****
Beiträge: 273
Registriert: So, 22.12.2013 11:23

Re: Text in Zelle (Zahl + Buchstaben) in wert umwandeln und in matrixabfrage verwenden ?

Beitrag von HeritzP » So, 21.01.2018 15:44

Hallo,

als Matrixformel.

Code: Alles auswählen

=SUMMEWENNS(WERT(WECHSELN(LINKS(D1:D10;SUCHEN(" ";D1:D10;1)-1) ;".";",";1));MONAT(A1:A10);1;C1:C10;"Deposit")
Gruß HeritzP

Katko
Beiträge: 7
Registriert: Sa, 07.10.2017 12:14

Re: Text in Zelle (Zahl + Buchstaben) in wert umwandeln und in matrixabfrage verwenden ?

Beitrag von Katko » So, 21.01.2018 15:57

Hab´s grad´ entdeckt. Du scheinst ja ein echtes Calc-Genie zu sein. Oder bist Mathematiker, Informatiker oder sonst irgendein ?-iker Also wenn das hinhaut, müsst ich dir eigentlich ein Bier ausgeben.

Probier ich gleich aus, danke !

Katko
Beiträge: 7
Registriert: Sa, 07.10.2017 12:14

Re: Text in Zelle (Zahl + Buchstaben) in wert umwandeln und in matrixabfrage verwenden ?

Beitrag von Katko » So, 21.01.2018 16:01

Genial, verstehe ich im Moment zwar noch nicht, aber funzt super !
Vielleicht gibt´s ja noch irgendwann ne Erklärung !?

Danke, danke, danke

Antworten