Stundenzahl auf viertel runden

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

djchaques
Beiträge: 8
Registriert: Di, 05.12.2017 13:51

Stundenzahl auf viertel runden

Beitrag von djchaques » Fr, 16.02.2018 15:08

Hallo zusammen. Die Suche bringt mich nicht weiter. Mein Problem:
Für Arbeitszeitberechnungen muss ich eine positive Stundenzahl immer auf eine viertel Stunde abrunden.
Und eine negative Stundenzahl immer auf eine viertel Stunde aufrunden.
(Alle Zeiten wurden schon vorher in Dezimalwerte umgewandelt)

Beispiele:

positiv:
1,08 wird 1,00
2,14 wird 2,00
4,25 bleibt 4,25
1,26 wird 1,25
1,58 wird 1,50
6,99 wird 6,75
10 bleibt 10
11,234 wird 11

und negativ so:
-1,08 wird -1,25
-2,14 wird -2,25
-4,25 bleibt -4,25
-1,26 wird -1,50
-1,58 wird -1,75
-6,99 wird -7,00
-10 bleibt -10
-11,234 wird -11,25

Kann mir einer helfen? (Hinsichtlich einer Formel und nicht, weil es arbeitsrechtlich fragwürdig ist...) :lol:

F3K Total
********
Beiträge: 3269
Registriert: Mo, 28.02.2011 17:49

Re: Stundenzahl auf viertel runden

Beitrag von F3K Total » Fr, 16.02.2018 15:53

Hi,
angenommen die 1. Zahl steht in A2, dann schreibe diese z.B diese Formel in B2:

Code: Alles auswählen

=WENN(A2>0;ABRUNDEN(A2*4;0)/4;AUFRUNDEN(A2*4;0)/4)
Sie kann dann heruntergezogen werden.
Gruß R

djchaques
Beiträge: 8
Registriert: Di, 05.12.2017 13:51

Re: Stundenzahl auf viertel runden

Beitrag von djchaques » Fr, 16.02.2018 16:02

Vielen Dank!!!!!!
Das hat super funktioniert.
Und so schnell, ich bin echt begeistert.

housefreund
******
Beiträge: 500
Registriert: Do, 03.01.2008 23:23

Re: Stundenzahl auf viertel runden

Beitrag von housefreund » So, 18.02.2018 21:57

Ich weiß, gar nicht Thema hier und eigentlich auch gar nicht Bestandteil des Forums, aber wie kommt es denn zu dieser Regelung? :)

Antworten