Rechenzeichen aus zelle auslesen und in einer Formel verwenden

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

rufius
*
Beiträge: 13
Registriert: Fr, 16.11.2012 10:54

Rechenzeichen aus zelle auslesen und in einer Formel verwenden

Beitrag von rufius » Do, 01.03.2018 07:36

Hallo

Ich möchte aus einer Zelle zB." + " in einer Formel benutzen.

Also a1 = +
a2 = 2
a3 =3

Formel =a2..a1..a3
Ergebnis 5

wenn ich a1 in minus änere
Ergebnis -1
Hat jemand eine Idee.

Stephan
********
Beiträge: 10471
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Rechenzeichen aus zelle auslesen und in einer Formel verwenden

Beitrag von Stephan » Do, 01.03.2018 08:15

z.B.:
=WENN(A1="+";A2+A3;WENN(A1="-";A2-A3;""))


GRuß
Stephan

rufius
*
Beiträge: 13
Registriert: Fr, 16.11.2012 10:54

Re: Rechenzeichen aus zelle auslesen und in einer Formel verwenden

Beitrag von rufius » Do, 01.03.2018 08:25

Vielen Dank
Ich vergass zu erwähnen das des mehrer dieser optionen gibt
a1---a2---a3 ---a4---a5---a6---a7---a8 usw
34---15---"+"----36--12----"-"---14---0,5 - 9 1,5

Zum Schluß soll das Erbnis
a1*a2 + (aus a3) a4*a5 - (aus a6) a7*a8
Ich habe es mit verketten versucht diese ist aber eine Text funktion.
Kann man die Verkettung als Formel ausgeben?
also Textfeld '=34+15 in ein Ergebnis

Mondblatt24
*****
Beiträge: 211
Registriert: So, 14.05.2017 16:11

Re: Rechenzeichen aus zelle auslesen und in einer Formel verwenden

Beitrag von Mondblatt24 » Do, 01.03.2018 08:32

Hallo,
eine Beispieldatei wäre vorteilhafter und übersichtlicher gewesen!
Also, auf geht's 8)

VG Peter.
Win.10(x64)__ LO 5.4.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

Antworten