[GELÖST] Formel funktioniert nicht

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

CäsarJulius
Beiträge: 1
Registriert: Mo, 19.03.2018 19:20

[GELÖST] Formel funktioniert nicht

Beitrag von CäsarJulius » Mo, 19.03.2018 22:26

Hallo. Ich habe ein Problem mit dieser Formel: =SUMMENPRODUKT(Monat(A10:A3300)=5;AI10:AI3300 In der Spalte A10:A3300 ist das Datum abgelegt, in der AI10:AI3300 die Beträge. Benutze ich die Formel in der Form, werden alle Tages Beträge addiert, zu einen Gesamt-Monat, zb. 1-31 Mai.
Ich möchte aber jeden einzelnen Tag, die Beträge addiert haben, zumal es viele Buchungen an einen einzelnen Tag gibt.
Wie könnte jetzt die Formel aussehen...wer kann helfen?
Groß DANK vorab

Mondblatt24
*****
Beiträge: 269
Registriert: So, 14.05.2017 16:11

Re: Formel funktioniert nicht

Beitrag von Mondblatt24 » Di, 20.03.2018 07:32

Hallo,

Code: Alles auswählen

=SUMMENPRODUKT(TAG(A10:A3300)=1;MONAT(A10:A3300)=5;AI10:AI3300)
Gruß Peter
Win.10(x64)__ LO 6.0.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

Hiker
****
Beiträge: 125
Registriert: Mo, 08.09.2014 21:34
Wohnort: Berlin

Re: Formel funktioniert nicht

Beitrag von Hiker » Di, 20.03.2018 07:40

HAllo,

das Selektionskriterium steht am Anfang Deiner Formel: Monat(A10:A3300)=5

Wenn Du ein konkretes Datum vorgibst und MONAT weglässt, arbeitet die Formel sicher auch für Einzeltage:
z.B. für das Datum, was in A10 steht:

Code: Alles auswählen

=SUMMENPRODUKT(A10;AI10:AI3300)
Das nächste Problem ist dann eher Tabellendesign: Möchtest Du tatsächlich nur sehen was noch am selben Tag
passiert ist, funktioniert die obige Formel gut und Du brauchst nur eine Zelle.
Willst Du das Ergebnis für alle Tage hast Du einen Ergebnisvektor, und die Frage ist wohin damit?

Um beispielsweise in eine großen Tabelle sozusagen Zwischensummen pro Tag einzuziehen würde ich die Formel
generell nicht empfehlen, da zuviele Zellen verknüpft werden, was bei großen Tabellen in der Bedienung zäh wird,
da Calc bei jeder Änderung eine sehr große Zahl von Zellen neu berechnen/berücksichtigen muß.
Da würde ich eher mit einer gleitenden Summe in einer (ausgeblendeten) Hilfsspalte arbeiten. z.B. in H10

Code: Alles auswählen

=WENN(A10=A9;AI10+AI9;AI10)

und dann in einer Summenspalte I bei Bedarf anzeigen also für I10:

Code: Alles auswählen

=WENN(A10=A11;"";H10)
mfg,
Jörn
Libre Office 6.0.4.2 (Win8.1 Pro, Win 10 Pro) / Libre Office 4.2 (Win 7) / AOO (Win 7)

Gast

Re: Formel funktioniert nicht [GELÖST]

Beitrag von Gast » Di, 20.03.2018 08:29

Hiker und den anderen...ein großes DANKE. Mein Problem ist gelöst.

Gast

Re: Formel funktioniert nicht [GELÖST]

Beitrag von Gast » Di, 20.03.2018 08:31

Mondblatt...genau die Formel brauche ich. Danke

Mondblatt24
*****
Beiträge: 269
Registriert: So, 14.05.2017 16:11

Re: Formel funktioniert nicht

Beitrag von Mondblatt24 » Di, 20.03.2018 08:54

Hallo,
Re: Formel funktioniert nicht [GELÖST]
Wenn das Thema als Gelöst markiert wird, dann bitte im Betreff der Frage!
Sonst wird es in der Übersicht mit den Fragen nicht angezeigt.

MfG Peter
Win.10(x64)__ LO 6.0.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

Benutzeravatar
lorbass
********
Beiträge: 4116
Registriert: Mo, 01.05.2006 21:29
Wohnort: Bonn

Re: Formel funktioniert nicht

Beitrag von lorbass » Di, 20.03.2018 18:22

Mondblatt24 hat geschrieben:
Di, 20.03.2018 08:54
Wenn das Thema als Gelöst markiert wird, dann bitte im Betreff der Frage!
Als Gast kann er/sie/es aber nicht. Ich erledige das dann mal…

Gruß
lorbass, Moderator

Antworten