mehrere Wenn Funktionen

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

teamdj
Beiträge: 5
Registriert: Fr, 20.04.2018 07:09

mehrere Wenn Funktionen

Beitrag von teamdj » Fr, 20.04.2018 07:32

Hallo,

meine Tabelle Setup:

B C
2 Münze W1 -8,90 €
3 Münze W2 -10,90 €
4 Münze W3 -13,50 €
5 10er W1 +79,00 €
6 10er W2 +99,00 €
7 10er W3 +119,00 €
8 GuS. W1 +8,90 €
9 GuS. W2 +10,90 €
10 GuS. W3 +13,50 €

jetzt möchte ich einer Tabelle Ausdruck in der Zelle C 25 mehrere Wenn Funktionen (mehr als 7) haben

A B C
24 Bezeichnung Anzahl Summe
25 Münze W1 1 Formel =WENN(A25=Setup.$B$2;Setup.$C$2*B25;WENN(A25=Setup.$B$3;Setup.$C$3*B25) usw.
26 Münze W2 1 Formel =WENN(A26=Setup.$B$2;Setup.$C$2*B26;WENN(A26=Setup.$B$3;Setup.$C$3*B26) usw.

hinter usw. in der Formel sollen die anderen Wenn Bedingungen kommen also:
Formel =WENN(A25=Setup.$B$2;Setup.$C$2*B25;WENN(A25=Setup.$B$3;Setup.$C$3*B25;WENN(A25=Setup.$B$4;Setup.$C$4*B25)

Vor der Formel soll noch stehen =WENN(A25="";"") quasi wenn in A25 nichts steht, dann soll in C25 auch nichts stehen
wie kann ich das regeln ?

Danke für eure Hilfe:

paljass
******
Beiträge: 683
Registriert: Do, 25.10.2012 07:25

Re: mehrere Wenn Funktionen

Beitrag von paljass » Fr, 20.04.2018 08:20

Hi,
ich denke fast, dass man das Problem ohne die vielen Wenn-Verschachtelungen mit Summenprodukt() lösen kann. Stell mal eine Beispieltabelle zur Verfügung und beschreibe noch mal genau, was du für ein Ergebnis erwartest.

Gruß
paljass
EDV ist wie U-Boot fahren - machst du ein Fenster auf, fangen die Probleme an.

teamdj
Beiträge: 5
Registriert: Fr, 20.04.2018 07:09

Re: mehrere Wenn Funktionen

Beitrag von teamdj » Fr, 20.04.2018 16:34

hier einmal die Beispieltabelle,

Ich möchte in der Tabelle (Ausdruck) Berechnungen vornehme,
die Daten zum berechnen sind in der Tabelle (Setup) hinterlegt.

Daten Tabelle Setup:
10er W1 ist quasi eine 10er Karte für Wäsche 1 die Wäsche 1 kostet 8,90 €
Der Kunde bekommt quasi 10 Münzen und zahlt 79,00 € dafür

jetzt soll in der Tabelle(Ausdruck) gerechnet werden.
Quasi wenn Wir die Abrechnung erstellen dann tragen wir in der Tabelle
unter (Bezeichnung) ein, was verkauft wurde bsp. 10er W1
jetzt soll in Summe automatisch der Betrag 79,00 € stehen
Wenn A25 allerdings leer ist dann soll in allen folgenden Spalten nichts stehen.
Dateianhänge
BeispielTabelle.ods
(16.64 KiB) 32-mal heruntergeladen

Mondblatt24
*****
Beiträge: 248
Registriert: So, 14.05.2017 16:11

Re: mehrere Wenn Funktionen

Beitrag von Mondblatt24 » Fr, 20.04.2018 18:01

Hallo,
hier mein Vorschlag.

BeispielTabelle.ods
(12.35 KiB) 37-mal heruntergeladen


Gruß Peter
Win.10(x64)__ LO 5.4.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

teamdj
Beiträge: 5
Registriert: Fr, 20.04.2018 07:09

Re: mehrere Wenn Funktionen

Beitrag von teamdj » Fr, 20.04.2018 18:10

Hallo Mondblatt,
Danke für deine schnelel Antwort im Grunde ist das schon die Perfekte Lösung.
Leider habe ich jetzt einmal alles druchprobiert es funktioniert auch
mit der Berechnung in der Tabelle nur leider nicht bei folgenden Angaben

GutS. W1 +
GutS. W2 +
GutS. W3 +
falls es daran liegen sollte das die Bezeichnung wegen einem Punkt oder + Zeichen stört, dann
kann ich das ändern.

teamdj
Beiträge: 5
Registriert: Fr, 20.04.2018 07:09

Re: mehrere Wenn Funktionen

Beitrag von teamdj » Fr, 20.04.2018 18:19

Hallo
ich habe den Wert ( GutS. W1 +) jetzt geänder auf ( GutSVerk W1 ) und jetzt funktioniert es

paljass
******
Beiträge: 683
Registriert: Do, 25.10.2012 07:25

Re: mehrere Wenn Funktionen

Beitrag von paljass » Fr, 20.04.2018 18:20

Hi teamdj,
in der Tat liegt es an dem Pluszeichen - dieses wird in Lo/AOo als regulärer Ausdruck benutzt.
Du musst also entweder eine Zeichen wählen, das nicht als regulärer Ausdruck gebraucht wird oder du stellst unter Extras -Oprionen - Calc - Berechnen die Option "Reguläre Ausdrücke in Formeln ermgölichen" aus.

Gruß
paljass
EDV ist wie U-Boot fahren - machst du ein Fenster auf, fangen die Probleme an.

mikeleb
******
Beiträge: 723
Registriert: Fr, 09.12.2011 16:50

Re: mehrere Wenn Funktionen

Beitrag von mikeleb » Fr, 20.04.2018 19:36

Hallo,
es ginge auch, wenn das Pluszeichen maskiert wird:

Code: Alles auswählen

=WENN(A25="";"";SUMMEWENN(Setup.$B$2:$B$36;WECHSELN(A25;"+";"\+");Setup.$C$2:$C$36)*B25)
Gruß,
mikeleb

teamdj
Beiträge: 5
Registriert: Fr, 20.04.2018 07:09

Re: mehrere Wenn Funktionen

Beitrag von teamdj » Fr, 20.04.2018 21:47

Super Danke euch allen !!!

Ich habe es hinbekommen.
Gerne würde ich jetzt noch eine Verfeinerung vornehmen in der "Auswahlliste"

Splate A (Bezeichnung)
in der Auswahlliste möchte ich gerne das die komplette Liste angezeigt wird
ohne das ich scrollen muß.
Geht das ?

Antworten