Durchschnitte bilden aller Zeilen mit gleichem Beginn

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

0101

Durchschnitte bilden aller Zeilen mit gleichem Beginn

Beitrag von 0101 » Sa, 28.04.2018 18:00

Hallo,

ich habe eine etwas schwierige Aufgabenstellung und weiß gar nicht, ob es hierfür eine Lösung im OO gibt. Folgendes Problem: Ich habe eine Tabelle mit verschiedenen Angaben zu Wohnungen. Eine Zeile ist eine Wohnung. Weiterer Aufbau:

Spalte 1 - Landkreis
Spalte 2 - Kaltmiete
Spalte 3 - Warmmiete

Insgesamt habe ich 367 Zeilen bzw. 367 Wohnungen inklusive der 3 Angaben.
Mein Ziel: Ich möchte nun in Spalte 4 den WarmmieteDurchschnitt und in Spalte 5 den Kaltmietendurchschnitt des jeweiligen Landkreises angezeigt haben. Wenn in den 367 Zeilen beispielsweise 4x Aachen vorkommt, möchte ich, dass es automatisch den Kaltmietendurchschnitt von diesen 4 Zeilen berechnet und einträgt. Versteht ihr mein Anliegen? Gibt es hierfür einen praktikablen Weg?

Benutzeravatar
Faol
***
Beiträge: 73
Registriert: Di, 26.01.2016 21:18

Re: Durchschnitte bilden aller Zeilen mit gleichem Beginn

Beitrag von Faol » Sa, 28.04.2018 19:39

Hallo,

als erstes fällt mir hierzu eine Pivottabelle ein.
Dazu folgende Links:
Datenpilot/Pivottabelle
Hier ein Video:
Youtube

Gruß
Faol
⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒
Win.10 Prof. (x64) • AOO 4.1.5
⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐

clag
********
Beiträge: 3543
Registriert: Di, 27.01.2009 15:30

Re: Durchschnitte bilden aller Zeilen mit gleichem Beginn

Beitrag von clag » So, 29.04.2018 10:48

Hallo 0101
Dein Anliegen lässt sich mit den Funktionen SUMMEWENN() und ZÄHLENWENN() recht einfach lösen
prinzipiell

Code: Alles auswählen

=SUMMEWENN(Bereich;Kriterien;Summenbereich)/ZÄHLENWENN(Bereich;Kriterien)
konkret

Code: Alles auswählen

=SUMMEWENN($B$2:$B$368;$B2;$C$2:$C$368)/ZÄHLENWENN($B$2:$B$368;B2)
habe für Dich eine Beispieldatei erstellt
guckst Du hier
Mittelwerte-LK.ods
(30.12 KiB) 34-mal heruntergeladen
viel Spaß
LG
clag

nutzt: WinXP SP3 / AOO 4.1.2 / Firefox

Antworten