Datum zwischen A und B = WAHR/FALSCH

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

gunman
*
Beiträge: 16
Registriert: Fr, 15.12.2006 18:43

Datum zwischen A und B = WAHR/FALSCH

Beitrag von gunman » Do, 03.05.2018 18:35

Hallo Leute,

kann mir bitte jemand dabei helfen? Bin irgendwie zu blöd dafür:

Welche Formel muss in Spalte D stehen?

Danke für eure Hilfe,
gun

Bildschirmfoto 2018-05-03 um 18.33.19.png
Bildschirmfoto 2018-05-03 um 18.33.19.png (54.16 KiB) 5571 mal betrachtet

quotsi
****
Beiträge: 186
Registriert: Do, 14.11.2013 10:04

Re: Datum zwischen A und B = WAHR/FALSCH

Beitrag von quotsi » Do, 03.05.2018 19:13

Ist das eine Hausaufgabe oder eine Strafe Deiner Eltern?
Eigentlich ist die Logik klar: Jedes der Daten in Spalte C soll nicht in den 4 Datumsbereichen zwischen A und B (1...4) liegen.
Dann braucht man nur die Formel in D1 eintragen und am Punkt bis zur 31. Zeile runterziehen.
Die Formel ist aber was Spezifisches für AOO oder LO, also keine Allgemeinbildung für die Schule, sondern eher was für einen Computerkurs.

Oder wolltest Du nur die Intelligenz (Konnen die das überhaupt lösen?) oder Dummheit (Sind sie so blöd, dass sie antworten?) der Anwesenden testen?

Egal, ich füge die Datei bei...
Dateianhänge
calc - logische Aufgabe.ods
(17.51 KiB) 26-mal heruntergeladen
win7pro - Avira - LO 5.4.4.7 (x64) - AOO 4.1.4

gunman
*
Beiträge: 16
Registriert: Fr, 15.12.2006 18:43

Re: Datum zwischen A und B = WAHR/FALSCH

Beitrag von gunman » Do, 03.05.2018 19:22

Danke quotsi!

Und nein, keine Verarsche. Ich hatte echt 'nen Hänger bzw. bin immer anderes ran gegangen! Danke, das ist die händische Lösung.

Ich habe immer versucht per "sverweis" zu arbeiten oder habe an eine Matrix { } gedacht. Bin nicht der Prof. Problem ist, wenn ich das Jahr voll mache, wird die Formel ziemlich lang. Es läuft darauf hinaus, bestimmt Zeiträume in einem Jahreskalenderblatt zu markieren. Aber wenn es keine andere Lösung gibt ...

Sorry, ich will niemand nerven und es ist auch nicht für die Schule. Dazu bin ich zu alt.

gun

echo
******
Beiträge: 722
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: Datum zwischen A und B = WAHR/FALSCH

Beitrag von echo » Do, 03.05.2018 20:30

Hallo, für D2 zum runter kopieren:

Code: Alles auswählen

=SUMMENPRODUKT(($A$2:$A$100<=C2)*($B$2:$B$100>=C2))
Ergebnis= 1 (WAHR) 0 (FALSCH)

Gruß Holger

Mondblatt24
*****
Beiträge: 212
Registriert: So, 14.05.2017 16:11

Re: Datum zwischen A und B = WAHR/FALSCH

Beitrag von Mondblatt24 » Do, 03.05.2018 20:35

Hallo,
wenn es darum geht z. B. Ferientermine im Kalender anzeigen zu lassen, geht dies auch mit der bedingten Formatierung.
Markiere den Bereich 1.1. - 31.12.


Kalender zum Beispiel Ferien.ods
(22.42 KiB) 29-mal heruntergeladen

MfG Peter

edit: fehler in der Formel!
richtig ist: =SUMMENPRODUKT(A4>=$AB$4:$AB$6;A4<=$AC$4:$AC$6
Win.10(x64)__ LO 5.4.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

gunman
*
Beiträge: 16
Registriert: Fr, 15.12.2006 18:43

Re: Datum zwischen A und B = WAHR/FALSCH

Beitrag von gunman » Fr, 04.05.2018 12:42

Ahh, Leute!

"Summenprodukt" und dann multiplizieren - das hatte ich nicht auf dem Schirm. Habe in meinen Versuchen immer die gesamte Matrix ausgelesen, nicht die Spalten separat. Fettes Danke, das wars!

Gruß, gun

Antworten