Seite 1 von 1

Ersatz für WENN/UND Funktion ohne Makro

Verfasst: Sa, 05.05.2018 19:39
von Faol
Hallo,

ich benötige ein Vergleichsfunktion (Formel!) für die folgende Beispieldatei.
Wenn Und Bedingungen.ods
(15.5 KiB) 33-mal heruntergeladen
Es gibt dort eine Eingabezelle, welche später von einem Makro im Sekundentakt
gesteuert wird und von einem Listener überwacht wird.
Der Listener tritt in Aktion, sobald sich die Ergebnis Zelle im Tabellenblatt ändert.
Die Abstände der Werte in Spalte A liegen genau bei 7200 Sekunden = 2 Stunden.

Nun möchte ich die Zeitvergleiche per Formel lösen.
Ich habe im Tabellenblatt bereits eine kombinierte WENN/UND Funktion
in der Ergebniszelle (E19) hinterlegt, allerdings ist hier wohl die Limitation
erreicht und weitere WENN-Verschachtelungen (>7) sind nicht möglich.

Unter den Spaltenüberschriften, "Anfangswert, "Endwert", "Ergebnis" ist zu sehen
wie die Berechnungen der Formel erfolgen sollen.

Ich bin für jede Idee dankbar.

Gruß
Faol

Re: Ersatz für WENN/UND Funktion ohne Makro

Verfasst: Sa, 05.05.2018 20:07
von HeritzP
Hallo,

teste folgende Formel.

Code: Alles auswählen

=VERWEIS(C19;C2:C13;E2:E13)
Gruß HeritzP

Re: Ersatz für WENN/UND Funktion ohne Makro

Verfasst: Sa, 05.05.2018 20:18
von Faol
Hallo HeritzP,

mit einer kleinen Erweiterung funktioniert die Formel:

=WENN(VERWEIS(C19;C2:C13;E2:E13)=86400;0;VERWEIS(C19;C2:C13;E2:E13))

Erweiterung weil:
79201 bis 86400 = 0
sein soll.

Vielen Dank

Gruß
Faol

Re: Ersatz für WENN/UND Funktion ohne Makro

Verfasst: Sa, 05.05.2018 20:33
von HeritzP
Hallo,

in E13 könnte man auch die 0 schreiben und dann Abfragen was passiert, wenn die Zahl höher als 86400 ist.

Gruß HeritzP