Werte in zwei Spalten miteinander multiplizieren und Ergebnisse davon summieren

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Jochen41df35

Werte in zwei Spalten miteinander multiplizieren und Ergebnisse davon summieren

Beitrag von Jochen41df35 » Mo, 04.06.2018 17:30

Ich habe 2 Spalten C und D. Von denen sollen die Werte zeilenweise miteinander multipliziert werden.
Also C2*D2, C3*D3 usw..Cn*Dn

Und am Ende die Ergebnisse davon dann summiert werden:
sum = C2*D2+C3*D3*...*Cn*Dn

Wie kann ich das automatisieren ohne jede Zeile einzeln aufzählen zu müssen?
Und wie kann ich diese Aufgabe ohne extra Spaltung für die Zwischenrechnung lösen?
Also so dass ich sum = C2*D2+C3*D3*...*Cn*Dn in einer Zelle drinstehen habe und die das dann auch einmal rechnet.

Mondblatt24
*****
Beiträge: 245
Registriert: So, 14.05.2017 16:11

Re: Werte in zwei Spalten miteinander multiplizieren und Ergebnisse davon summieren

Beitrag von Mondblatt24 » Mo, 04.06.2018 17:43

Hallo,
die Funktion Summenprodukt() ist dafür gemacht.


Gruß Peter
Win.10(x64)__ LO 5.4.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

Jochen41df35

Re: Werte in zwei Spalten miteinander multiplizieren und Ergebnisse davon summieren

Beitrag von Jochen41df35 » Mo, 04.06.2018 18:29

Und wie bau ich das in die Formel ein, so dass die einzelnen Zeilen sich dynamisch anpassen?

Ich kann ja wohl schlecht jede Zeile einzeln in der Formel aufzählen:

=SUMME(C2*D2)+SUMME(C3*D3)+...+SUMME(Cn*Dn)

Bei n Zeilen wären dass n mal SUMME(Cn*Cn) die ich miteinander addieren muss.

HeritzP
*****
Beiträge: 284
Registriert: So, 22.12.2013 11:23

Re: Werte in zwei Spalten miteinander multiplizieren und Ergebnisse davon summieren

Beitrag von HeritzP » Mo, 04.06.2018 19:01

Hallo,


im Prinzip so.

Code: Alles auswählen

=SUMMENPRODUKT(C2:C20;D2:D20)

Gruß HeritzP

Jochen41df35

Re: Werte in zwei Spalten miteinander multiplizieren und Ergebnisse davon summieren

Beitrag von Jochen41df35 » Di, 05.06.2018 15:56

Vielen Dank, das hat super geklappt.

Antworten