Wert aus nebenstehender Tabelle nehmen

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Benutzeravatar
hxCtYCQgSI70IdDPpFWP
**
Beiträge: 25
Registriert: Mo, 22.08.2016 16:58

Wert aus nebenstehender Tabelle nehmen

Beitrag von hxCtYCQgSI70IdDPpFWP » Mo, 29.10.2018 00:32

Ich habe eine Tabelle der Form

Kategorie prozent wert
A 20% 1,50 €
B 12% 0,50 €
C 15% 0,00 €

Daneben habe ich eine Tabelle der Form

WertVorher <WertVorher>
Kategorie <Kategorie>
Gesamt <WertVorher> * prozent_von_Kategorie

Beispiel

WertVorher <WertVorher>
Kategorie B
Gesamt <WertVorher> * 0,12

oder

WertVorher <WertVorher>
Kategorie C
Gesamt <WertVorher> * 0,15

Wie muß die Formel im Feld <WertVorher> * prozent_von_Kategorie aussehen, damit das funktioniert?

In anderen Worten: suche in der Kategorietabelle nach der Kategorie, wenn du sie findest, gebe den Prozentwert daneben aus.

echo
******
Beiträge: 764
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: Wert aus nebenstehender Tabelle nehmen

Beitrag von echo » Mo, 29.10.2018 11:28

Hallo
wenn deine "Kategorietabelle" zB. in A2:B4 steht (Suchspalte Kategorie = A ; Prozentwerte in B)
sowie die gesuchte Kategorie in G2 steht,
dann sollte ein simpler SVerweis() den %-Wert liefern:
=SVERWEIS(G2;$A$2:$B$4;2;0) * <WertVorher>

eine kleine Erweiterung unterdrückt Fehler und gibt Fehlermeldung aus:
=WENN(ZÄHLENWENN($A$2:$A$4;G2);SVERWEIS(G2;$A$2:$C$4;2;0);"Nicht gefunden")

Gruß Holger
Dateianhänge
Unbenannt 1.ods
(11.11 KiB) 23-mal heruntergeladen


Antworten