Wie auf *.95 Preis automatisch auf-/oder abrunden ?

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Gast

Wie auf *.95 Preis automatisch auf-/oder abrunden ?

Beitrag von Gast » Mo, 26.11.2018 15:20

hallo! ich habe einige euro preise und möchte diese immer auf *.95 euro auf- oder abrunden lassen. leider weiß ich nicht wie ich diese formel erzeugen kann.

vielen dank!
m.f.g.
oli

Eddy
********
Beiträge: 2582
Registriert: So, 02.10.2005 10:14

Re: Wie auf *.95 Preis automatisch auf-/oder abrunden ?

Beitrag von Eddy » Mo, 26.11.2018 15:32

Hallo Gast,

runde auf volle Beträge und ziehe davon 0,05 ab.

Bitte

Eddy

Gast

Re: Wie auf *.95 Preis automatisch auf-/oder abrunden ?

Beitrag von Gast » Mo, 26.11.2018 18:56

Servus,

von hier.
https://www.ms-office-forum.net/forum/s ... ostcount=3

Code: Alles auswählen

=GANZZAHL(A1)+(REST(A1;1)<=0,9)*0,9+(REST(A1;1)>0,9)*1,5
Gast

Gast lupo1

Re: Wie auf *.95 Preis automatisch auf-/oder abrunden ?

Beitrag von Gast lupo1 » Di, 27.11.2018 20:06

B1: =RUNDEN(A1+5%;0)-5% tut es kaufmännisch fair. Mathematisch fair wird vermutlich nicht verlangt.

Gast Peter

Re: Wie auf *.95 Preis automatisch auf-/oder abrunden ?

Beitrag von Gast Peter » Mi, 28.11.2018 09:47

Servus Gast.
Gast hat geschrieben:
Mo, 26.11.2018 18:56

Code: Alles auswählen

=GANZZAHL(A1)+(REST(A1;1)<=0,9)*0,9+(REST(A1;1)>0,9)*1,5
Rundet auf 0,5 ab oder auf 0,9 auf erfüllt aber nicht den Wunsch
Gast hat geschrieben:
Mo, 26.11.2018 15:20
ich habe einige euro preise und möchte diese immer auf *.95 euro auf- oder abrunden lasse

Gast Peter

Re: Wie auf *.95 Preis automatisch auf-/oder abrunden ?

Beitrag von Gast Peter » Mi, 28.11.2018 09:52

Guten Tag Lupo.
Gast lupo1 hat geschrieben:
Di, 27.11.2018 20:06
B1: =RUNDEN(A1+5%;0)-5% tut es kaufmännisch fair. Mathematisch fair wird vermutlich nicht verlangt.
Warum so kompliziert?
Wie von Eddy bereits vorgeschlagen tut es

Code: Alles auswählen

=RUNDEN(A1;0)-0,05
genau so.

5% wird von Calc ohnehin in 0,05 umgewandelt und wozu A1+5%?

Gast lupo1

Re: Wie auf *.95 Preis automatisch auf-/oder abrunden ?

Beitrag von Gast lupo1 » Mi, 28.11.2018 22:59

Hallo Eddy,

wenn Du mich kommentierst, solltest Du meinen ganzen Beitrag zuerst verstehen. Ich habe extra das Stilmittel fett verwendet. Das bedeutet, dass die entspr. Passage eine entscheidende Rolle für meine Formel spielt.

Bin gespannt, ob Du es jetzt überprüfst und ich nicht noch einmal schreiben muss, oder ob ich für Dich noch mit einem Beispiel kommen muss.

quotsi
*****
Beiträge: 266
Registriert: Do, 14.11.2013 10:04

Re: Wie auf *.95 Preis automatisch auf-/oder abrunden ?

Beitrag von quotsi » Do, 29.11.2018 10:18

Jetzt antworte ich mal ganz frech:
Was ist kaufmännisch fair (Definition)?
Das ist nicht allgemein bekannt.
win7prof - Avira - LO 6.1.3.2 (x64) - AOO 4.1.5

Stephan
********
Beiträge: 10679
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Wie auf *.95 Preis automatisch auf-/oder abrunden ?

Beitrag von Stephan » Do, 29.11.2018 11:11

Bin gespannt, ob Du es jetzt überprüfst und ich nicht noch einmal schreiben muss, oder ob ich für Dich noch mit einem Beispiel kommen muss.
Es brauchte imho eine Begründung der Zweckmäßigkeit Deiner Art der Verwendung kaufmännischen Rundens im Konkreten, denn eigentlich geht es beim kaufmännischen Runden um das Intervall 0,01 und es scheint mir völlig unüblich das auf 0,95 zu übertragen, auch wenn es mir rechen-formal verständlich ist.

Natürlich ist bei Geldbeträgen das kaufmännische Runden relevant, aber doch in normaler Form und nicht in abstrakter Übertragung auf 0,95. Du hast hier eine interessante Variante des Rundens angesprochen, aber es bedarf imho doch keines Streits welche hier die 'bessere' oder 'relevantere' Art des Rundens ist.



Gruß
Stephan

Benutzeravatar
balu
********
Beiträge: 3682
Registriert: Fr, 24.08.2007 00:28
Wohnort: Warstein

Re: Wie auf *.95 Preis automatisch auf-/oder abrunden ?

Beitrag von balu » Do, 29.11.2018 11:14

Moin moin.

Wer wird denn sich hier gleich wieder in die Haare kriegen wollen? ;-)

Gast (oli) hat geschrieben: möchte diese immer auf *.95 euro auf- oder abrunden lassen.
Das sagt wohl so einiges, aber es sagt auch nicht alles. Und erst wenn 'Gast oli' sich wirklich festgelegt hat, könnt ihr Euch um die passende Formel streiten.

Ich sehe da nämlich folgendes kleines Problem.
Wenn immer auf *.95 gerundet werden soll, was geschieht denn beispielsweise bei einem Betrag von 6,01 €? Soll dann
- auf 5,95 €
oder
- auf 6,95 €
gerundet werden?

Oder wie sieht das bei 6,49 € aus?
Will 'Gast oli' dann kaufmännisch Runden, dann wäre wohl

Code: Alles auswählen

=RUNDEN(A1+0,05;0)-0,05
mit dem Ergebnis von 6,95 € Okay.

Oder will er "nach eigenem Gusto" auf 5,95 € Runden, dann wäre

Code: Alles auswählen

=RUNDEN(A1;0)-0,05
angesagt.

Ab welchen Nachkommastellenwert soll also Auf- beziehungsweise Abgerundet werden?



Gruß
balu
Sei öfter mal ein Faultier, sag öfter mal "Ach was!" Dann kriegst du keinen Herzinfarkt, und hast ne menge Spass.

wehr rächtschraipfähler findet khan si behalden :D

Stephan
********
Beiträge: 10679
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Wie auf *.95 Preis automatisch auf-/oder abrunden ?

Beitrag von Stephan » Do, 29.11.2018 11:27

Ab welchen Nachkommastellenwert soll also Auf- beziehungsweise Abgerundet werden?
z.B. siehe:
https://de.wikipedia.org/wiki/Rundung


Gruß
Stephan

Benutzeravatar
balu
********
Beiträge: 3682
Registriert: Fr, 24.08.2007 00:28
Wohnort: Warstein

Re: Wie auf *.95 Preis automatisch auf-/oder abrunden ?

Beitrag von balu » Do, 29.11.2018 12:14

Hallo Stephan,

mir gehts nicht darum wie man ab wann Rundet, sondern wie 'Gast oli' das haben will. Er hat sich nicht dazu geäußert ob er es kaufmännisch oder Mathematisch korrekt haben will, oder nach seiner eigenen Regel.



Gruß
balu
Sei öfter mal ein Faultier, sag öfter mal "Ach was!" Dann kriegst du keinen Herzinfarkt, und hast ne menge Spass.

wehr rächtschraipfähler findet khan si behalden :D

Gast Peter

Re: Wie auf *.95 Preis automatisch auf-/oder abrunden ?

Beitrag von Gast Peter » Do, 29.11.2018 12:24

Guten Tag Lupo.
Es war nicht Eddy und meine Frage war ernst gemeint.

Es geht nicht darum, dass die fett gedruckten Textteile elementar für Deine Formel sind, sondern warum Du der Meinung bist, dass es notwendig ist, deine "faire" Formel anzuwenden.

Calc rundet standardmäßig "kaufmännisch" und aus meiner Sicht für den angefragten Zweck ausreichend.

Bei Deiner "kaufmännisch fairen" Formel wird 1,45 bereits auf 2 aufgerundet
Bei meiner "standard" Formel wird 1,45 auf 1 abgerundet und erst ab 1,5 auf 2.

Für mich handelt sich bei der Anfangsfrage um Schwellenpreise, die ohnehin nicht fair sind, sondern rein der Verkaufsförderung dienen und daher verhältnismäßig willkürlich festgelegt werden. Im Prinzip kann alles was über 1,0 liegt ebensogut auf 1,95 aufgerundet werden. Wenn man meint es ließe sich so verkaufen.

Es geht also nicht um "fair" sondern um eine kaufmännische Mischkaltulation, bei der einige Preise werbewirksam abgepreist werden um Kunden zu locken und andere Preise dafür aufgepreist werden, um die Kosten insgesamt zu decken.


Mir ist daher nicht ersichtlich, welchen Sinn es bei rein willkürlich festgelegten Preisschwellen macht deine "kaufmännisch faire" Rundungsformel anzuwenden.

Gast lupo1

Re: Wie auf *.95 Preis automatisch auf-/oder abrunden ?

Beitrag von Gast lupo1 » Do, 29.11.2018 13:16

  • Peter statt Edding - habs gesehen, aber als Gast kann man nicht editieren, und für sowas schreibe ich nix hinterher
  • Viele Antworten, die nicht auf den Kern gehen
  • 5% - darüber diskutiert ein Excelaner nun mal nicht! Akzeptieren. Dumm sterben. Irrelevant.
Wie vorausgeahnt nun das Beispiel:

A1:A8: 3,44 bis 3,51
B1: =RUNDEN(A1+5%;0)-5%
C1: =RUNDEN(A1;0)-0,05

Na, zappelt es im Karton, was faires Runden (im Sinne einer statischen Korrektzuordnung) ist? Bei Eddings Formel würde der Kunde bevorzugt; meine rundet hingegen für Händler und Kunde bei massenhaft vorhandenen Preisen neutral.

Gast Peter

Re: Wie auf *.95 Preis automatisch auf-/oder abrunden ?

Beitrag von Gast Peter » Do, 29.11.2018 15:48

Gast lupo1 hat geschrieben:
Do, 29.11.2018 13:16
5% - darüber diskutiert ein Excelaner nun mal nicht! Akzeptieren. Dumm sterben. Irrelevant.
Ob Du dumm stirbst ist allein Deine Entscheidung und hat mit Excel nichts zu tun.
Gast lupo1 hat geschrieben:
Do, 29.11.2018 13:16
Wie vorausgeahnt nun das Beispiel:
Wo ist die Neuigkeit/Überraschung?
Gast lupo1 hat geschrieben:
Do, 29.11.2018 13:16
Bei Eddings Formel würde der Kunde bevorzugt; meine rundet hingegen für Händler und Kunde bei massenhaft vorhandenen Preisen neutral.
Nein, das hängt von den tatsächlich vorhandenen Preisen/Werten ab.

Antworten