[GELÖST] Datum, Syntax Problem

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Teufelskomet_1
**
Beiträge: 27
Registriert: So, 09.06.2019 12:40

[GELÖST] Datum, Syntax Problem

Beitrag von Teufelskomet_1 » Do, 20.06.2019 17:47

Hallo,
ich schon wieder. Diesmal habe ich ein Syntax-Problem bei der Funktion ZÄHLENWENNS

In der Spalte C steht das Datum, formatiert als TT.MMM. In der Spalte D steht der Behälter B211...B241 als Text. Ich möchte nun zählen wie häufig der Behälter B211 in der Spalte B vorkommt im gesamten Monat Mai.

=ZÄHLENWENNS(C12:C34;F6;D12:D34;"B211")

In Zelle F6 steht das Suchkriterium, sollte Mai sein. Hier ist das Problem. Zwar kann ich als Format für F6 MMMM nehmen. Aber dann wird keine Übereinstimmung gefunden. Mit einem konkreten Datum wie 23.05.2019 funktioniert es.
Gibt es Wildcards für die Tage z.B. **.MMM. Die Varainte habe ich probiert, hat nicht funktioniert.

Gruß
Teufelskomet
Dateianhänge
Datumsproblem.ods
(12.05 KiB) 17-mal heruntergeladen
Zuletzt geändert von Teufelskomet_1 am Do, 20.06.2019 19:15, insgesamt 1-mal geändert.

Mondblatt24
*****
Beiträge: 425
Registriert: So, 14.05.2017 16:11

Re: Datum, Syntax Problem

Beitrag von Mondblatt24 » Do, 20.06.2019 18:10

Hallo,
Formel in F7:
=SUMMENPRODUKT(MONAT($C$12:$C$34)=MONAT($F$6);$D$12:$D$34=$E7)

Gruß Peter
Win.10 (x64)__ LO 6.2.5 (x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden. Anleitung

Teufelskomet_1
**
Beiträge: 27
Registriert: So, 09.06.2019 12:40

Re: Datum, Syntax Problem

Beitrag von Teufelskomet_1 » Do, 20.06.2019 19:14

Hallo Mondblatt,
auf SUMMENPRODUKT als Lösung wäre ich niemals gekommen.

Vielen Dank

Antworten