Seite 1 von 1

[GELÖST] Summe, wenn entsprechende Wert in anderer Tabelle enthalten

Verfasst: Di, 05.11.2019 22:46
von RalfE
Hallo,
ich stehe gerade etwas auf dem Schlauch und komme bei einem Problem gerade nicht weiter:
Summe der Werte einer Tabelle, wenn das dort in der gleichen Zeile angegebene Datum in einer zweiten Tabelle enthalten ist....

Tabellen 1:
Datum1 3
Datum2 4
Datum3 9
Datum4 23
Datum5 55


Tabelle2:
Datum2 AAA
Datum4 BBB
Datum6 CCC

Nun soll die Summe der WerteX der Tabelle 1 ermittelt werden, für die ein entsprechendes Datum in Tabelle 2 enthalten ist.
Geht das auch irgendwie auch ohne eine Hilfsspalte in Tabelle 1?

(Ergebnis: 27)

LG
Ralf

Re: Summe, wenn entsprechende Wert in anderer Tabelle enthalten

Verfasst: Mi, 06.11.2019 07:31
von Mondblatt24
Hallo,
Du schreibst ja selbst welche Funktion Du brauchst, nämlich Summewenn().
In diesem Video wird die Funktion erklärt.

Gruß Peter

Re: Summe, wenn entsprechende Wert in anderer Tabelle enthalten

Verfasst: Mi, 06.11.2019 23:38
von RalfE
Genau die Funktion funktioniert leider nicht (zumindest bei mir). SUMMEWENN (und auch SUMMEWENNS) akzeptiert da leider nur einen Wert (Entweder direkt oder als Verweis), mit dem die Werte in der Datumsspalte der 1. Tabelle dann verglichen werden.

Was ich brauche, ist eine Funktion, die alle Datumswerte in Spalte 1 der 1. Tabelle mit allen Datumswerten in Spalte 1 der zweiten Tabelle vergleicht und dann jeden die Werte in Spalte 2 der Tabelle 1 Summiert, bei denen der entsprechende Datumswert irgendwo in der zweiten Tabelle vorkommt.

Ich hoffe, ich habe das jetzt verständlich beschrieben....

LG
Ralf

Re: Summe, wenn entsprechende Wert in anderer Tabelle enthalten

Verfasst: Do, 07.11.2019 06:46
von Mondblatt24
Hallo,
Ich hoffe, ich habe das jetzt verständlich beschrieben....
erstelle bitte eine Beispieldatei (kein Screenshot) und hänge sie hier an.

Gruß Peter

Re: Summe, wenn entsprechende Wert in anderer Tabelle enthalten

Verfasst: Do, 07.11.2019 07:02
von paljass
Moin,

Code: Alles auswählen

=SUMMENPRODUKT(Tabelle1.A1:A10=A1:A10;Tabelle1.B1:B10)
Spalte A = Datum
Spalte B = Werte

Gruß
paljass

Re: Summe, wenn entsprechende Wert in anderer Tabelle enthalten

Verfasst: Do, 07.11.2019 08:42
von RalfE
Dabei findet leider überhaupt kein Vergleich mit den Werten aus Tabelle 2 statt......

Ich glaube aber, ich hab was passendes gefunden, muss ich aber erst noch ausprobieren: DBSUMME

Re: Summe, wenn entsprechende Wert in anderer Tabelle enthalten

Verfasst: Do, 07.11.2019 08:47
von mikeleb
Hallo,

Code: Alles auswählen

=SUMMENPRODUKT(ZÄHLENWENN(Tabelle2.A1:A4;Tabelle1.A1:A8);Tabelle1.B1:B8)

Re: Summe, wenn entsprechende Wert in anderer Tabelle enthalten

Verfasst: Do, 07.11.2019 08:58
von Mondblatt24
RalfE hat geschrieben:
Do, 07.11.2019 08:42
Dabei findet leider überhaupt kein Vergleich mit den Werten aus Tabelle 2 statt......

Ich glaube aber, ich hab was passendes gefunden, muss ich aber erst noch ausprobieren: DBSUMME
auf welchen Beitrag bezieht sich diese Aussage?

Hier noch eine Matrixformel als mögliche Lösung:

Code: Alles auswählen

=SUMMENPRODUKT((A1:A16=MTRANS($Tabelle2.A1:A16))*(B1:B16))
Eingabe mit Strg+Shift+Enter abschließen.

Gruß Peter

Re: Summe, wenn entsprechende Wert in anderer Tabelle enthalten

Verfasst: Do, 07.11.2019 09:14
von RalfE
Danke habs ausprobiert, funktionieren beide Lösungen mit SUMMENPRODUKT.....
Mit DBSUMME gehts auch:

Code: Alles auswählen

=DBSUMME(Tabelle1.A1:A8;Tabelle1.B1;Tabelle2.A1:A6)
wobei da die Bereiche die Spaltenüberschriften einschließen und für die zu vergleichenden Spalten identisch sein müssen (Tabelle1.A1 = Tabelle2.A1)


..viel Wege führen zum Ziel