Allgemeiner Ein-/undAusgabefehler

Setup und Komponenten-übergreifende Probleme.

Moderator: Moderatoren

Abla

Allgemeiner Ein-/undAusgabefehler

Beitrag von Abla » Mo, 17.11.2014 12:23

Liebe Helfenden,

ich bekomme folgende Fehlermeldung, wenn ich OO öffne (Ich habe noch die 3.3-Version):

"Fehler beim Laden des BASIC des Dokuments
file:///C:/users/Benutzer/AppData/Roaming/OpenOffice.org/3/users/basic/dialog.xlc/:
Allgemeiner Fehler.
Allgemeiner Ein-/Ausgabefehler."

Ich klicke dann auf "Schließen", voraufhin die Meldung nochmal erscheint und ich nochmals auf "Schließen" klicke, danach läuft OO (bisher) ohne Probleme.

Gravierender ist daher folgendes Problem:

Wenn ich die neue Version 4.1.1. installieren möchte (oder über die Systemsteuerung 3.3 deinstallieren oder reparieren möchte), erhalte ich irgendwann diese Fehlermeldung:

"Bitte beenden Sie OpenOffice.org 3.3 und den OpenOffice.org 3.3-Schnellstarter, bevor Sie fortfahren. Wenn Sie ein Mehrbenutzersystem [...]"

Ich benutze kein Mehrbenutzersystem, im Taskmanager sind (meiner Meinung nach) alle relevanten Prozesse beendet.

1. Frage: Was genau ist der Schnellstarter? Woran erkenne ich, ob dieser aktiv/geöffnet ist?

Hintergrundinformation: Den Ordner "AppData" gibt es bei mir - jedenfalls an dem angegebenen Ort - nicht. Ich muss zugeben, dass es sein kann, dass ich diesen in einem Aufräumwahn einfach mal ahnungslos gelöscht habe.

2. Frage: Kann ich diesen Ordner wieder herstellen?
3. Frage: Hängen beide Probleme zusammen?
4. Frage: Wie bekomme ich es andernfalls hin, das Programm einfach zu löschen und die neue Version komplett neu zu installieren?

In hoffnungsvoller Erwartung eurer Antworten und vorab schon großer Dankbarkeit

hylli
*******
Beiträge: 1627
Registriert: Mi, 22.02.2006 19:37

Re: Allgemeiner Ein-/undAusgabefehler

Beitrag von hylli » Mo, 17.11.2014 16:02

zu 1.: Den Schnellstarter erkennst Du an dem Symbol rechts unten im Systray (unter Windows!). Alternativ erkennst Du diesen auch, wenn OpenOffice Deines erachtens geschlossen ist und Du im Taskmanager im Reiter Prozesse folgende Prozesse vorfindest: soffice.bin und/oder soffice.exe.

zu 2.: Der Ordner AppData ist vermutlich versteckt. Um diesen sichtbar zu machen, kannst Du bei geöffnetem Laufwerk C: -> Organisieren -> Ordner- und Suchoptionen -> Ansicht die entsprechende Option "Ausgeblendete Dateien, Ordner und Laufwerke anzeigen" aktivieren.

zu 3.: Glaube ich nicht!

zu 4.: Alle Prozesse "soffice.bin" und "soffice.exe" im Taskmanager beenden, anschließend sollte sich OpenOffice problemlos installieren lassen.

Wenn allerdings das Benutzerverzeichnis korrupt ist, solltest Du dieses gegebenenfalls löschen oder zumindest umbenennen:
http://www.ooowiki.de/BenutzerVerzeichn ... eichnis.3F

Hylli
Ein Dankeschön für eine Lösung tut nicht weh!
Wer eine Lösung selbst findet, sollte die für die Nachwelt auch posten!

Geschäftlich: LibreOffice 5.1.x ("Still") unter Windows 7 32/64bit
Privat: LibreOffice 5.x unter Linux Mint 18.x Cinnamon 64bit u. Arch Anywhere "Mate"

pmoegenb
********
Beiträge: 4331
Registriert: Di, 22.06.2004 12:02
Wohnort: 71134 Aidlingen
Kontaktdaten:

Re: Allgemeiner Ein-/undAusgabefehler

Beitrag von pmoegenb » Mo, 17.11.2014 16:02

Abla hat geschrieben:Wenn ich die neue Version 4.1.1. installieren möchte (oder über die Systemsteuerung 3.3 deinstallieren oder reparieren möchte), erhalte ich irgendwann diese Fehlermeldung:
"Bitte beenden Sie OpenOffice.org 3.3 und den OpenOffice.org 3.3-Schnellstarter, bevor Sie fortfahren. Wenn Sie ein Mehrbenutzersystem [...]"
Ich benutze kein Mehrbenutzersystem, im Taskmanager sind (meiner Meinung nach) alle relevanten Prozesse beendet.
1. Frage: Was genau ist der Schnellstarter? Woran erkenne ich, ob dieser aktiv/geöffnet ist?
Die Prozesse
  • soffice.bin *32
    soffice.exe *32
müssen beendet sein.
Abla hat geschrieben: Hintergrundinformation: Den Ordner "AppData" gibt es bei mir - jedenfalls an dem angegebenen Ort - nicht. Ich muss zugeben, dass es sein kann, dass ich diesen in einem Aufräumwahn einfach mal ahnungslos gelöscht habe.
2. Frage: Kann ich diesen Ordner wieder herstellen?
Ich vermute mal Du hast Windows Vista oder höher.

Bei gelöschten Ordner \AppData würde Deine System insgesamt nicht mehr funktionieren.
Abla hat geschrieben: 3. Frage: Hängen beide Probleme zusammen?
Nein
Abla hat geschrieben: 4. Frage: Wie bekomme ich es andernfalls hin, das Programm einfach zu löschen und die neue Version komplett neu zu installieren?
Man muss keine ältere Version löschen, wenn man eine neuere Version installiert. Die Setup-Routine macht das von sich aus.

Des Weiteren vermute ich, dass Dein Benutzerverzeichnis versaut ist. Benenne dieses um, dann bist Du sehr wahrscheinlich das Problem los.
Du gelangst zu dem versteckten Verzeichnis C:\Users\%USERNAME%\AppData\Roaming wie folgt:
  • - Win + r drücken.
    - %appdata% eingeben.
    - Eingabetaste drücken oder auf OK-Schalter klicken.
Gruß

Peter
---------------------------------------------------------------------------
Windows 7 Prof. 64-bit SP1, LibreOffice 4.3.6.2 und AOO 4.1.1

gast freedom

Re: Allgemeiner Ein-/undAusgabefehler

Beitrag von gast freedom » Mo, 17.11.2014 16:03

Hallo,

deinem Beitrag ist anzusehen, dass du weder die Suchfunktion des Forums,
noch eine Suchmaschine benutzt hast.
"Fehler beim Laden des BASIC des Dokuments
file:///C:/users/Benutzer/AppData/Roaming/OpenOffice.org/3/users/basic/dialog.xlc/:
Allgemeiner Fehler.
Allgemeiner Ein-/Ausgabefehler."
viewtopic.php?f=9&t=52890&p=198749&hili ... lc#p198749
viewtopic.php?f=9&t=51339&p=190509&hili ... lc#p190509
im Taskmanager sind (meiner Meinung nach) alle relevanten Prozesse beendet.
Rethorische Frage: Was genau ist deine Meinung dazu?

Fakt ist, dass diese Prozesse soffice.bin und soffice.exe heißen.
das Programm einfach zu löschen
Hoffentlich meinst du das nicht ernst. Programme werden nicht gelöscht, sondern deinstalliert.

Abla
Beiträge: 2
Registriert: Mo, 17.11.2014 12:32

Re: Allgemeiner Ein-/undAusgabefehler

Beitrag von Abla » Di, 18.11.2014 00:30

Wow, vielen Dank erstmal für die schnellen, hilfreichen Antworten. Mit eurer Hilfe konnte ich jetzt herausfinden, dass tatsächlich alle relevanten Prozesse beendet sind sowie den Ordner AppData finden.

Nur um mich zu vergewissern (Ich interpretiere aus dem Umstand, dass der Ordner versteckt ist, dass man da womöglich Mist bauen kann, wenn man was falsch macht): Das Benutzerverzeichnis umbennen tue ich, indem ich einfach den Ordner "AppData/Roaming/OpenOffice.org/3/user" z.B. in "AppData/Roaming/OpenOffice.org/3/abla" manuell umbenenne, richtig?
Ich vermute mal Du hast Windows Vista oder höher.
Ich habe Windows 7. Das ändert doch nichts an euren Ratschlägen, oder?
deinem Beitrag ist anzusehen, dass du weder die Suchfunktion des Forums,
noch eine Suchmaschine benutzt hast.

"Fehler beim Laden des BASIC des Dokuments
file:///C:/users/Benutzer/AppData/Roaming/OpenOffice.org/3/users/basic/dialog.xlc/:
Allgemeiner Fehler.
Allgemeiner Ein-/Ausgabefehler."


viewtopic.php?f=9&t=52890&p=198749&hilit=dialog.xlc#p198749
Wie auch der user "lodar" in diesem Link, war mir leider nicht bewusst, dass ich nach "dialog.xlc" hätte suchen müssen. Sollten hierdurch Unannehmlichkeiten entstanden sein, bitte ich meine Unwissenheit zu entschuldigen.
Rethorische Frage: Was genau ist deine Meinung dazu?
Durch das rhetorische Stilmittel des Zusatzes "meiner Meinung nach" wollte ich verdeutlichen, dass ich es mir durchaus vorstellen kann, dass ich - ahnungslos wie ich bin - nicht weiß, welche Prozesse von Relevanz sind. Ich halte es mit meiner informationstechnologischen Unwissenheit wie Sokrates - diese ist mir bewusst und ich verschleiere sie nicht, wenn ich Mehr- und Besserwissende um Rat frage. Mit der Vorstellung lag ich ja offensichtlich auch richtig; hatte ich eben im Taskmanager nicht nach den Prozessen soffice.bin und soffice.exe gesucht.
Hoffentlich meinst du das nicht ernst. Programme werden nicht gelöscht, sondern deinstalliert.
Wiederum bitte ich meine laienhafte Ausdrucksweise zu entschuldigen. Stellen Sie sich vor, ich meinte das tatsächlich ernst. Ich lasse mich aber immer gerne eines Besseren belehren. Ein solcher Fauxpas wird mir künftig hoffentlich nicht mehr unterlaufen.

Dankbare und friedliche Grüße

hylli
*******
Beiträge: 1627
Registriert: Mi, 22.02.2006 19:37

Re: Allgemeiner Ein-/undAusgabefehler

Beitrag von hylli » Di, 18.11.2014 07:41

Ja, genau wie Du oben geschrieben hast einfach das Verzeichnis "user" umbenennen, und AOO neu starten.

Hylli
Ein Dankeschön für eine Lösung tut nicht weh!
Wer eine Lösung selbst findet, sollte die für die Nachwelt auch posten!

Geschäftlich: LibreOffice 5.1.x ("Still") unter Windows 7 32/64bit
Privat: LibreOffice 5.x unter Linux Mint 18.x Cinnamon 64bit u. Arch Anywhere "Mate"

Abla
Beiträge: 2
Registriert: Mo, 17.11.2014 12:32

Re: Allgemeiner Ein-/undAusgabefehler

Beitrag von Abla » Di, 18.11.2014 12:31

Wunderbar, alte Version lief wieder einwandfrei und Aktualisierung funktionierte auch ohne Probleme.
Danke, danke, danke!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 7 Gäste