Tabellenfeld und Formularfeld zeigen Daten unterschiedlich an

Datenbanklösungen mit AOO/LO

Moderator: Moderatoren

Earl
*
Beiträge: 17
Registriert: Di, 19.06.2012 13:33

Tabellenfeld und Formularfeld zeigen Daten unterschiedlich an

Beitrag von Earl » Mo, 24.10.2016 18:47

Hallo,
Ich habe in BASE eine Datenbanktabelle angelegt mit einem Uhrzeit-Feld (u.A.).
Das Zeitformat ist 00:00:00.
Wenn ich in diesem Feld die Uhrzeit eingebe. wird sie auch korrekt angezeigt.

Weiterhin habe ich ein Formular aus den gleichen Feldern erstellt, wie sie in der Tabelle angelegt sind.
Hier werden mir die Uhrzeiten jedoch ohne die Sekunden anezeigt.
Ich finde leider nicht heraus wo der Unterschied ist.
Könnt ihr mir helfen?

Gruß
Earl

RobertG
*******
Beiträge: 1735
Registriert: Fr, 13.04.2012 19:28
Kontaktdaten:

Re: Tabellenfeld und Formularfeld zeigen Daten unterschiedlich an

Beitrag von RobertG » Mo, 24.10.2016 19:24

Hallo Earl,

wenn Du auch die Sekunden angezeigt bekommen willst, dann musst Du das Feld entsprechend formatieren. Die Formatierung aus der Tabelle wird nicht automatisch in ein Formular übernommen.
Formular zum Bearbeiten (nicht zur Dateneingabe) öffnen.
Formularfeld markieren (geht manchmal nicht direkt, da es mit der Überschrift für das Feld gruppiert ist - Gruppierung betreten).
Rechte Maustaste und Feldeigenschaften bearbeiten.
Im Reiter "Allgemein" findest Du die die Möglichkeit, das "Zeitformat" entsprechend einzustellen.

Hast Du statt eines einzelnen Formularfeldes ein Tabellenkontrollfeld genommen, so musst Du beim Bearbeiten mit der Maus auf den entsprechenden Spaltenkopf der Tabelle klicken.

Gruß

Robert

Earl
*
Beiträge: 17
Registriert: Di, 19.06.2012 13:33

Re: Tabellenfeld und Formularfeld zeigen Daten unterschiedlich an

Beitrag von Earl » Di, 25.10.2016 12:56

Hallo Robert,
Danke für die ausführliche Antwort. Hat auf Anhieb geklappt.
Da muss man als Einsteiger aber erstmal drauf kommen.

Allerdings wurde die Formatierung des Datums aus der Tabelle korrekt ins Formular übernommen.
Also: Mal so und mal so. Merkwürdig.

Gruß
Earl

RobertG
*******
Beiträge: 1735
Registriert: Fr, 13.04.2012 19:28
Kontaktdaten:

Re: Tabellenfeld und Formularfeld zeigen Daten unterschiedlich an

Beitrag von RobertG » Di, 25.10.2016 16:06

Hallo Earl,

die Formatierung des Datums ist in Tabelle und Formular nur zufällig gleich gesetzt. Sie kann auch in der Tabelle ohne Probleme anders sein als im Formular. Intern gespeichert wird das sowieso beim Datum über das Format '2016-10-25' - aber das benutzt weder die Tabelle noch das Formular.

Eventuell wäre es eine gewünschte Erweiterung, dass das Formular erst einmal die Formatierung aus der Datengrundlage der definierten Tabelle übernimmt und anschließend anders formatiert werden kann. Mal sehen, ob ich für so etwas auf der LO-Bugliste eine entsprechende Meldung weitergebe.

Nachtrag: Ich habe das als Enhancement-Anfrage aufgegeben: https://bugs.documentfoundation.org/sho ... ?id=103497

Gruß

Robert

Antworten