[gelöst] Tabellen sind weg

Datenbanklösungen mit AOO/LO

Moderator: Moderatoren

it-frosch
*
Beiträge: 14
Registriert: Fr, 09.09.2005 12:58
Wohnort: Leipzig

[gelöst] Tabellen sind weg

Beitrag von it-frosch » So, 30.07.2006 16:18

Hallo,

ich habe unter ubuntu 6.06 mit OO 2.02 eine Base DB mit 15 Tabellen erstellt die Beziehungen zwischen den Tabellen definiert, ein Formular entworfen und das ganze gespeichert und auf einen USB Stick kopiert, um auf einem anderen Rechner die DB weiter zu bearbeiten.

Auf dem zweiten Rechner ist WinXP mit OO 2.0x installiert.
Wenn ich die vom USB Stick auf den Rechner kopierte DB öffne existiert nur noch das Formular. Alle Tabelle sind weg.

Auf einem anderen Linuxrechner (Ubuntu 6.06 + OO 2.0x) konnte ich die kopierte DB ohne Probleme öffnen und es waren auch alle Tabellen vorhanden.

Das ist mir jetzt schon zum zweiten Mal passiert.

Hat jemand ähnliche Erfahrungen gemacht oder weiß jemand den Grund für das Verhalten?
Zuletzt geändert von it-frosch am Fr, 04.08.2006 15:03, insgesamt 1-mal geändert.
es grüßt und dankt der IT-Frosch

WinXP - JRE 5.0 Update 6 | Ubuntu 6.06 - JRE 1.4.2 | Openoffice 2.0.2

qmmuffel
**
Beiträge: 34
Registriert: Sa, 10.06.2006 18:19

Tabellen sind weg

Beitrag von qmmuffel » Mo, 31.07.2006 20:58

Hallo IT-Frosch,
welche Dateiendung hat Deine DB auf dem Stick ?
Wie hast Du Deine DB gebaut: HSQL oder Verbindung zu einer anderen DB ?
Gruß
Wolfgang
SUSE-Linux 9.0, KDE 3.1, JRE 1.4.2; Win98SE, JRE 1.4.2_12; OpenOffice 2.0.3

it-frosch
*
Beiträge: 14
Registriert: Fr, 09.09.2005 12:58
Wohnort: Leipzig

Beitrag von it-frosch » Mo, 31.07.2006 23:45

Hallo qmmuffel,

es ist eine HSQL DB. Die Dateiendung ist odb.
es grüßt und dankt der IT-Frosch

WinXP - JRE 5.0 Update 6 | Ubuntu 6.06 - JRE 1.4.2 | Openoffice 2.0.2

qmmuffel
**
Beiträge: 34
Registriert: Sa, 10.06.2006 18:19

Tabellen sind weg

Beitrag von qmmuffel » Di, 01.08.2006 19:19

Hallo it-frosch,
das hört sich ja mysteriös an ...
- Wie ist Dein Stick formatiert ? Wenn NTFS beteiligt ist: kannst Du das Ganze mal auf einem Windows-FAT-Dateisystem testen.

- Verändert sich die Größe der Datei ?

- Versuch doch mal die odb über ein Packprogramm auf Deinen Stick zu kopieren und dann unter Win zu öffnen

- Unter Linux kannst Du mit dem Befehl md5sum -b <datei> eine Prüfsumme der Datei bilden und unter Windows gibt es das Tool MD5-Summer (Generator + Checker) unter
http://www.md5summer.org/
Mit diesem Tool kannst Du unter Win die Prüfsumme der Datei auf Deinem Win-PC auslesen. Beide Prüfsummen müssen gleich sein, wenn die Datei unverändert ist.

Gruß
Wolfgang
SUSE-Linux 9.0, KDE 3.1, JRE 1.4.2; Win98SE, JRE 1.4.2_12; OpenOffice 2.0.3

it-frosch
*
Beiträge: 14
Registriert: Fr, 09.09.2005 12:58
Wohnort: Leipzig

Beitrag von it-frosch » Mi, 02.08.2006 11:11

Hallo Wolfgang,

danke erst einmal für die Hilfe. ;-)

Der USB Stick ist mit FAT formatiert.
Ich habe das Ganze jetzt mal auf dem einem anderen Win-PC ausprobiert.
Die MD5 Summen von der DB (auf Linux, auf dem Stick, auf Win-PC) habe ich geprüft. Sie sind identisch.

Ich kann auf diesem Win-PC die DB mit allen Tabellen auch öffnen. ;-)

Das werde ich heute noch mal auf dem ursprünglichen Win-PC testen.
Wahrscheinlich ist auf dem irgend etwas mysterös.
Mal schauen.
es grüßt und dankt der IT-Frosch

WinXP - JRE 5.0 Update 6 | Ubuntu 6.06 - JRE 1.4.2 | Openoffice 2.0.2

it-frosch
*
Beiträge: 14
Registriert: Fr, 09.09.2005 12:58
Wohnort: Leipzig

Beitrag von it-frosch » Fr, 04.08.2006 15:03

Auf dem mysteriösen Win-XP Rechner war doch noch die OO Version 2.0.
Nach Installation der aktuellen Version 2.0.3 war der Effekt verschwunden.
Ich kann die DB vom USB Stick kopieren und alle Tabellen sind vorhanden.
es grüßt und dankt der IT-Frosch

WinXP - JRE 5.0 Update 6 | Ubuntu 6.06 - JRE 1.4.2 | Openoffice 2.0.2

Antworten