Vorformulierte Formeln benutzen

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

echo
******
Beiträge: 751
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: Vorformulierte Formeln benutzen

Beitrag von echo » Sa, 21.07.2018 16:16

Hallo, schön das es funktioniert und danke füs Feedback
Weil es dazu passt, ein kleiner Nachtrag noch zu einer sehr oft verwendeten Kombination: Index() und Vergleich()

=SVERWEIS(A2;$U$2:$AB$21;VERGLEICH(I2;$V$1:$AB$1;1)+1;1)
In deiner Formel sucht Vergleich() nach der richtigen Spalte, der SVerweis() durchsucht Spalte U und stellt die richtige Zeile ein.
aber angenommen die Suchspalte vom SVerweis() ist nicht ganz links in der Tabelle oder steht sogar ganz wo anders (ZB. Liste für PullDownMenü) dann gibt es ein Problem die gesuchte Zeile einzustellen.

Lösung: Index:
Sverweis() möchte die Spalte eingestellt haben,
Index sucht gar nicht selbst und möchte sowohl die Zeile wie auch ggf. die Spalte eingestellt haben, um eine Zelle aus der Matrix anzuzeigen.
das Vergleich() das kann haben wir ja schon gesehen, also Vergleich doppelt, ein mal für die Zeile, ein mal für die Spalte.
=INDEX($V$2:$AB$21;VERGLEICH(A2;$U$2:$U$21;1);VERGLEICH(I2;$V$1:$AB$1;1))
Nur Daten ohne Suchzeile/Suchspalte : $V$2:$AB$21
Suchspalte: $U$2:$U$21
Suchzeile: $V$1:$AB$1
Der erste Vergleich sucht nach der Zeile, der zweite Vergleich nach der Spalte.
Beide Formeln SVerweis... und Index... liefern das gleiche Ergebnis, mit dem Unterschied, das die Suchspalte extra in der Formel steht. Die Suchspalte kann jetzt also beliebig eingestellt werden, und muss nicht zwingend ganz links in der Matrix stehen. :)
Gruß Holger

Antworten